在线检测未来函数

通达信买卖分析主图指标公式

来源:Internet,编辑:股旁网,2015-07-23

线:MA(C,20),DOTLINE;{这是假设的参与依据}
买入条件:=CROSS(C,MA(C,20));{可根据自己的选股条件,也可以是N个的组合,我是为了方便把上穿20日线作为买入标准}
DRAWICON(买入条件,L*0.98,1);{这是在买入条件成立的情况下,在当日K线下方用红箭头表示买入信号}
价格1:=IF(买入条件,C,DRAWNULL);{这是在买入条件成立的情况下,以当日收盘价作为买入成交价}
DRAWNUMBER(买入条件,L*0.96,价格1),COLORLIRED;{这是在买入条件成立的情况下,在当日最低价下方标出买入成交价,颜色粉红}
卖出条件:=CROSS(MA(C,20),C);{这是假设的卖出条件成立,各位可根据自己的止盈止损条件设立,我这是为了做指标,把下穿20日线作为卖出依据}
DRAWICON(卖出条件,H*1.01,2);{这是假设的卖出条件成立,在当日K线上方用绿色箭头表示卖出信号}
价格2:=IF(卖出条件,C,DRAWNULL);{这是假设的卖出条件成立,以当日收盘价作为卖出成交价}
DRAWNUMBER(卖出条件,H*1.04,价格2),COLORLIGREEN;{这是在卖出条件成立的情况下,在当日最高价上方标出卖出成交价,颜色绿色}
DRAWLINE(买入条件,C,卖出条件,REF(C,BARSLAST(买入条件)),0),COLORGRAY,DOTLINE;{这是以买入日起到卖出日止的横线,深灰色,用于观察天数}
DRAWNUMBER(卖出条件,H*1.08,(C/REF(C,BARSLAST(买入条件))-1)*100),COLORYELLOW;{这是买入成立,卖出成立,期间的盈亏百分比,用黄色在卖出日K线上方表示}
DRAWNUMBER(卖出条件,REF(C,BARSLAST(买入条件)),BARSLAST(买入条件)),COLORWHITE;{这是一次操作,含买入和卖出的交易天数}

通达信买卖分析主图指标公式

 

相关文章