在线检测未来函数

大智慧烧香拜佛指标公式

来源:Internet,编辑:股旁网,2015-07-24

input:p(10,1,100),A(5,1,100);
{DRAWGBKLAST(CLOSE>0,STRIP(RGB(66,66,66),RGB(66,66,66),0));}
N:=2.5;
svol:=INTPART(SUM(V,0)/CAPITAL);
tj0:=svol>REF(svol,1) or BARSSINCE(CLOSE)=0;
S1:=BARSLAST(tj0)+1;{//时间1}
tj2:=S1<ref(S1,1);{//取点}
S2:=if(tj2,ref(S1,1)+1,S1);{//时间2}
S3:=sum(tj2,0);
阶段总额(万):=SUM(AMOUNT/10000,S2)*100;
阶段总量(手):=SUM(V,S2)*100;
阶段成本(元):=(阶段总额(万)/(阶段总量(手)/100));
Zk1:="KD.K#WEEK"(9,3,3);
Zd2:="KD.D#WEEK"(9,3,3);
ZF1:="macd.diff#WEEK"(12,26,9);
ZA2:="macd.dea#WEEK"(12,26,9);
换手率:v/FINANCE2(37),LINETHICK0,COLORCYAN;
JCD:=FILTER(CROSS(Zk1,Zd2) and Zd2<30,13);
取点:=barslast(JCD);
吸筹区:=if(取点>0 and 取点<61,取点,0);
ZS1:=吸筹区;
ZS2:=吸筹区+1;
ZS3:=换手率/5;
ZSA:=IF(ZS1>0,sum((ZS3),吸筹区+1),0);
换手冷清:STICKLINE(换手率<3,(0-6)*4,(换手率-6)*4,3,1),COLOR555555;
换手活跃:STICKLINE(换手率>=3 and 换手率<7,(0-6)*4,(换手率-6)*4,3,1),COLOR008888;
换手热烈:STICKLINE(换手率>=7,(0-6)*4,(换手率-6)*4,3,1),COLOR000088;
VERTLINE(JCD,1),COLORGREEN;
DRAWTEXTREL(5,20,'◇阶段平均成本:'+NUMTOSTRN(阶段成本(元),2)+'(元)'),colorWhite;
DRAWTEXTREL(190,20,'◇估算主力筹码:'+NUMTOSTRN(ZSA,2)+'%'),colorWhite;
DRAWTEXTREL(360,20,'◇主力建仓天数:'+NUMTOSTRN(ZS1,0)+'(天)'),colorWhite;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
卖出: 14.5*n,COLORC6C600;
清仓:17.5*n,COLORFF75FF;
动力线:= (EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*10-17.5)*n;
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),15,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),15 ,1),COLOR00FF00;
底部:-15.5*n,COLOR70DB93;
关注:-12.5*n,COLORYELLOW;
T1:=FILTER(CROSS(动力线,关注),20);
T2:=FILTER(CROSS(动力线,底部),20);
T3:=FILTER(CROSS(清仓,动力线),20);
T4:=FILTER(CROSS(卖出,动力线),20);
DRAWICON((T1 OR T2),0,7);
0,POINTDOT,LINETHICK2,COLOR70DB93;
RSV:=((((HHV(HIGH,p) - CLOSE) / (HHV(HIGH,p) - LLV(LOW,p))) * 200) - 125);
散户:SMA(RSV,A,1)+15,COLORGRAY,LINETHICK2;;
RSV1:=((((CLOSE - LLV(LOW,p)) / (HHV(HIGH,p) - LLV(LOW,p))) * 200) - 105);
主力:SMA(RSV1,A,1)+15,COLORGRAY,LINETHICK2;
PARTLINE(散户,散户<0),COLORyellow,LINETHICK2;
PARTLINE(主力,主力>0),COLORyellow,LINETHICK2;
超跌回升:=CROSS(主力,(0 - 79));
STICKLINE(超跌回升,50,0,10,0),color0000FF;
准备起爆:=CROSS(主力,散户);
STICKLINE(准备起爆,10,-10,10,0),color00FFFF;
小心阴跌一:=CROSS(散户,主力);
STICKLINE(小心阴跌一,10,-10,10,0),COLORGRAY;
DRAWTEXT(准备起爆,5,' 佛,'),color00FFFF;
DRAWTEXT((T3 OR T4),0,'$'),align1,color00FFFF;

大智慧烧香拜佛指标公式

 

相关文章