在线检测未来函数

通达信财富整合主图指标公式

来源:Internet,编辑:股旁网,2015-07-24

N:=26;
P:=2;
P1:=5;
P2:=10;
DRAWBAND(MA(CLOSE,P1),RGB(155,50,50),MA(CLOSE,P2),RGB(83,123,68));
DRAWBAND(MA(CLOSE,60),RGB(55,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,P1),COLORWHITE;
MA13:MA(CLOSE,P2),COLORGREEN;
MA20:MA(CLOSE,20);
MA34:MA(CLOSE,34),COLORLIGREEN;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK1;
MA119:MA(CLOSE,119);
MA121:MA(CLOSE,121),COLORRED,LINETHICK1;
MA250:MA(CLOSE,250),LINETHICK2,COLOR0000FF;
涨停:=IF(REF(C,1)*1.095-C<0.01 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;
DRAWTEXT(涨停,L-0.1,'涨停'),COLORYELLOW;
PDAY1 := BARSLAST(CROSS(MA5,MA60));{5日均线上穿60日均线}
PDAY2 := BARSLAST(CROSS(MA13,MA60));{13日均线上穿60日均线,至此形成鸭颈部}
PDAY3 := BARSLAST(REF(HIGH=HHV(HIGH,PDAY2),1));{形成头部,要下跌}
PDAY4 := BARSLAST(CROSS(MA13,MA5){ OR (REF(MA13,1)<REF(MA5,1) AND MA5=MA13)});{下跌后,5日均线和13日均线死叉}
PDAY5 := BARSLAST(CROSS(MA5,MA13){ OR (REF(MA5,1)=REF(MA13,1) AND MA5>MA13)});{回落不久,5日均线和13日均线形成金叉,形成部}
A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
A2:= COUNT(CROSS(MA13,MA5),PDAY2)=1;
A3:=MA5>MA60 AND MA13>MA60;
老鸭头:=(A1 AND A2 AND A3) AND FILTER(A1 AND A2 AND A3 ,5);
DRAWTEXT(老鸭头,L,'老鸭头'),COLORGREEN;
STICKLINE(老鸭头,H,L,0.5,0),COLORGREEN;
STICKLINE(老鸭头,O,C,6,1),COLORGREEN,LINETHICK3;
压:=MA13<MA34 AND MA34>MA13 AND CROSS(MA34,MA13);
DRAWTEXT(压,MA34+0.012,'压'),COLORYELLOW;
VOL5:=MA(VOL,5),COLORWHITE;
VOL13:=MA(VOL,13),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF ;
量托:=VOL5>=VOL40 AND CROSS(VOL13,VOL40) AND REF(VOL13,1)<REF(VOL40,1);
DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;
C3:=REF(C,1);
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,4,0),COLORBLUE;
STICKLINE(跌停,OPEN,CLOSE,3,0),COLORGREEN;
DRAWTEXT(跌停,H+0.1,'跌停'),COLORGREEN;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,26)*15+C,45);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWBMP(BU,L*0.999,'B');
DRAWBMP(SEL,H*1.02,'S');
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORLIRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,1),COLORLIRED;
JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价:=SMA(JC,5,1),COLORCYAN;
价:=IF(C>=参考价,参考价,参考价*0.98 ), CIRCLEDOT,COLOR0000FF;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORCYAN;
STICKLINE(买线<卖线,CLOSE,OPEN,3,1),COLORCYAN;
趋势线:MA(CLOSE,34),COLORYELLOW,LINETHICK2;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK2;
IF(趋势线>REF(趋势线,1),趋势线,DRAWNULL),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.10,0.00,0,STRCAT('所属地区:',DYBLOCK)),COLORRED;
DRAWTEXT_FIX(C>0,0.00,0.06,0,STRCAT('千股千评:',EXTERNSTR(0,1))),COLORRED;
DRAWTEXT_FIX(C>0,0.20,0.00,0,STRCAT('主营业务:',EXTERNSTR(0,6))),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.00,0.12,0,STRCAT('主题投资:',EXTERNSTR(0,7))),COLORYELLOW;
DRAWTEXT_FIX(C>0,0.00,0.00,0,STRCAT('所属行业:',HYBLOCK)),COLORYELLOW;

通达信财富整合主图指标公式

 

相关文章