在线检测未来函数

通达信乘风BOLL主图指标公式

来源:Internet,编辑:股旁网,2015-07-31

N:=30;
DRAWGBK(C>0,RGB(80,60,60),RGB(50,100,200),0,' ',0);
BOLL2:MA(CLOSE,N/1.5),LINETHICK2,COLORAA00AA;
UB2:BOLL2+2*STD(CLOSE,N/1.5),LINETHICK1,COLOR00FF00;
LB2:BOLL2-2*STD(CLOSE,N/1.5),LINETHICK1,COLOR00FF00;
BOLL:MA(CLOSE,N/3),LINETHICK1,COLOR00DDFF;
UB:BOLL+2*STD(CLOSE,N/3),LINETHICK1,DOTLINE,COLORFF0000;
LB:BOLL-2*STD(CLOSE,N/3),LINETHICK1,DOTLINE,COLORFF0000;
ZMA5:MA.MA1#DAY,COLOR0000FF,NODRAW;
STICKLINE(H>=MA(C,20)+2*STD(C,20) AND H/BOLL2>=1.1,H*1.005,L*0.995,5,1),COLOR00FF00;
STICKLINE(L<MA(C,20)-2*STD(C,20),H*1.005,L*0.995,5,1),COLOR00FFFF;
STICKLINE(H>=MA(C,10)+2*STD(C,10) AND H/BOLL2>=1.1,H,L,4.5,0),COLOR00AA00;
STICKLINE(L<MA(C,10)-2*STD(C,10),H,L,4.5,0),COLOR000033;
STICKLINE(C<O,H,L,0.02,0),COLOR999000;
STICKLINE(C>=O,H,L,0.02,0),COLOR000088;
STICKLINE(C<O,C,O,3.2,0),COLOR777000;
STICKLINE(C<O,C,O,2.1,0),COLOR888000;
STICKLINE(C<O,C,O,1,0),COLOR999000;
STICKLINE(C>=O,C,O,3.2,0),COLOR000066;
STICKLINE(C>=O,C,O,2.1,0),COLOR000077;
STICKLINE(C>=O,C,O,1,0),COLOR000088;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C<O,H,L,0.02,0),COLORFFE600;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C>=O,H,L,0.02,0),COLOR0000FF;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C<O,C,O,3.2,0),COLORDDC400;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C<O,C,O,2.1,0),COLOREED500;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C<O,C,O,1,0),COLORFFE600;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C>=O,C,O,3.2,0),COLOR0000DD;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C>=O,C,O,2.1,0),COLOR0000EE;
STICKLINE((C*3+O*2+H+L)/7>=COST((COST(98)-COST(2))/(COST(98)+COST(2))*100) AND C>=O,C,O,1,0),COLOR0000FF;
主升:=(C*3+O*2+H+L)/7>=(MA(C,60)+MA(C,60)+2*STD(C,60))/2;
STICKLINE(C<O AND 主升,H,L,0.02,0),COLORFFFFFF;
STICKLINE(C>=O AND 主升,H,L,0.02,0),COLORFF00FF;
STICKLINE(C<O AND 主升,C,O,3.2,0),COLORBBBBBB;
STICKLINE(C<O AND 主升,C,O,2.1,0),COLORCCCCCC;
STICKLINE(C<O AND 主升,C,O,1,0),COLORDDDDDD;
STICKLINE(C>=O AND 主升,C,O,3.2,0),COLORBB00BB;
STICKLINE(C>=O AND 主升,C,O,2.1,0),COLORCC00CC;
STICKLINE(C>=O AND 主升,C,O,1,0),COLORDD00DD;
STICKLINE((REF(C,1)-C)/REF(C,1)>=0.095 AND C=O AND H=L,C,O,4,0),COLORFFF000;
STICKLINE((C-REF(C,1))/REF(C,1)>=0.095 AND C=O AND H=L,C,O,4,0),COLOR00FFFF;
{BOLL3:MA(CLOSE,N),LINETHICK2,COLOR000088;
UB3:BOLL3+2*STD(CLOSE,N),LINETHICK2,COLORFFF000;
LB3:BOLL3-2*STD(CLOSE,N),LINETHICK2,COLORFFF000;}
IF(PERIOD<5,ZMA5,DRAWNULL),COLOR0000FF,LINETHICK1;
BOLL2,LINETHICK2,COLORAA00AA;
UB2,LINETHICK1,COLOR00FF00;
LB2,LINETHICK1,COLOR00FF00;
BOLL,LINETHICK1,COLOR00DDFF;
UB,LINETHICK1,DOTLINE,COLORFF0000;
LB,LINETHICK1,DOTLINE,COLORFF0000;
超跌:=ZMA5/L>1.19;
DRAWICON(PERIOD<5 AND ZMA5/L>=1.18,H*1.015,26);
DRAWICON(PERIOD<5 AND H/ZMA5>=1.18,H*1.015,15);
DRAWICON(PERIOD<5 AND H/MIN(UB,UB2)>=1.025,L*0.96,6);
DRAWICON(PERIOD<5 AND MAX(LB,LB2)/L>=1.02,L*0.96,5);

通达信乘风BOLL主图指标公式

 

相关文章