在线检测未来函数

通达信财富钥匙指标公式

来源:Internet,编辑:股旁网,2015-07-31

{XDB:="虎拓圣龙.买入力度";
XDS:="虎拓圣龙.卖出力度";}
MM:=H-REF(C,1);
SS:=REF(C,1)-L;
S:=IF(SS>0,SS,0.01);
M:=IF(MM>0,MM,0.01);
HJ:=M+S;
买入力度:=M/HJ*AMOUNT/CAPITAL;
卖出力度:=S/HJ*AMOUNT/CAPITAL;
X:=(买入力度-卖出力度);
SUMX:=SUM(X,0);
SUMXP:=X*10;
CT:=COUNT(SUMXP>0,0);
ST:=COUNT(SUMXP<0,0);
CZ:=CT-ST;
T1:=V>MA(V,0)*5;
T2:=SLOPE(C,5)>0.02;
T3:=SLOPE(C,4)>0.016;
X1:=T1 AND T2 AND SUMX>0 AND CT>ST*1.5;
X2:=(COUNT(SUMXP>0,6)>5 OR COUNT(SUMXP>0,10)>7) AND SUMX>0.1 AND T3;
Y:=HHV(SUMXP,0);
B:=X1*Y;
庄家:(X2*Y)/200,LINETHICK2,COLOR0088FF;
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
散户: (100-VARA)/1,LINETHICK1 ,COLORWHITE;
H00:=SUM(IF((CLOSE> REF(CLOSE,1.000)),VOL,IF((CLOSE<REF(CLOSE,1.000)),(0-VOL),0)),0);
H01:=SUMBARS(VOL,CAPITAL);
H02:=IF((CLOSE>LLV(CLOSE,H01)),1.000,(0-1.000))*IF((H00 >LLV(H00,H01)),1.000,(0-1.000));
H03:=(COUNT((IF((H02=(0-1.000)),1.000,0)=1.000),8.000)>2.000);
H04:=((CLOSE-DMA((((3.000 * HIGH + LOW)+OPEN)+2.000 * CLOSE)/7.000,VOL/SUM(AMOUNT,13.000)/
AMOUNT/VOL/100.000/100.000))/DMA((((3.000*HIGH+LOW)+OPEN)+2.000*CLOSE)/7.000,VOL/SUM(AMOUNT,13.000)/
AMOUNT/VOL/100.000/100.000)*100.000<(0-18.000));
H05:=((CLOSE-MIN(REF(CLOSE,5.000)*0.865,REF(CLOSE,21.000)*0.772))/CLOSE<0.009);
H06:=((H03 AND H04) AND H05);
H07:=(((((OPEN < EMA(CLOSE,5.000)) AND (CLOSE=HIGH)) AND (CLOSE/OPEN>=1.05)) AND (VOL/
CAPITAL>=0.019)) AND (VOL/CAPITAL<=0.200));
H08:=(H07 AND (COUNT(H07,5.000)=1.000));
H09:=((((((((((((MA(CLOSE, 3.000)>REF(MA(CLOSE,3.000),1.000)) AND (MA(CLOSE, 5.000)>
REF(MA(CLOSE,5.000),1.000))) AND (MA(CLOSE,10.000)>REF(MA(CLOSE,10.000),1.000))) AND
(VOL/240.000>REF(VOL,30.000)*1.200/240.000*1.500)) AND (CLOSE>LOW*1.059)) AND (CLOSE>
REF(MA(CLOSE,3.000),1.000))) AND REF(CLOSE,1.000)) AND (MA(CLOSE,5.000)>REF(MA(CLOSE,
5.000),1.000))) AND (MA(CLOSE,10.000)>REF(MA(CLOSE,10.000),1.000))) AND (MA(CLOSE,20.000)>
REF(MA(CLOSE,20.000),1.000))) AND (MA(VOL,5.000)>REF(MA(VOL,5.000),1.000))) AND ((MA(CLOSE,5.000)-MA
(CLOSE,10.000))<= 0.579));
A0A:=FILTER(H09,5.000);
牛股:((H06 OR H07) AND A0A),LINETHICK1,COLORRED;
主力筹码:=EMA(WINNER(CLOSE)*70,10);
散户筹码:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,10);
机构拉升:(主力筹码-散户筹码)/1,LINETHICK1,COLORMAGENTA;
钥匙:50,COLOR00FF66;
ZLCM:=EMA((WINNER(CLOSE) * 70),3);
SHCM:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
主力控盘:((ZLCM / (ZLCM + SHCM)) * 100),LINETHICK2,COLORYELLOW;
顶:90, LINETHICK2 ,COLORRED;
风险:80,COLORYELLOW;
VARF:=TROUGHBARS(3,15,1)<4;
多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
STICKLINE(FILTER(VARF=1,5) AND 多空<-10,40,0,2,0),COLORF00FF0;
STICKLINE(FILTER(VARF=1,5),40,0,2,0),COLORYELLOW;
DRAWTEXT(牛股,-10.4,'▲←超级黑马'),COLORRED;

通达信财富钥匙指标公式

 

相关文章