在线检测未来函数

大智慧股海看量指标公式

来源:Internet,编辑:股旁网,2015-08-03

人气:="分时引1.人气#DAY";
DRAWTEXTREL(500,20,'人气:'+NUMTOSTRN(人气,3)),COLORbbffff;
实际V: VOL,LINETHICK0,PRECIS0 ;
Var1:=DYNAINFO(17)*REF(MA(VOL,5),1);
Var2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测V1:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,Var1,Var2);
预测V2:=IF(实际V>=预测V1,实际V,预测V1);
比1:=预测V2/实际V;
比比:=BETWEEN(比1,0.8,1.2);
比:=IF(比比,1,比1);
预测V:实际V*比,LINETHICK0,PRECIS0;
预比昨:"分时引.预比昨#DAY",LINETHICK0 ;
上海:STKINDI('1A0001','分时引.预比昨#DAY'),LINETHICK0 ;
深圳:STKINDI('399001','分时引.预比昨#DAY'),LINETHICK0;
流通盘:CAPITAL/1000000;
换手率:VOL/CAPITAL*100,LINETHICK0;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=(V9+V8)*比;
卖盘2:=(V6+V7)*比;
买盘:=IF(CATEGORY<>0 AND BARSTATUS=2 AND DATATYPE=8,买盘1,买盘2);
卖盘:=IF(CATEGORY<>0 AND BARSTATUS=2 AND DATATYPE=8,卖盘1,卖盘2);
买卖差:=买盘-卖盘;
STICKLINE(CLOSE>MA(CLOSE,30) AND C>=o,0,VOL*比,8,1),colorred;
STICKLINE(CLOSE>MA(CLOSE,30) AND C<o,0,VOL*比,8,1),COLORFFFF00;
STICKLINE(CLOSE>MA(CLOSE,30) AND 买卖差>=0,0,买盘,8,0),colorred;
STICKLINE(CLOSE>MA(CLOSE,30) AND 买卖差>=0,0,卖盘,6,0),COLORDDcc00;
STICKLINE(CLOSE>MA(CLOSE,30) AND 买卖差<0,0,买盘,8,0),colorred;
STICKLINE(CLOSE>MA(CLOSE,30) AND 买卖差<0,0,卖盘,6,0),COLORDDcc00;
STICKLINE(CLOSE<MA(CLOSE,30) AND C>=o,0,VOL*比,6,1),colorred;
STICKLINE(CLOSE<MA(CLOSE,30) AND C<o,0,VOL*比,6,1),COLORFFFF00;
STICKLINE(CLOSE<MA(CLOSE,30) AND 买卖差>=0,0,买盘,6,0),colorred;
STICKLINE(CLOSE<MA(CLOSE,30) AND 买卖差>=0,0,卖盘,4,0),COLORFF5500;
STICKLINE(CLOSE<MA(CLOSE,30) AND 买卖差<0,0,买盘,6,0),colorred;
STICKLINE(CLOSE<MA(CLOSE,30) AND 买卖差<0,0,卖盘,4,0),COLORFF5500;
STICKLINE(1,0,MAX(买盘,卖盘),1,0),COLORFFFFFF;
总:="分时引1.总#day";
进出量:=IF(CATEGORY=0,人气*总/100,FRACPART(人气)*总);
红天3:=COUNT(进出量>0,3)=3;
红天5:=COUNT(进出量>0,5)=5;
红天9:=COUNT(进出量>0,9)=9;
DRAWICON(红天3,-500 ,9),ALIGN1;
DRAWICON(红天5,-250 ,11),LAYER3,ALIGN1;
DRAWICON(红天9,0 ,10),LAYER3,ALIGN1;
大前诤:="分时引2.大前诤#day";
大前换:="分时引2.大前换#day";
DRAWTEXTREL(0,520,' 大前日诤 :'+NUMTOSTRN(大前诤,2)),ColorFFFFFF,LAYER0;
DRAWTEXTREL(190,520,'%:'+NUMTOSTRN(大前换,2)),ColorFFFFFF,LAYER0;
大单净:="分时引2.前总诤#day";
前大单换:="分时引2.前换#day";
DRAWTEXTREL(0,640,' 前大单净 :'+NUMTOSTRN(前大单净,2)),ColorFFFFFF,LAYER0;
DRAWTEXTREL(190,640,'%:'+NUMTOSTRN(前大单换,2)),ColorFFFFFF,LAYER0;
昨大单净:="分时引2.咋总诤#day";
昨大单换:="分时引2.咋换#day";
DRAWTEXTREL(0,760,' 昨大单净 :'+NUMTOSTRN(昨大单净,2)),ColorFFFFFF,LAYER0;
DRAWTEXTREL(190,760,'%:'+NUMTOSTRN(昨大单换,2)),ColorFFFFFF,LAYER0;
大单净量:="分时引2.日总诤#day";
大单换:="分时引2.总净换#day";
DRAWTEXTREL(0,880,' 大单净量 :'+NUMTOSTRN(大单净量,0)),ColorFFFFFF,LAYER0;
DRAWTEXTREL(190,880,'%:'+NUMTOSTRN(大单换,2)),ColorFFFFFF,LAYER0;
mm0:="分时引1.mm0#day";
mm01:="分时引1.mm01#day";
mm02:="分时引1.mm02#day";
mm1:="分时引1.mm1#day";
mm11:="分时引1.mm11#day";
mm12:="分时引1.mm12#day";
mm2:="分时引1.mm2#day";
mm21:="分时引1.mm21#day";
mm22:="分时引1.mm22#day";
mm3:="分时引1.mm3#day";
mm31:="分时引1.mm31#day";
mm32:="分时引1.mm32#day";
DRAWRECTREL(0,480,250,1000 ,RGB(50,50,50)),LAYER3;
DRAWRECTREL(0,20,mm3,60,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,20,mm31,60,RGB(200,0,20)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,60,mm32,100,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,130,mm2,170,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,130,mm21,170,RGB(200,0,20)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,170,mm22,210,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,240,mm1,280,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,240,mm11,280,RGB(200,0,20)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,280,mm12,320,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,350,mm0,390,RGB(0,200,200)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,350,mm01,390,RGB(200,0,20)),COLORFFFFFF,LAYER1;
DRAWRECTREL(0,390,mm02,430,RGB(0,200,200)),COLORFFFFFF,LAYER1;

大智慧股海看量指标公式

 

相关文章