在线检测未来函数

通达信量化趋势线主图指标公式

来源:Internet,编辑:股旁网,2015-08-03

{使用说明:1.红k主力做多,绿k就不用说了;2.粉k和蓝k 都是一种变盘信号,对于小散只能做多的单项交易,只能选择出红k来交易;3.两条趋势线可以把握一下大的趋势:跌破粉线中线做空,估计在两线之间属于盘整无方向。}

QQ1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,QQ1*(HIGH-LOW),IF(CLOSE<OPEN,QQ1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖:=IF(CLOSE>OPEN,0-QQ1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-QQ1*(HIGH-LOW),0-VOL/2));
DD:=(主买+主卖)/10000;
DDX1:=EMA(DD,60)*60;
DDX2:=MA(DDX1,5);
DDX3:=MA(DDX1,13);
STICKLINE(DDX1<DDX3,H,L,0,0),COLORGREEN;
STICKLINE(DDX1<DDX3,C,O,2.8,0),COLOR00B500;
STICKLINE(DDX1<DDX3,C,O,2.6,0),COLOR00C600;
STICKLINE(DDX1<DDX3,C,O,2,0),COLOR00D500;
STICKLINE(DDX1<DDX3,C,O,1,0),COLOR00E600;
STICKLINE(DDX1>DDX3,H,L,0,0),COLOR106FFF;
STICKLINE(DDX1>DDX3,C,O,2.8,0),COLOR0000C8;
STICKLINE(DDX1>DDX3,C,O,2.6,0),COLOR0000D7;
STICKLINE(DDX1>DDX3,C,O,2,0),COLOR0000EA;
STICKLINE(DDX1>DDX3,C,O,1,0),COLOR0000FF;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,H,L,0,0),COLORFF5D10;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2.8,0),COLORFF5D10;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2.6,0),COLORFF7710;
STICKLINE(DDX1<DDX2 AND DDX1>DDX3,C,O,2,0),COLORFF9910;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,H,L,0,0),COLORFF00FF;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2.8,0),COLORD000D0;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2.6,0),COLORE600E6;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,2,0),COLORF900F9;
STICKLINE(DDX1>DDX2 AND DDX1<DDX3,C,O,1,0),COLORFF09FF;
{风险提示}
MA2:=MA(CLOSE,10);
MA34:=MA(CLOSE,34);
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
K:=SMA(VARF,3,1);
顶:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (K>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND
(K>79),H*1.02,'风险'),COLORYELLOW;
{量化趋势线}
降:=HHV(EMA(C,3),8),COLORCYAN;
升:=LLV(EMA(C,3),8),COLORRED;
走势:=EMA(C,3),COLORYELLOW;
线上多:IF(走势<降,降,DRAWNULL),COLORCYAN,LINETHICK2;
线下空:IF(走势>升,升,DRAWNULL),COLORMAGENTA,LINETHICK2;
{提示说明}
DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,'1.红K主力做多,绿K主力做空;粉K和蓝K都是一种变盘信号,小散只能选择出红K来交易;'),COLOR00C5FF;
DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,'2.两条趋势线可以把握一下大的趋势:跌破粉线中线做空,估计在两线之间属于盘整无方向。'),COLORD6BA63;
DRAWTEXT_FIX(ISLASTBAR ,0.20,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.30,0.01,1,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.50,0.01,1,GNBLOCK),COLORWHITE;

通达信量化趋势线主图指标公式

 

相关文章