在线检测未来函数

通达信必抓黑马一号指标公式

来源:Internet,编辑:股旁网,2015-08-03

AHC1:=CLOSE*VOL;
AHC22:=EMA((EXPMA(AHC1,23)/EXPMA(VOL,23)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
通道:=1.0668*AHC22;
起爆:=CROSS(C,通道) AND REF(C,1)*1.05-C<0.008 AND C>O*0.5;
RRF:=起爆;
A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
金线王:=EMA(A2,200)*1.118;
金线王2:=EMA(A2,200)*1.118;
条件:=(C-REF(C,1))/REF(C,1)*100>8;
金K线:=CROSS(C,金线王) AND 条件;
AA05:=MA(C,5);
AA30:=MA(C,30);
MA05:=MA(C,5);
MA10:=MA(C,13);
MA30:=MA(C,34);
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
五日乖离率:=(C-AA05)/AA05*100;
三拾日乖离率:=(C-MA30)/MA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
STICKLINE(IF(RRF,-120,0),+12,0,5,0),COLOR000088;
STICKLINE(IF(RRF,-120,0),+12,0,5,0),COLOR0000AA;
STICKLINE(IF(RRF,-120,0),+12,0,5,0),COLOR0000CC;
STICKLINE(IF(RRF,-120,0),+12,0,5,0),COLOR0000EE;
STICKLINE(IF(RRF,-120,0),+12,0,5,0),COLOR0000EE;
STICKLINE(IF(RRF,-120,0),+12,0,5,0),COLORLIMAGENTA;
STICKLINE(IF(RRF,-120,0),+9,0,5,0),COLOR770077;
STICKLINE(IF(RRF,-120,0),+9,0,5,0),COLOR990099;
STICKLINE(IF(RRF,-120,0),+9,0,5,0),COLORBB00BB;
STICKLINE(IF(RRF,-120,0),+9,0,5,0),COLORDD00DD;
STICKLINE(IF(RRF,-120,0),+9,0,5,0),COLORFF00FF;
STICKLINE(IF(RRF,-120,0),+9,0,5,0),COLORDD00DD;
STICKLINE(IF(RRF,-120,0),+6,0,5,0),COLOR003300;
STICKLINE(IF(RRF,-120,0),+6,0,5,0),COLOR005500;
STICKLINE(IF(RRF,-120,0),+6,0,5,0),COLOR007700;
STICKLINE(IF(RRF,-120,0),+6,0,5,0),COLOR009900;
STICKLINE(IF(RRF,-120,0),+6,0,5,0),COLOR00CC00;
STICKLINE(RRF,0,3,5,0),COLOR008888;
STICKLINE(RRF,0,3,5,0),COLOR00AAAA;
STICKLINE(RRF,0,3,5,0),COLOR00CCCC;
STICKLINE(RRF,0,3,5,0),COLOR00FFFF;
STICKLINE(IF(金K线,-120,0),+12,0,4,0),COLOR000088;
STICKLINE(IF(金K线,-120,0),+12,0,4,0),COLOR0000AA;
STICKLINE(IF(金K线,-120,0),+12,0,4,0),COLOR0000CC;
STICKLINE(IF(金K线,-120,0),+12,0,4,0),COLOR0000EE;
STICKLINE(IF(金K线,-120,0),+12,0,4,0),COLOR0000EE;
STICKLINE(IF(金K线,-120,0),+12,0,4,0),COLORLIMAGENTA;
STICKLINE(IF(金K线,-120,0),+9,0,4,0),COLOR770077;
STICKLINE(IF(金K线,-120,0),+9,0,4,0),COLOR990099;
STICKLINE(IF(金K线,-120,0),+9,0,4,0),COLORBB00BB;
STICKLINE(IF(金K线,-120,0),+9,0,4,0),COLORDD00DD;
STICKLINE(IF(金K线,-120,0),+9,0,4,0),COLORFF00FF;
STICKLINE(IF(金K线,-120,0),+9,0,4,0),COLORDD00DD;
STICKLINE(IF(金K线,-120,0),+6,0,4,0),COLOR003300;
STICKLINE(IF(金K线,-120,0),+6,0,4,0),COLOR005500;
STICKLINE(IF(金K线,-120,0),+6,0,4,0),COLOR007700;
STICKLINE(IF(金K线,-120,0),+6,0,4,0),COLOR009900;
STICKLINE(IF(金K线,-120,0),+6,0,4,0),COLOR00CC00;
STICKLINE(IF(金K线,-120,0),+3,0,4,0),COLOR666666;
STICKLINE(IF(金K线,-120,0),+3,0,4,0),COLOR777777;
STICKLINE(IF(金K线,-120,0),+3,0,4,0),COLOR888888;
STICKLINE(IF(金K线,-120,0),+3,0,4,0),COLOR999999;
STICKLINE(IF(金K线,-120,0),+3,0,4,0),COLORDDDDDD;
STICKLINE(IF(金K线,-120,0),+3,0,4,0),COLORFFFFFF;
DRAWTEXT(RRF,10.5,'黑马一号'),COLORYELLOW;
{DRAWTEXT(RRF,8.5,'黑'),COLORYELLOW;}
DRAWTEXT(金K线,6,'黑马启动'),COLORYELLOW;
{DRAWTEXT(RRF,3.5,'启'),COLORRED;
DRAWTEXT(RRF,1,'动'),COLORRED;}
STICKLINE(买入,10,0,3,0),COLORRED;
{DRAWTEXT(买入,10.5,'黑'),COLORYELLOW;
DRAWTEXT(买入,7.5,'马'),COLORYELLOW;
DRAWTEXT(买入,4.5,'必'),COLOR00FFFF;}
DRAWTEXT(买入,1.5,'黑马必抓'),COLOR00FFFF;

通达信必抓黑马一号指标公式

 

相关文章