在线检测未来函数

通达信线上买主图指标公式

来源:Internet,编辑:股旁网,2015-08-05

{M5:MA(CLOSE,5)COLORYELLOW;}
M5:MA(CLOSE,5)COLORWHITE;
M10:MA(CLOSE,10)COLORYELLOW;
VZT:= REF(HIGH,1)<REF(HIGH,2) AND REF(LOW,1)<REF(LOW,2);
VJT:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
DIFX:=VZT AND VJT;
DIYXSJ:=BARSLAST(DIFX);
FXBOTTOM:=REF(L,DIYXSJ+1);
DP:=C<FXBOTTOM AND C<O;
SELLPIONT:=DP AND COUNT(DP,5)=1 AND REF(DP,1)=0;
DRAWICON(SELLPIONT AND C<O, H*1.005, 2);
AZT:= REF(HIGH,1)>REF(HIGH,2) AND REF(LOW,1)>REF(LOW,2);
AJT:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
DINGFX:=AZT AND AJT;
DINGYXSJ:=BARSLAST(DINGFX);
FXTOP:=REF(H,DINGYXSJ+1);
SP:=C>FXTOP AND C>O;
BUYPIONT:=SP AND COUNT(SP,5)=1 AND REF(SP,1)=0;
DRAWICON(BUYPIONT AND C>O, L*0.995, 1);
T11:=CONST(LLVBARS(L,10));
T11H:=CONST(REF(H,T11));
CC:=CONST(CURRBARSCOUNT);
T12:=CONST(BARSLAST(CURRBARSCOUNT>CC+T11 AND H>T11H));
T12H:=CONST(REF(H,T12));
T13:=CONST(BARSLAST(CURRBARSCOUNT>CC+T12 AND H>T12H));
T13H:=CONST(REF(H,T13));
上线买1:DRAWLINE(CURRBARSCOUNT=T13+1,T13H,ISLASTBAR,T13H,1),LINETHICK2,COLOR0000FF;
DRAWTEXT(ISLASTBAR,T13H,' 上线买1')LINETHICK1,COLOR0000FF;
T:=BARSLAST(LLVBARS(LOW,10)=0);
T21:=CONST(REF(REF(T,1),T)+T+1);
T21H:=CONST(REF(H,T21));
T22:=CONST(BARSLAST(CURRBARSCOUNT>CC+T21 AND H>T21H));
T22H:=CONST(REF(H,T22));
T23:=CONST(BARSLAST(CURRBARSCOUNT>CC+T22 AND H>T22H));
T23H:=CONST(REF(H,T23));
上线买2:DRAWLINE(CURRBARSCOUNT=T23+1,T23H,ISLASTBAR,T23H,1),LINETHICK2,COLOR0000FF;
DRAWTEXT(ISLASTBAR,T23H,' 上线买2')LINETHICK1,COLOR0000FF;

通达信线上买主图指标公式

 

相关文章