在线检测未来函数

同花顺机构方向主图指标公式

来源:Internet,编辑:股旁网,2015-08-10

VAR1:=REF(CLOSE,2);
会员: SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,COLORFFAA66;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
逃亡: IF(会员< REF(会员,1) AND 会员>79,会员,0);
DRAWTEXT(逃亡 ,90 ,'逃'),coloryellow;
DRAWTEXT(88>0 AND REF(O,1)/REF(C,1)>1.04 AND REF(L,1)<=688 AND O>REF(C,1)AND C<REF(O,1)AND C/O>=1.01,15,'见底'),colorred,LINETHICK1;
DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,20),15,'绝底'),colorred, LINETHICK1;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
做多能量:3*Q3-2*Q4,colorred,LINETHICK2;
Q8:=HHVBARS(HIGH, 50);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
跨越:EMA(Q3, 3),colorlimagenta;
DRAWTEXT(CROSS(做多能量, 8) AND Q10<-13,22,'大底来'),coloryellow,LINETHICK5;
VAR4:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
做空能量:SMA(VAR4,3,1),colorgreen,LINETHICK2;
DRAWTEXT(CROSS(跨越,做空能量) ,40,'强势'),LINETHICK1;
DRAWTEXT(CROSS(做多能量,跨越) ,22,'拉升'),LINETHICK1;
DRAWTEXT(CROSS(跨越,做多能量) ,70,'调整'),COLORFFAA66,LINETHICK1;
DRAWTEXT(REF(CROSS(做空能量,跨越),25) AND 做空能量>1.005*跨越,跨越,'买入点'),colorlired,LINETHICK1;
DRAWTEXT(REF(CROSS(跨越,做多能量),82) AND 跨越>1.3*做多能量,做多能量,'逢低买入'),colorlired,LINETHICK1;
DRAWTEXT(CROSS(做多能量,跨越),做多能量,'始'),colorred;
DRAWTEXT(CROSS(跨越,做多能量),跨越,'终'),colorgreen;
////机构建仓////
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0),STICK,colorred;
VAR5:=SMA(最佳买入选股,3,1);
VAR6:=SMA(VAR5,3,1),COLOR0000FF;
VAR7:=SMA(VAR6,3,1),COLOR00FFFF;
建仓买点:=IF(CROSS(VAR6,VAR7) AND (VAR6<40),5,0* 10000);
DRAWTEXT(建仓买点,8,'建仓'),colorred;
///主力吸货////
VAR8:=REF(LOW,1);
VAR9:=SMA(ABS(LOW-VAR8),3,1)/SMA(MAX(LOW-VAR8,0),3,1)*100;
VAR10:=EMA(IF(CLOSE*1.2,VAR9*10,VAR9/10),3);
VAR11:=LLV(LOW,38);
VAR12:=HHV(VAR10,38);
VAR13:=IF(LLV(LOW,90),1,0);
VAR14:=EMA(IF(LOW<=VAR11,(VAR10+VAR12*2)/2,0),3)/618*VAR13;
Cdxs:=HHV(VAR14,0)/90;
STICKLINE(VAR14,0,VAR14/Cdxs,3,0),colorlired;
////买卖波段////
VAR15:=SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,5,1);
波段线:=EMA(VAR15,3);
VAR16:=EMA(波段线,2);
VAR17:=EMA(VAR16,2);
VAR18:=CROSS(VAR16,VAR17);
VAR19:=CROSS(VAR17,VAR16);
抄底:=IF(CROSS(波段线,8) OR CROSS(波段线,15),波段线*3.0,0);
DRAWICON(VAR18 AND VAR16>20,0,1);
DRAWTEXT(抄底>1,8,'抄底'),colorred;
DRAWICON( VAR19,80,2);
////马上成功////
Hua:=(CLOSE - LLV(LOW,14)) / (HHV(HIGH,14) - LLV(LOW,14)) * 1.2 * CLOSE;
Nv1:=EMA(Hua,4);
Nv2:=EMA(Hua,8);
DRAWICON(CROSS(Nv1,Nv2) AND CLOSE/OPEN>1.05,3,1);
DRAWICON(CROSS(Nv2,Nv1) AND COUNT(CROSS(Nv1,Nv2) AND CLOSE/OPEN>1.05 ,20) ,85,2);
////必涨之星////
Hua2:=SMA(MAX(CLOSE-REF(CLOSE,1),0),16,2)/SMA(ABS(CLOSE/REF(CLOSE,1)),16,2)*100;
Xian=SMA(Hua2,3,1);
Nv3:=SMA(Xian,3,1);
XiNv=3*Xian-2*Nv3;
买入条件:=CROSS(XiNv,Nv3);
卖出条件:=CROSS(Nv3,XiNv);
DRAWICON( 卖出条件,82,2),coloryellow;
DRAWICON(买入条件,0,222),colorwhite;//必涨之星
Hxn:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);//花仙女涨停
DRAWTEXT(Hxn>90 AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1) AND COUNT(Hxn>90,30)=1,做多能量-7, '见涨'),,colorlired;
Hxjz:=MA((2*CLOSE+HIGH+LOW)/4,5);//花仙女绝招
Bztd:=Hxjz*89/100;
DRAWTEXT(CROSS(LOW,Bztd),22,'必涨'),colorred;
////花神////
花:=EMA(SLOPE(1,1)+C,3),colorred;
女:=EMA(SLOPE(1,1)+C,7),colorblue;
STICKLINE(花>女 ,1,2,12,0) ,colorred;//花神线,红色开始为买
STICKLINE(花<=女 ,1,2,12,0),colorgreen;//花神线,绿色开始为卖

同花顺机构方向主图指标公式

 

相关文章