在线检测未来函数

大智慧猎人主图指标公式

来源:Internet,编辑:股旁网,2015-08-10

DRAWGBK(c,'36' );LC:=CLOSE;
猎人:MA(LC,3);
猎人1:MA(LC,6);
猎人2:MA(LC,9);
猎人3:MA(LC,34);
猎人4:MA(LC,60);
猎人5:MA(LC,120);
PARTLINE(猎人,c>猎人,RGB(255,0,0),猎人>c,RGB(80,240,60)),LINETHICK1;
PARTLINE(猎人1,c>猎人1,RGB(255,0,0),猎人1>c,RGB(80,240,60)),LINETHICK1;
PARTLINE(猎人2,c>猎人2,RGB(255,0,0),猎人2>c,RGB(80,240,60)),LINETHICK1;
PARTLINE(猎人3,c>猎人3,RGB(255,0,0),猎人3>c,RGB(80,240,60)),LINETHICK1;
PARTLINE(猎人4,c>猎人4,RGB(255,0,0),猎人4>c,RGB(80,240,60)),LINETHICK1;
PARTLINE(猎人5,c>猎人5,RGB(255,0,0),猎人5>c,RGB(80,240,60)),LINETHICK1;
a:=(3*c+l+o+h)/6;
X:=WMA(a,20);
rcc:=DYNAINFO(3);
s2:=sma(c,3,1);
s6:=sma(c,5,1);
dk:=2*(s2-s6);
STICKLINE(dk>0,rcc,rcc+dk,0,1),COLORRED;
STICKLINE(dk<0,rcc,rcc+dk,0,1),COLORCYAN;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWTEXT(VAR19,L,'B'),COLORWHITE;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWTEXT(VAR1A,H*1.02,'S'),COLORYELLOW;
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(bu,LOW,'B'),ALIGN1,colorred,linethick3;
DRAWTEXT(bu,LOW,' ̄'),ALIGN1,Color208FFF,LINETHICK3;
DRAWTEXT(sel,HIGH,' ̄'),ALIGN1,ColorFFFF00,LINETHICK3;
DRAWTEXT(sel,HIGH,'S'),ALIGN1,colorgreen,linethick3;

大智慧猎人主图指标公式

 

相关文章