在线检测未来函数

通达信新极品量指标公式

来源:Internet,编辑:股旁网,2015-08-13

A股:CAPITAL/1000000,LINETHICK0,COLORWHITE;
成交量:VOL,POINTDOT,COLORYELLOW;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1,VVOL,0,-1,-1),COLOR00C0C0;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL /2)),POINTDOT,COLORRED;
主卖:IF(CLOSE>OPEN,AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,AA*(HIGH-LOW),VOL /2)),COLORCYAN,POINTDOT;
STICKLINE(C>=REF(C,1) ,0,VOL,2.2,1),COLORRED;
STICKLINE(C<REF(C,1),0,VOL,2.2,1),COLORCYAN;
STICKLINE(主买>0,0,主买,2.2,0),COLORRED;
资金异动:VOL/MA(VOL,55)*100,COLORYELLOW;
STICKLINE(主卖>0,0,主卖,0.8,0),COLORCYAN;
STICKLINE(资金异动>100 ,0,VOL,0.1,0),COLORYELLOW;
成交量比%:主买/VOL*100,COLORWHITE,NODRAW;
换手率%:VOL/CAPITAL*100,POINTDOT,COLORWHITE;
总手:VOL,NODRAW;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,'说明: 红色柱为吸货量,绿色为出货量,蓝色为地量'),COLORGRAY;
ZZ:=IF(REF(C,1)>REF(O,1) AND O>REF(C,1)*1.014 AND C<O*1.02,1,3);
V5:=MA(V,5);
V12:=MA(V,12);
V34:=MA(V,34);
C6:=MA(C,6);
STICKLINE(CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975,0,VOL,1,0),COLORRED;
STICKLINE(CROSS(C6,C) AND V>V5*1.2 AND V>V12*1.2,0,VOL,1,0),COLORGREEN;
STICKLINE(VOL<MA(VOL,13)/2 AND V<V12/2,0,VOL,1,0),COLORBLUE;
STICKLINE(VOL>MA(VOL,13)*2 AND V>V34*3 AND C<REF(C,1)*1.05 AND CROSS(C,C6) AND V>V5*1.2 AND V>V12*1.2 AND ZZ>2 AND C>H*0.975,VOL*0.5,0,1,0),COLORRED;
STICKLINE(VOL>MA(VOL,13)*2 AND V>V34*3 AND C<REF(C,1)*1.05 AND CROSS(C6,C) AND V>V5*1.2 AND V>V12*1.2,VOL*0.5,0,1,0),COLORRED;

通达信新极品量指标公式

 

相关文章