在线检测未来函数

大智慧五彩布林通道主图指标公式

来源:Internet,编辑:股旁网,2015-08-20

Var2:=REF(CLOSE-OPEN, 2);
Var3:=REF(CLOSE, 1);
Var4:=REF(CLOSE, 2);
Var5:=REF(CLOSE, 3);
Var6:=REF(CLOSE, 4);
Var7:=MAX(MAX(MAX(CLOSE, Var3), Var4), Var5);
Var8:=MIN(MIN(MIN(CLOSE, Var3), Var4), Var5);
持股1:STICKLINE(CLOSE=Var7 AND (Var3>=Var4 OR Var3>=Var5) OR Var3=Var7 AND (Var4=Var8 OR Var5=Var8) AND CLOSE>=Var4 OR Var4=Var7 AND Var5=Var8 AND CLOSE>=Var3 OR Var5=Var7 AND CLOSE>=Var3 AND CLOSE>=Var4,Var3,CLOSE,5,1), COLORRED;
红持股:红持股1,colorred;
品红变盘:STICKLINE(CLOSE=Var7 AND Var3=Var8, Var4, CLOSE, 5, 1), COLORff00ff;{MAGENTA;}
黄下跌:STICKLINE(CLOSE=Var8 AND (Var3<Var4 OR Var3<Var5) OR Var3=Var8 AND (Var4=Var7 OR Var5=Var7) AND CLOSE<Var4 OR Var4=Var8 AND Var5=Var7 AND CLOSE<Var3 OR Var5=Var8 AND CLOSE<Var3 AND CLOSE<Var4,Var3,CLOSE,5,0),COLOryellow;
绿买:STICKLINE(Var3=Var7 AND CLOSE=Var8, Var4, CLOSE, 5, 0), COLOR00ff00;{GREEN;}
STICKLINE(Var3=Var8 AND CLOSE>=Var4 OR (Var4=Var8 AND Var3<=Var5 OR Var5=Var8 AND Var3<=Var4) AND Var4<Var6 AND CLOSE>=Var3, Var3, Var4, 5, 0), COLOR00ff00;{GREEN;}
蓝卖:STICKLINE(Var3=Var7 AND CLOSE<Var4 OR (Var4=Var7 AND Var3>Var5 OR Var5=Var7 AND Var3>Var4) AND Var4>=Var6 AND CLOSE<Var3, Var3, Var4, 5, 1), COLORBLUE;
Var9:=SAR(5, 1, 5);
Var10:=EMA(CLOSE, 30);
Var11:=IF(CLOSE>450, 8, IF(CLOSE>=20 AND CLOSE<150, 0.200, IF(CLOSE<20 AND CLOSE>=10, 0.070, IF(CLOSE<10, 0.030, 0.070))));
变色龙:STICKLINE(CLOSE>Var9, Var10, Var10+Var11,6,0), COLORff00ff;
STICKLINE(CLOSE<Var9, Var10, Var10-Var11, 6, 0),COLORffcc66;
STICKLINE(CROSS(CLOSE, Var9), Var10, Var10-Var11,6,0);
STICKLINE(CROSS(Var9, CLOSE), Var10, Var10+Var11,6,0),COLORFF0066;
Var22:=MA(LLV(CLOSE,9)*1.1,14)*1;
Var33:=MA(HHV(CLOSE,26)*0.9,14)*1;
Var55:=EMA((HIGH+LOW+CLOSE)/3,3);
VarB:=AMOUNT/(100*VOL);
VarC:=MA(VarB,34);
VarD:=MA(CLOSE,26);
通道: (VarD+VarC)/2, pointdot, coloryellow;
阻力: VarD+2*STD(CLOSE,34),LINETHICK2 , COLORGREEN;
支持: (VarD-2*STD(CLOSE,26)),LINETHICK2 , colorgreen;
VarE:=MA(WINNER(CLOSE),34)*100;
警: DRAWTEXT(VarE>60 AND HIGH>阻力,HIGH,'★警'), COLORYELLOW;
突破:DRAWTEXT(VarE<15 AND CROSS(Var55,通道),LOW,'★突破'), colorwhite;

大智慧五彩布林通道主图指标公式

 

相关文章