在线检测未来函数

通达信美化版MACD指标公式

来源:Internet,编辑:股旁网,2015-08-24

SHORT:=9;
LONG:=26;
MID:=12;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK1;
DEA:=EMA(DIF,MID),LINETHICK2;
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLOR0000FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1,0),COLOR000066;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1,0),COLOR00CC33;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLOR006633;
DIFF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),LINETHICK1;
DEAA:EMA(DIF,MID),COLOR00FFFF,LINETHICK1;

通达信美化版MACD指标公式

 

相关文章