在线检测未来函数

飞狐抄底注意指标公式

来源:Internet,编辑:股旁网,2015-08-27

快线: (((C+L)/2-LLV(L,19))/(HHV(H,19)-LLV(L,19))*100)+20,COLORFFFFFF;
慢线:=(((C+L)/2-LLV(L,68))/(HHV(H,68)-LLV(L,68))*100)+20;
分析趋势:STICKLINE(慢线>82.8,108,103,6,1),COLORRED;
注意信号:STICKLINE(慢线<22.8,-1.5,-4,6,0),COLORRED;
综合判断:STICKLINE(快线>82.8,105,103,6,0),COLORMAGENTA;
控制风险:STICKLINE(快线<24.8,-9,-5,6,1),COLORMAGENTA;
STICKLINE(((MA(((C+L)/2-LLV(L,250))/(HHV(H,250)-LLV(L,250))*100,1)+20)*1.08)>96,110,108,6,0),COLORRED;
STICKLINE(((MA(((C+L)/2-LLV(L,250))/(HHV(H,250)-LLV(L,250))*100,1)+20)*1.08)<22.8,-10.5,-14,6,0),COLORRED;
防线:=EMA(((2*C+H+L)/4-LLV(L,31))/(HHV((H+C)/2,21)-LLV(L,31))*100,8);
均线:=SMA(防线,4,1);
PARTLINE(防线>REF(防线,1),防线),colorred,LINETHICK2;
PARTLINE(防线<REF(防线,1),防线),color00ff00,LINETHICK2;
PARTLINE(均线>REF(均线,1),均线),colorf00ff0;
PARTLINE(均线<REF(均线,1),均线),colorff0000;
中:=100-3*SMA(((C+L)/2-LLV(L,120))/(HHV((H+C)/2,120)-LLV(L,120))*100,29,1)+2*SMA(SMA(((C+L)/2-LLV(L,120))/(HHV((H+C)/2,120)-LLV(L,120))*100,29,1),62,1);
线:=中>IF(中>REF(中,1),中,中-5) AND EMA(((C+L)/2-LLV(L,3))/(HHV((H+C)/2,3)-LLV(L,3))*100,11)>=REF(EMA(((C+L)/2-LLV(L,3))/(HHV((H+C)/2,3)-LLV(L,3))*100,11),1);
趋:=MIN((C+L)/2,(MAX((C+L)/2,MAX((C+L)/2,EMA((C+L)/2,16)))));
势:=EMA(3*(H+L+C)/3-2*SMA((H+L+C)/3,2,1),14);
STICKLINE((IF((L+C+(H+C)/2)/3>势,(L+C+(H+C)/2)/3,势))>(REVERSE(IF((L+C+(H+C)/2)/3>势,(L+C+(H+C)/2)/3,势))+2*势),-28,-8,6,1),COLOR9933ff;
STICKLINE((中>IF(中>REF(中,1),中,中-3)) AND (趋=(MAX((C+L)/2,MAX((C+L)/2,EMA((C+L)/2,16))))),-28,-8,6,1),COLORYELLOW;
STICKLINE(线 AND (趋>=REF(趋,1) AND 趋=(MAX((C+L)/2,MAX((C+L)/2,EMA((C+L)/2,16))))),-28,-8,6,1),COLORRED;
STICKLINE(((EMA((C+L)/2,8)-EMA((C+L)/2,89))*100)<(-50) AND (((C+L)/2-REF((C+L)/2,1))/(REF((C+L)/2,1)))*(100)>2.28,-28,-8,6,1),COLOR008800;
控险区:STICKLINE((SMA(WINNER((L+(H+C)/2)/2),8,1)*100)>78.8,-18,-28,6,0),COLORFF972F;
强险区:STICKLINE((SMA(WINNER((L+(H+C)/2)/2),8,1)*100)>88.8,-8,-17,6,0),COLORBLUE;
DRAWTEXT(CROSS(((SMA(MAX((C+L)/2-REF((C+L)/2,1),0),5,1)/SMA(ABS((C+L)/2-REF((C+L)/2,1)),2,1)*34<8 AND SMA(MAX((C+L)/2-REF
((C+L)/2,1),0),1,1)/SMA(ABS((C+L)/2-REF((C+L)/2,1)),1,1)*100<1) AND (((C+L)/2)<REF((C+L)/2,86)-REF((C+L)/2,86)*0.29)
AND (SUM(IF(((C+L)/2)>REF((C+L)/2,1),VOL,0),2)/SUM(IF(((C+L)/2)<=REF((C+L)/2,1),VOL,0),1)*13<1) AND (((C+L)/2)<HHV(H,1)))*100,1),20,'神'),COLORred;
VAR1:=SMA(ABS(L-REF(L,1)),13,1)/SMA(MAX(L-REF(L,1),0),13,1)*100;
VAR2:=(EMA(IF(L<=LLV(L,34),(EMA(IF(C*1.2,VAR1*13,VAR1/13),13)+HHV(EMA(IF(C*1.2,VAR1*13,VAR1/13),13),34)*2)/2,0),3)/618*IF(LLV(L,56),1,0));
VAR3:=SMA(MAX((H+L+O+2*C)/5-REF((H+L+O+2*C)/5,1),0),10,1)/SMA(ABS((H+L+O+2*C)/5-REF((H+L+O+2*C)/5,1)),10,1)*100;
VAR4:=IF(COUNT(VAR3<20,5)>=1 AND COUNT((H+L+O+2*C)/5=LLV((H+L+O+2*C)/5,10),10)>=1 AND C>=O*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(VAR4 AND 防线<30,均线,'进?'),ALIGN1,LINETHICK2,COLORYELLOW;
买?:=REF(MA(L,2)*0.96,1)<MA(LOW,26)*0.85 AND REF(MA(L,2)*0.96,1)<MA(L,2)*0.96 AND REF(MA(L,2)*0.96,1)<REF(MA(L,2)*0.96,2);
DRAWICON(买?,-8,4),ALIGN1;
DRAWTEXT(买?,-19,'买?'),COLORFFFFFF,ALIGN1;
零:=SUM(IF((C+L)/2>REF((C+L)/2,1),VOL,IF((C+L)/2<REF((C+L)/2,1),0-VOL,0)),0);
轴:=IF((C+L)/2>LLV((C+L)/2,SUMBARS(VOL,CAPITAL)),1,-1);
信:=IF(零>LLV(零,SUMBARS(VOL,CAPITAL)),1,-1);
号:=IF((轴*信)=-1,1,0) AND (C+L)/2=LLV((C+L)/2,126);
IF(FILTER(号,3)=1,10,-7);
心:=((H+C)/2+L+(C+L)/2)/3;
中:=EMA((心-EMA(LLV(心,47),2))/(EMA(HHV(心,21),2)-EMA(LLV(心,47),2)),2)*90;
有:IF(CROSS(-1.8,中),7,-7),COLORYELLOW;
DRAWTEXT((CROSS(-3,中)),3,'3天内'),ALIGN1,COLORFFFFFF;
数:=EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)/8*10;
DRAWTEXT(CROSS(5,数),-7,'底部'),ALIGN1,COLORYELLOW;
进:=DMA((3*H+L+O+2*C)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100));
入:=MA(HHV(H,488),18);
底:=MA(HHV(H,220),18);
部:=MA(HHV(H,98),18);
区:=MA(LLV(L,488),18);
域:=MA(LLV(L,220),18);
注:=MA(LLV(L,98),18);
意:=MA((区*0.96+域*0.96+注*0.96+入*0.558+底*0.558+部*0.558)/6,18);
分:=MA((区*1.25+域*1.23+注*1.2+入*0.55+底*0.55+部*0.65)/6,18);
析:=MA((区*1.3+域*1.3+注*1.3+入*0.68+底*0.68+部*0.68)/6,18);
把:=IF(vol>0,MA((意*3+分*2+析)/6*1.738,18),MA((意*3+分*2+析)/6*1.738,18)*DAY);
握:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
控:=MA(IF(CLOSE*1.35<=把,握*10,握/10),3);
制:=IF(L<=LLV(L,30),(控+HHV(控,30)*2)/2,0);
抄底:((MA(制 AND C<COST(1),3) AND (C-进)/进*100<-11)*20)-7,COLOR00ff00;
注意:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
启动:=EMA(IF(L<=LLV(L,55),(EMA(IF(C*1.35,注意*10,注意/10),3)+HHV(EMA(IF(C*1.35,注意*10,注意/10),3),0)*2)/2,0),3)/618;
DIFF:=EMA((C+L)/2,3)-EMA((C+L)/2,5);
STICKLINE(IF(启动>5,12,启动)/3*5>0 AND (DIFF+1.9>EMA(DIFF+1.9,11)),40,IF(启动>5,12,启动)/3*5+40,1,0),LINETHICK2,COLORMAGENTA;

飞狐抄底注意指标公式

 

相关文章