在线检测未来函数

通达信提刀机构指标公式

来源:Internet,编辑:股旁网,2015-08-28

量能:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,20)*500;
HAN:=DATE<1151230;
金资:IF(量能>0,量能,0)*10*HAN,COLORMAGENTA,LINETHICK2;
行情:STICKLINE(量能>0,量能*4,0,3.8,0)*800000*HAN,COLOR000555;
STICKLINE(量能>0,量能*4,0,2.7,0)*800000*HAN,,COLOR000777;
STICKLINE(量能>0,量能*4,0,1.9,0)*800000*HAN,COLOR000999;
STICKLINE(量能>0,量能*4,0,1.3,0)*800000*HAN,COLOR000BBB;
STICKLINE(量能>0,量能*4,0,0.1,0)*800000*HAN,COLOR000DDD;
STICKLINE(量能<0,0,量能*4,3,0)*800000*HAN,COLOR005500;
STICKLINE(量能<0,0,量能*4,2.3,0)*800000*HAN,COLOR007700;
STICKLINE(量能<0,0,量能*4,1.6,0)*800000*HAN,COLOR009900;
STICKLINE(量能<0,0,量能*4,0.8,0)*800000*HAN,COLOR00BB00;
STICKLINE(量能<0,0,量能*4,0.1,0)*800000*HAN,COLOR00DD00;
主力:EMA(EMA(量能,30),3)*20*HAN,COLORGREEN;
乖离:=(C-MA(C,5))/MA(C,5)*1000,LINETHICK2;
主力S:IF(主力>REF(主力,1),主力,DRAWNULL)*HAN,COLORRED,LINETHICK2;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
专用:=3*Q3-2*Q4;
Q8:=HHVBARS(HIGH, 50);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
顶:=STICKLINE(CROSS(专用, 8) AND Q10<-13, 0,340,10,0);
底顶:=FILTER(顶,50);
跨越:=EMA(Q3, 3);
DRAWTEXT(FILTER(CROSS(跨越,专用) AND REF(专用,1)>80 AND 跨越>80,20)*HAN, -150,'..庄家逃跑'),COLORWHITE ,LINETHICK5;
AA:=STICKLINE(CROSS(跨越,专用) AND REF(专用,1)>80 AND 跨越>80, 0,270,10,0);
底顶A:=FILTER(AA,30);
STICKLINE(底顶A, 0,-150,5,-1)*HAN,COLOR000077;
STICKLINE(底顶A, 0,-150,4,-1)*HAN,COLOR000099;
STICKLINE(底顶A, 0,-150,3,-1)*HAN,COLOR0000BB;
STICKLINE(底顶A, 0,-150,2,-1)*HAN,COLOR0000DD;
STICKLINE(底顶A, 0,-150,1,-1)*HAN,COLOR0000FF;
V3:=100-(100-3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1)+2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1),15,1));
V4:=100-(100-3*SMA((O-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1)+2*SMA(SMA((O-LLV(L,55))/(HHV(H,55)-LLV(L,55))
*100,20,1),15,1));
T7:=V3>REF(V4,1) AND V>REF(V,1) AND C>REF(C,1);
风:=STICKLINE(T7 AND COUNT(T7,30)=1,0,20,2,0);
风A:=STICKLINE(底顶 OR 风, 0,270,5,0) ;
风AA:=FILTER(风A,20);
STICKLINE(风AA, 0,260,5,0)*HAN,COLORFF11FF;
STICKLINE(风AA, 0,260,4,0)*HAN,COLORFF33FF;
STICKLINE(风AA, 0,260,3,0)*HAN,COLORFF55FF;
STICKLINE(风AA, 0,260,2,0)*HAN,COLORFF77FF;
STICKLINE(风AA, 0,260,1,0)*HAN,COLORFF99FF;
DRAWTEXT(FILTER(风AA,20),250,'..庄家出现')*HAN,COLORYELLOW,LINETHICK5;
V1:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
V2:=2*ABS(V1);
V5:=(H+L+C)/3;
V6:=(V5-MA(V5,10))/(0.015*AVEDEV(V5,10));
V7:=(V5-MA(V5,30))/(0.015*AVEDEV(V5,30));
V8:=IF(V6>=150 AND V6<200 AND V7>=150 AND V7<200,10,0);
V9:=IF(V6<=-150 AND V6>-200 AND V7<=-150 AND V7>-200,-10,V8);
VA:=(C-MA(C,13))/MA(C,13)*100;
VB:=100-ABS(VA);
VC:=3*SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1)-2
*SMA(SMA((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55))*100,20,1),15,1);
顶线:= IF(VB<90,VB,100);
多方:= IF(V1>0,V1,0);
空方:= -IF(V1<0,V2,0);
预警系统:= (IF((V7>=200 AND V6>=150) OR CROSS(65,多方),15,IF(V7<=-200 AND V6<=-150,-15,V9))+65);
T1:=C>MA(C,20) AND MA(C,20)>=REF(MA(C,20),1);
T3:=多方>60 AND 预警系统>65 AND 顶线=100;
T4:=多方>48 AND 预警系统>65 AND 顶线<100;
T8:=V3<=REF(V4,1) AND C AND 空方>=REF(空方,1) AND VC*HAN;
DRAWTEXT(T1 AND COUNT(T1,30)=1,-150,'上升通道!')*HAN,COLOR00FFFF;

通达信提刀机构指标公式

 

相关文章