在线检测未来函数

飞狐股指佛手箱主图指标公式

来源:Internet,编辑:股旁网,2015-09-13

【H】:HHV(HIGH,14),LINETHICK3,COLORWHITE;
【L】:LLV(LOW,14),LINETHICK3,COLORWHITE;
T:(【H】+【L】)/2 ,LINETHICK1,COLORWHITE;
STICKLINE(C>=COST(50)AND C<=COST(58)AND C>O,O,C,2,0),COLORRED;
STICKLINE(C>=COST(97)AND C<=COST(100)AND C>O,O,C,2,0),COLORWHITE;
DRAWTEXT(C>=COST(97)AND C<=COST(100) AND C>O,C,'--获利大于97%'),COLORRED;
DRAWTEXT(C>=COST(50)AND C<=COST(58) AND C>O,C,'--获利50%'),COLORYELLOW;
JJ:=(H+L+3*C)/5;
VAR21:=EMA(JJ,5);VAR22:=EMA(JJ,13);VAR23:=EMA(JJ,21);VAR24:=EMA(JJ,34);H1A:=(VAR21+VAR22+VAR23+VAR24)/4;
成本和谐:MA(H1A,5),COLORRED,LINETHICK0;
LL:=LLV(C,100);
TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);
STICKLINE(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),10,0),COLORGREEN,LINETHICK1;
黄昏之星:=((((((REF(CLOSE,2) / REF(OPEN,2)) > 1.03) AND (REF(OPEN,1) >
REF(CLOSE,2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) /
REF(CLOSE,1)) < 0.02)) AND ((CLOSE / OPEN) < 0.97)) AND (CLOSE <REF(CLOSE,2)));
射击之星:=(((MIN(OPEN,CLOSE) = LOW) AND ((HIGH - LOW) > (3 *
(MAX(OPEN,CLOSE) - LOW)))) AND (CLOSE > MA(CLOSE,5)));
锤头:=(((HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH -
MIN(OPEN,CLOSE))))) AND (CLOSE < MA(CLOSE,5)));
吊颈:=(( (HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH -
MIN(OPEN,CLOSE))))));
穿头破脚:=((((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN)
< 0.96)) AND (CLOSE < REF(OPEN,1))) AND (OPEN > REF(CLOSE,1))) OR
(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
1.04)) AND (CLOSE > REF(OPEN,1))) AND (OPEN < REF(CLOSE,1))));
身怀六甲:=(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04)
AND ((ABS((CLOSE - OPEN)) / CLOSE) < 0.005)) AND (MAX(CLOSE,OPEN) <
MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1))));
乌云盖顶:=(((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) <
0.97)) AND (OPEN > REF(CLOSE,1))) AND (CLOSE < REF(CLOSE,1)));
曙光初现:=(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1)));
倾盆雨:=(((((REF(CLOSE,1) / REF(OPEN,1)) >= 1.03) AND (OPEN <
REF(CLOSE,1))) AND (OPEN > REF(OPEN,1))) AND (CLOSE < REF(OPEN,1)));
DRAWTEXT(倾盆雨,H*1.03,'倾盆大雨'),COLORCYAN;
DRAWTEXT(黄昏之星,H*1.02,'黄昏之星'),COLORCYAN;
DRAWTEXT(射击之星,H*1.03,'射击之星高位见顶'),COLORCYAN;
DRAWTEXT(锤头,L-L*0.02,'锤头低位见底'),COLORGREEN;
DRAWTEXT(吊颈,H*1.03,'吊颈高位见顶'),COLORCYAN;
DRAWTEXT(穿头破脚,H*1.05,'穿头破脚'),COLORCYAN;
DRAWTEXT(乌云盖顶,H*1.03,'乌云盖顶'),COLORCYAN;
DRAWTEXT(曙光初现,L-L*0.02,'曙光初现(放量见涨)'),COLORGREEN;
DRAWTEXT(身怀六甲,L-L*0.02,'身怀六甲,底升顶落'),COLORGREEN;
阳长下影线:=(O-L)/O>0.06 AND C>O;
阴长下影线:=(C-L)/C>0.06 AND C<O;
阳长上影线:=(H-C)/C>0.06 AND C>O;
阴长上影线:=(H-O)/O>0.06 AND C<O;
光头阳长下影线:=C=H AND (O-L)/O>0.06 AND C>O;
光脚阴长上影线:=C=L AND (H-O)/O>0.06 AND C<O;
白色十字星:=C=O AND H>C AND C>L;
DRAWTEXT(阳长下影线,H*1.01,'阳长下影线'),COLORCYAN;
DRAWTEXT(阴长下影线,H*1.04,'阴长下影线'),COLORWHITE;
DRAWTEXT(阳长上影线,H*1.06,'阳长上影线'),COLORRED;
DRAWTEXT(光头阳长下影线,H*1.07,'光头阳长下影线'),COLORCYAN;
DRAWTEXT(光脚阴长上影线,H*1.08,'光脚阴长上影线'),COLORYELLOW;
DRAWTEXT(白色十字星,H*1.02,'白色十字星'),COLORWHITE;
S下:=HHV(MA(HIGH,2),2),COLORGREEN,LINETHICK0;
S上:=LLV(MA(HIGH,2),1),COLORRED,LINETHICK0;
SPPP:=-(S上-S下)/REF(C,1)*100;
SPTEM1:=(MIN(O,C)-L)/(H-L)*100;
SPTEM2:=(H-MAX(O,C))/(H-L)*100;
SPTEM3:=(C-O)/(H-L)*100;
SKJ1:=(SPTEM3>49 AND SPTEM1>0.3*SPTEM2) OR SPTEM3>80;
SKJ2:=(SPTEM3<=49 AND SPTEM3>20 AND SPTEM1>SPTEM2);
SKJ3:=(SPTEM3<=20 AND SPTEM3>-20 AND SPTEM1>1.2*SPTEM2);
SKJ4:=(SPTEM3<-20 AND SPTEM3>-40 AND SPTEM1>2*SPTEM2);
SKJ:=(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4) AND (SPPP>2 OR REF(SPPP,1)>2 );
短买:=IF(SUM(SPPP>0,5)=5 AND SUM(SKJ>0,5)=0,5*(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4),5*SKJ),COLORRED;
DRAWTEXT(短买,L,'短买'),COLORWHITE;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)<10 AND H>REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,2,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,2,0),COLORFF00FF;
天量:=VOL=HHV(VOL,0);
DRAWTEXT(天量,C,'-------高位天量卖'),COLORYELLOW;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9,C,'---------二次BIAS乖离底买'),COLORGREEN;
COST(50),COLORGREEN,CIRCLEDOT;
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波浪顶:IF(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK1;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
波浪底:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK1;

飞狐股指佛手箱主图指标公式

 

相关文章