在线检测未来函数

飞狐价格预测主图指标公式

来源:Internet,编辑:股旁网,2015-09-15

CJHD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
CJLD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
CJA:=REF(C,BARSLAST(CJHD));
CJB:=REF(C,BARSLAST(CJLD));
CJT1:=BARSLAST(CJHD)<BARSLAST(CJLD) AND NOT(CJHD) ;
CJT2:=BARSLAST(CJHD)>BARSLAST(CJLD) AND NOT(CJLD);
{波浪顶}
STICKLINE(CJT1,CJA,CJA,3,0),COLORFF00FF;
{波浪底}
STICKLINE(CJT2,CJB,CJB,3,0),COLORFF00FF;
统计天数:=BARPOS-hhv(if(BARSTATUS=1,BARPOS,0),0)+1;
预测价格:=LLV(C,统计天数)*1.1618;
高点:=HHV(C,统计天数);{H}
低点:=LLV(C,统计天数);{L}
压力支撑50:高点-(高点-低点)*0.5,Linethick1,colorgreen;;
支撑357:=高点-(高点-低点)*0.35765;
支撑642:=高点-(高点-低点)*0.6423;
压力357:=低点+(高点-低点)*0.35765;
压力642:=低点+(高点-低点)*0.6423;
牛顶:=低点+(高点-低点)*(1+0.618);
熊底:=ABS( 高点-(高点-低点)*(1+0.618) );
高点跌幅:=( HHV(C,统计天数) -C )/HHV(C,统计天数);
低点涨幅:=( C -LLV(C,统计天数) )/LLV(C,统计天数);
止跌:= HHV(C,统计天数) * 0.6;
DRAWTEXTEX(c,1,10,0, '低点涨幅:'+NUMTOSTR(低点涨幅,2) +'; ' +'高点跌幅:'+NUMTOSTR(高点跌幅,2) +'; ' +'高点40%止跌:'+NUMTOSTR(止跌,2) +'; ' + '预测:'+NUMTOSTR(预测价格,2) +'; '+'压支50%:'+NUMTOSTR(压力支撑50,2)),color00EEFF;
DRAWTEXTEX(c,1,10,50, '牛顶:'+NUMTOSTR(牛顶,2) +'; '+'熊底:'+NUMTOSTR(熊底,2) +'; '+ '压36%:'+NUMTOSTR(压力357,2)+'; '+'压64%:'+NUMTOSTR(压力642,2));
DRAWTEXTEX(c,1,10,100, '支36%:'+NUMTOSTR(支撑357,2)+'; '+'支64%:'+NUMTOSTR(支撑642,2));

飞狐价格预测指标公式

 

相关文章