在线检测未来函数

飞狐出色超赢主图指标公式

来源:Internet,编辑:股旁网,2015-09-21

JRH:=HHV(C,2); JRL:=LLV(C,2); MAMA3:=MA(CLOSE,3); YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6; VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1); VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD); 红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,LINETHICK; 离场:=IF(红色持股,JRL,0); 明离场价:=离场,COLORFF99FF,LINETHICK; 今离场价:=REF(离场,1)COLOR0000FF,LINETHICK; 青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,LINETHICK; 进:=IF(青色观望,JRH,0); 明进场价:=进,COLOR33AACC,LINETHICK; 今进场价:=REF(明进场价,1),COLORFF0000,LINETHICK; 黄色低买:VAR19,COLOR33AACC,LINETHICK; 洋红离场:VAR1A,COLORMAGENTA,LINETHICK; 急跌关注:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORWHITE,LINETHICK; 上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),LINETHICK,COLOR0000FF; 月:REF(MONTH,BARSCOUNT(CLOSE)-1),LINETHICK,COLORFF00FF; 日:REF(DAY,BARSCOUNT(CLOSE)-1),LINETHICK,COLOR00FFFF; STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF; STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00; STICKLINE(C>=O,L,H,0.1,0),COLOR0000CC; STICKLINE(C<O,L,H,0.1,0),COLOR999900; STICKLINE(1,C,O,7,0),COLOR858500; STICKLINE(C>=O,C,O,7,0),COLOR0000E5; STICKLINE(红色持股,CLOSE,O,5.6,0),COLOR000055; STICKLINE(红色持股,CLOSE,O,4,0),COLOR000088; STICKLINE(红色持股,CLOSE,O,3,0),COLOR0000AA; STICKLINE(红色持股,CLOSE,O,2,0),COLOR0000CC; STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000EE; STICKLINE(青色观望,CLOSE,O,5.6,0),COLOR555500; STICKLINE(青色观望,CLOSE,O,4,0),COLOR888800; STICKLINE(青色观望,CLOSE,O,3,0),COLORAAAA00; STICKLINE(青色观望,CLOSE,O,2,0),COLORCCCC00; STICKLINE(青色观望,CLOSE,O,1,0),COLOREEEE00; CO:=(C-O); STICKLINE(急跌关注,O,C-CO/2,5.6,0),COLOR555555; STICKLINE(急跌关注,O,C-CO/2,4,0),COLOR888888; STICKLINE(急跌关注,O,C-CO/2,2,0),COLORAAAAAA; STICKLINE(急跌关注,O,C-CO/2,2,0),COLORCCCCCC; STICKLINE(急跌关注,O,C-CO/2,1,0),COLOREEEEEE; STICKLINE(黄色低买,O,O+CO/3,5.6,0),COLOR335555; STICKLINE(黄色低买,O,O+CO/3,4,0),COLOR338888; STICKLINE(黄色低买,O,O+CO/3,3,0),COLOR33AAAA; STICKLINE(黄色低买,O,O+CO/3,2,0),COLOR33CCCC; STICKLINE(黄色低买,O,O+CO/3,1,0),COLOR33EEEE; STICKLINE(洋红离场,O,O+CO/3,5.6,0),COLOR550055; STICKLINE(洋红离场,O,O+CO/3,4,0),COLOR880088; STICKLINE(洋红离场,O,O+CO/3,3,0),COLORAA00AA; STICKLINE(洋红离场,O,O+CO/3,2,0),COLORCC00CC; STICKLINE(洋红离场,O,O+CO/3,1,0),COLOREE00EE; 压力:MA(REF(HHV(C,30),1),2),POINTDOT,COLOR9DFFFF,LINETHICK3; 支撑:MA(REF(LLV(C,30),1),2),POINTDOT,COLORABFF46,LINETHICK3; PMA:MA(C,5),COLORWHITE,LINETHICK2; PARTLINE(PMA>REF(PMA,1),PMA),COLORRED,LINETHICK2; PARTLINE(PMA<REF(PMA,1),PMA),COLORGREEN,LINETHICK2; X:=(3*C+L+O+H)/6; 多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6) +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12) +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+ REF(X,20))/210,COLORFF00FF,LINETHICK2; DD:=多空线<REF(多空线,1); PARTLINE(DD,多空线),COLOR00FFFF,LINETHICK2; A:=(PMA>多空线); PARTLINE(A,多空线),POINTDOT,COLOR33FF33,LINETHICK3; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:=SMA(RSV,9,1); D:=SMA(K,9,1); J:=3*K-2*D; X2:=LLV(J,2)=LLV(J,8); Y:=IF(CROSS(J,REF(J+0.01,1)) AND X2 AND J<20,30,0); DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X2 AND J<20,LOW*0.98,'★'),COLORYELLOW;

飞狐出色超赢主图指标公式

 

相关文章