在线检测未来函数

通达信江恩时空百分比主图指标公式

来源:Internet,编辑:股旁网,2015-09-22

N:=6000;
高:=REFDATE(HHV(H,N),DATE);
低:=REFDATE(LLV(L,N),DATE);
H11:=高-(高-低)*1.000;
H10:=高-(高-低)*0.875;
H9:=高-(高-低)*0.750;
H8:=高-(高-低)*0.666;
H7:=高-(高-低)*0.625;
H6:=高-(高-低)*0.500;
H5:=高-(高-低)*0.375;
H4:=高-(高-低)*0.333;
H3:=高-(高-低)*0.250;
H2:=高-(高-低)*0.125;
H1:=高-(高-低)*0.000;
STICKLINE(CURRBARSCOUNT=18,高,高,120,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=18,H1,H1,120,1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=18,H2,H2,120,1),COLORCCCCCC;
DRAWTEXT(CURRBARSCOUNT=10,H1,'0.000'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=10,H2,' 0.125'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=10,H3,' 0.250'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=10,H4,' 0.333'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=10,H5,' 0.375'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,H6,' 0.500'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=10,H7,' 0.625'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=10,H8,' 0.666'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=10,H9,' 0.750'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=10,H10,' 0.875'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=10,H11,' 1.000'),COLORGREEN;
STICKLINE(CURRBARSCOUNT=18,H3,H3,120,1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=18,H4,H4,120,1),COLORLIRED;
STICKLINE(CURRBARSCOUNT=18,H6,H6,120,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=18,H5,H5,120,1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=18,低,低,120,1),COLORRED;
STICKLINE(CURRBARSCOUNT=18,H7,H7,120,1),COLORRED;
STICKLINE(CURRBARSCOUNT=18,H8,H8,120,1),COLORRED;
STICKLINE(CURRBARSCOUNT=18,H9,H9,120,1),COLORRED;
STICKLINE(CURRBARSCOUNT=18,H10,H10,120,1),COLORRED;
STICKLINE(CURRBARSCOUNT=18,H11,H11,120,1),COLORRED;
DRAWTEXT(CURRBARSCOUNT=35,高*0.99,CON2STR(高,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=35,H11,CON2STR(H11,2)),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=35,H10,CON2STR(H10,2)),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=35,H9,CON2STR(H9,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=35,H8,CON2STR(H8,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=35,H1,CON2STR(H1,2)),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=35,H2,CON2STR(H2,2)),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=35,H3,CON2STR(H3,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=35,H6,CON2STR(H6,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=35,H4,CON2STR(H4,2)),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=35,H5,CON2STR(H5,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=35,H7,CON2STR(H7,2)),COLORRED;
低点:=800;
高点:=800;
时间:=1;
价格:=1;
调点:=1;
PURC:=CONST(FINDHIGH(H,0,高点*10,1));
PLZ:=CONST(BARSLAST(PURC=H))+1;
顶X:=CONST(IF(PLZ=1,H,REF(H,PLZ-1)));
QQT:=CONST(FINDLOW(L,0,低点*10,1));
PLL:=CONST(BARSLAST(QQT=L))+1;
低X:=CONST(IF(PLL=1,L,REF(L,PLL-1)));
ATM:=时间=2 OR 时间=2;
QTM:=时间=1 OR 时间=1;
BTM:=时间=1 OR 时间=1 OR 时间=1;
AAZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.809),DRAWNULL);
ABZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.5),DRAWNULL);
ACZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.618),DRAWNULL);
ADZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.382),DRAWNULL);
AEZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*0.236),DRAWNULL);
AFZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1),DRAWNULL);
AGZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.809),DRAWNULL);
AHZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.5),DRAWNULL);
AIZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.618),DRAWNULL);
AJZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.382),DRAWNULL);
AKZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1.236),DRAWNULL);
ALZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2),DRAWNULL);
AMZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.236),DRAWNULL);
ANZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.382),DRAWNULL);
AOZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.5),DRAWNULL);
APZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.618),DRAWNULL);
AQZ:=IF(ATM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2.809),DRAWNULL);
ARZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*3),DRAWNULL);
ASZ:=IF(BTM,ROUND(IF(PLZ>PLL,PLZ,PLL)),DRAWNULL);
HXCS1:=CURRBARSCOUNT=AAZ OR CURRBARSCOUNT=ABZ OR CURRBARSCOUNT=ACZ OR CURRBARSCOUNT=ADZ
OR CURRBARSCOUNT=AEZ OR CURRBARSCOUNT=AFZ OR CURRBARSCOUNT=AGZ OR CURRBARSCOUNT=AHZ
OR CURRBARSCOUNT=AIZ OR CURRBARSCOUNT=AJZ OR CURRBARSCOUNT=AKZ OR CURRBARSCOUNT=ALZ
OR CURRBARSCOUNT=AMZ OR CURRBARSCOUNT=ANZ OR CURRBARSCOUNT=AOZ
OR CURRBARSCOUNT=APZ OR CURRBARSCOUNT=AQZ OR CURRBARSCOUNT=ARZ OR CURRBARSCOUNT=ASZ;
QAZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1/8),DRAWNULL);
QBZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2/8),DRAWNULL);
QCZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*3/8),DRAWNULL);
QDZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*4/3),DRAWNULL);
QEZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*5/8),DRAWNULL);
QGZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*6/8),DRAWNULL);
QHZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*7/8),DRAWNULL);
QIZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*9/8),DRAWNULL);
QJZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*1/3),DRAWNULL);
QKZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*2/3),DRAWNULL);
QMZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*10/8),DRAWNULL);
QNZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*11/8),DRAWNULL);
QOZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*5/3),DRAWNULL);
QPZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*13/8),DRAWNULL);
QQZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*14/8),DRAWNULL);
QRZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*15/8),DRAWNULL);
QSZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*17/8),DRAWNULL);
QTZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*18/8),DRAWNULL);
QUZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*19/8),DRAWNULL);
QVZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*21/8),DRAWNULL);
QWZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*22/8),DRAWNULL);
QXZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*23/8),DRAWNULL);
QYZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*7/3),DRAWNULL);
QZZ:=IF(QTM,ROUND(IF(PLZ>PLL,PLZ,PLL)-ABS(PLZ-PLL)*8/3),DRAWNULL);
HXCS2:=CURRBARSCOUNT=QAZ OR CURRBARSCOUNT=QBZ OR CURRBARSCOUNT=QCZ
OR CURRBARSCOUNT=QDZ OR CURRBARSCOUNT=QEZ OR CURRBARSCOUNT=QGZ
OR CURRBARSCOUNT=QHZ OR CURRBARSCOUNT=QIZ OR CURRBARSCOUNT=QJZ
OR CURRBARSCOUNT=QKZ OR CURRBARSCOUNT=QMZ OR CURRBARSCOUNT=QNZ
OR CURRBARSCOUNT=QOZ OR CURRBARSCOUNT=QPZ OR CURRBARSCOUNT=QQZ
OR CURRBARSCOUNT=QRZ
OR CURRBARSCOUNT=QSZ OR CURRBARSCOUNT=QTZ OR CURRBARSCOUNT=QUZ
OR CURRBARSCOUNT=QVZ OR CURRBARSCOUNT=QWZ OR CURRBARSCOUNT=QXZ
OR CURRBARSCOUNT=QYZ OR CURRBARSCOUNT=QZZ ;
STICKLINE(HXCS1 OR HXCS2 ,顶X,低X,0,0),COLORMAGENTA;
DRAWKLINE(H,O,L,C);
天XX线:=IF(价格=5 AND 时间=5,DRAWNULL,顶X),COLORMAGENTA;
地XX线:=IF(价格=5 AND 时间=5,DRAWNULL,低X),COLORMAGENTA;
顶点:天XX线,COLORMAGENTA;
底点:地XX线,COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QAZ OR CURRBARSCOUNT=QIZ OR CURRBARSCOUNT=QSZ,顶X*0.98,'1/8')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QBZ OR CURRBARSCOUNT=QMZ OR CURRBARSCOUNT=QTZ,顶X*0.98,'2/8')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QCZ OR CURRBARSCOUNT=QNZ OR CURRBARSCOUNT=QUZ,顶X*0.98,'3/8')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QEZ OR CURRBARSCOUNT=QPZ OR CURRBARSCOUNT=QVZ,顶X*0.98,'5/8')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QGZ OR CURRBARSCOUNT=QQZ OR CURRBARSCOUNT=QWZ,顶X*0.98,'6/8')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QHZ OR CURRBARSCOUNT=QRZ OR CURRBARSCOUNT=QXZ,顶X*0.98,'7/8')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QJZ OR CURRBARSCOUNT=QDZ OR CURRBARSCOUNT=QYZ,顶X*0.98,'1/3')COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=QKZ OR CURRBARSCOUNT=QOZ OR CURRBARSCOUNT=QZZ,顶X*0.98,'2/3')COLORMAGENTA;

通达信江恩时空百分比主图指标公式

 

相关文章