在线检测未来函数

飞狐控盘成本主图指标公式

来源:Internet,编辑:股旁网,2015-09-29

input:m(88,1,200),n(6,1,200),p1(28,20,32),p2(32,30,35),p3(35,35,38),w(3,0,20),e(20,0,100);
var1:=ema(amount/v/100,3);
控盘成本:ema(var1,m);
低吸伏击:ema(var1,m)*0.85,Linethick2,colorffff00;
走势铁底:低吸伏击*0.87,Linethick3,colorff00ff;
var2:=l<=走势铁底 and c>ref(c,1)*1.02;
控盘成本,Linethick2,colorred;
drawicon(控盘成本 AND filter(var2,n),l,1),coloryellow;
A1:=3*eMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*eMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A2:=LLV(L,21);
a3:LLV(L,30);
a4:=EMA(A1,5);
A5:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
dif:="macd.diff"(12,26,9);
dea:="macd.dea"(12,26,9);
基础:=( dif<-0.1 and dif>dea),COLORyellow;
中线买入:CROSS(A1,a4)AND (A5-a4)>40 and 基础,COLORred;
STICKLINE(CROSS(A1,a4)AND (A5-a4)>40 and 基础 ,a3,a3*1.2,4,0),COLORred;
VAR10:=IF(DATE<1500830 AND DATE>900101,1,0);
VAR20:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
K1:=(P1/10)*VAR1*100;
K2:=(P2/10)*VAR1*100;
K3:=(P3/10)*VAR1*100;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1),COLORFFFFFF;
D:=SMA(K,3,1),COLOR00FFFF;
J:=3*K-2*D,COLORFF00FF;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0),COLOR00FF00;
主力:=EMA( (CLOSE-MA(CLOSE,n))/MA(CLOSE,n)*4800,2);
散户:=EMA( (CLOSE-MA(CLOSE,m))/MA(CLOSE,m)*4800,7);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1,COLORA0A0FF;
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF;
DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见 底'),COLORRED;
DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);

飞狐控盘成本主图指标公式

 

相关文章