在线检测未来函数

通达信拨开云天主图指标公式

来源:Internet,编辑:股旁网,2015-09-29

MM5:=5;
MM10:=10;
MM20:=20;
MM30:=30;
MM40:=0;
MM60:=0;
NC:=14;
M3:=MA(O,3),COLORBLUE;
M5:=MA(O,5),COLORBLUE;
M10:=MA(O,10),COLORGREEN;
M20:=MA(O,20),COLORCYAN;
M30:=MA(O,30),COLORRED;
M40:=MA(O,40),COLORMAGENTA;
M60:=MA(O,60),COLORLIGRAY;
M80:=MA(O,80),COLORGRAY;
M90:=MA(O,90),COLORLIBLUE;
M120:=MA(O,120),COLORLIGREEN;
M180:=MA(O,180),COLORLIRED;
M270:=MA(O,270),COLORLIRED;
M360:=MA(O,360),COLORLIMAGENTA;
M480:=MA(O,480),COLORYELLOW;
M540:=MA(O,540),COLORWHITE;
M640:=MA(O,640),COLORBLUE;
M720:=MA(O,BARSCOUNT(L)*0.1),COLORGREEN;
M810:=MA(O,BARSCOUNT(L)*0.2),COLORCYAN;
M960:=MA(O,BARSCOUNT(L)*0.3),COLORLIGRAY;
M1080:=MA(O,BARSCOUNT(L)*0.4),COLORLIRED;
M1440:=MA(O,BARSCOUNT(L)*0.5),COLORLIGRAY;
M1920:=MA(O,BARSCOUNT(L)*0.6),COLORLIMAGENTA;
M2160:=MA(O,BARSCOUNT(L)*0.7),COLORBROWN;
M2560:=MA(O,BARSCOUNT(L)*0.8),COLORCYAN;
M3240:=MA(O,BARSCOUNT(L)*0.9),COLORRED;
M4320:=MA(O,BARSCOUNT(L)*1),COLORMAGENTA;
MLLV:=MA(LLV(L,BARSCOUNT(L)*0.1),100);
MHHV:=MA(HHV(H,BARSCOUNT(H)*0.1),100);
MAZZQ:=MA(L,BARSCOUNT(L)),COLORGRAY,LINETHICK3;
B5:=MIN(M5,M3),LINETHICK3,COLORLIGRAY;
B10:=MIN(M10,B5),COLORBLUE;
B20:=MIN(M20,B10),COLORBLUE;
B30:=MIN(M30,B20),COLORGREEN;
B720:=MIN(M720,B30),COLORLIRED;
B810:=MIN(M810,B720),COLORLIMAGENTA;
B960:=MIN(M960,B810),COLORLIMAGENTA;
B1080:=MIN(M1080,B960),COLORLIMAGENTA;
B1440:=MIN(M1440,B1080),COLORYELLOW;
B1920:=MIN(M1920,B1440),COLORYELLOW;
B2160:=MIN(M2160,B1920),COLORYELLOW;
B2560:=MIN(M2560,B2160),COLORWHITE;
B3240:=MIN(M3240,B2560),COLORGREEN;
B4320:=MIN(M4320,B3240),COLORGREEN;
BMAZZQ:=MIN(MAZZQ,B4320),COLORBLUE,LINETHICK2;
BMLLV:MIN(MLLV,BMAZZQ),COLORLIGRAY,LINETHICK2;
S5:=MAX(M5,M3),LINETHICK3,COLORLIMAGENTA;
S10:=MAX(M10,S5),COLORRED;
S20:=MAX(M20,S10),COLORBLUE;
S30:=MAX(M30,S20),COLORGREEN;
S720:=MAX(M720,S30),COLORLIRED;
S810:=MAX(M810,S720),COLORLIMAGENTA;
S960:=MAX(M960,S810),COLORLIMAGENTA;
S1080:=MAX(M1080,S960),COLORLIMAGENTA;
S1440:=MAX(M1440,S1080),COLORYELLOW;
S1920:=MAX(M1920,S1440),COLORYELLOW;
S2160:=MAX(M2160,S1920),COLORYELLOW;
S2560:=MAX(M2560,S2160),COLORWHITE;
S3240:=MAX(M3240,S2560),COLORGREEN;
S4320:=MAX(M4320,S3240),COLORGREEN;
SMAZZQ:=MAX(MAZZQ,S4320),COLORRED,LINETHICK2;
SMHHV:MAX(MHHV,SMAZZQ),COLORLIGRAY,LINETHICK2;
MA5:MA(C,MM5),COLORBLUE;
MA10:MA(C,MM10),COLORGREEN;
MA20:MA(C,MM20),COLORCYAN;
MA30:MA(C,MM30),COLORRED;
MA40:MA(C,MM40),COLORMAGENTA;
MA60:MA(C,MM60),COLORLIGRAY;
HV1N :=(H-BMLLV)/H;
LV1N :=L/SMHHV;
QUL20:=RANGE(LV1N,0.7,0.80);
QUL30:=RANGE(LV1N,0.6,0.70);
QUL40:=RANGE(LV1N,0.5,0.60);
QUL50:=RANGE(LV1N,0.4,0.5);
QUL60:=RANGE(LV1N,0.3,0.4);
QUL70:=RANGE(LV1N,0.2,0.3);
QUL80:=RANGE(LV1N,0.1,0.2);
QUL90:=RANGE(LV1N,0,0.1);
QU01:=RANGE(HV1N,0.9,1.00);
QU10:=RANGE(HV1N,0.8,0.90);
QU20:=RANGE(HV1N,0.7,0.80);
QU30:=RANGE(HV1N,0.6,0.70);
QU40:=RANGE(HV1N,0.5,0.60);
QU50:=RANGE(HV1N,0.4,0.5);
QU60:=RANGE(HV1N,0.3,0.4);
SB5B60:IF(B5=BMLLV AND QUL20=1,MA5,DRAWNULL),COLORWHITE,LINETHICK4;
SB10B60:IF(B5=BMLLV AND QUL20=1,MA10,DRAWNULL),COLORWHITE,LINETHICK4;
SB20B60:IF(B5=BMLLV AND QUL20=1,MA20,DRAWNULL),COLORWHITE,LINETHICK4;
SB30B60:IF(B5=BMLLV AND QUL20=1,MA30,DRAWNULL),COLORWHITE,LINETHICK4;
SB5B61:IF(B5=BMLLV AND QUL30=1,MA5,DRAWNULL),COLORCYAN,LINETHICK4;
SB10B61:IF(B5=BMLLV AND QUL30=1,MA10,DRAWNULL),COLORCYAN,LINETHICK4;
SB20B61:IF(B5=BMLLV AND QUL30=1,MA20,DRAWNULL),COLORCYAN,LINETHICK4;
SB30B61:IF(B5=BMLLV AND QUL30=1,MA30,DRAWNULL),COLORCYAN,LINETHICK4;
SB5B62:IF(B5=BMLLV AND QUL40=1,MA5,DRAWNULL),COLORGRAY,LINETHICK4;
SB10B62:IF(B5=BMLLV AND QUL40=1,MA10,DRAWNULL),COLORGRAY,LINETHICK4;
SB20B62:IF(B5=BMLLV AND QUL40=1,MA20,DRAWNULL),COLORGRAY,LINETHICK4;
SB30B62:IF(B5=BMLLV AND QUL40=1,MA30,DRAWNULL),COLORGRAY,LINETHICK4;
SB5B63:IF(B5=BMLLV AND QUL50=1,MA5,DRAWNULL),COLORLIBLUE,LINETHICK4;
SB10B63:IF(B5=BMLLV AND QUL50=1,MA10,DRAWNULL),COLORLIBLUE,LINETHICK4;
SB20B63:IF(B5=BMLLV AND QUL50=1,MA20,DRAWNULL),COLORLIBLUE,LINETHICK4;
SB30B63:IF(B5=BMLLV AND QUL50=1,MA30,DRAWNULL),COLORLIBLUE,LINETHICK4;
SB5B64:IF(B5=BMLLV AND QUL60=1,MA5,DRAWNULL),COLORCYAN,LINETHICK4;
SB10B64:IF(B5=BMLLV AND QUL60=1,MA10,DRAWNULL),COLORCYAN,LINETHICK4;
SB20B64:IF(B5=BMLLV AND QUL60=1,MA20,DRAWNULL),COLORCYAN,LINETHICK4;
SB30B64:IF(B5=BMLLV AND QUL60=1,MA30,DRAWNULL),COLORCYAN,LINETHICK4;
SB5B65:IF(B5=BMLLV AND QUL70=1,MA5,DRAWNULL),COLORBLUE,LINETHICK4;
SB10B65:IF(B5=BMLLV AND QUL70=1,MA10,DRAWNULL),COLORBLUE,LINETHICK4;
SB20B65:IF(B5=BMLLV AND QUL70=1,MA20,DRAWNULL),COLORBLUE,LINETHICK4;
SB30B65:IF(B5=BMLLV AND QUL70=1,MA30,DRAWNULL),COLORBLUE,LINETHICK4;
SB5B66:IF(B5=BMLLV AND QUL80=1,MA5,DRAWNULL),COLORRED,LINETHICK4;
SB10B66:IF(B5=BMLLV AND QUL80=1,MA10,DRAWNULL),COLORRED,LINETHICK4;
SB20B66:IF(B5=BMLLV AND QUL80=1,MA20,DRAWNULL),COLORRED,LINETHICK4;
SB30B66:IF(B5=BMLLV AND QUL80=1,MA30,DRAWNULL),COLORRED,LINETHICK4;
SB5B67:IF(B5=BMLLV AND QUL90=1,MA5,DRAWNULL),COLORGREEN,LINETHICK4;
SB10B67:IF(B5=BMLLV AND QUL90=1,MA10,DRAWNULL),COLORGREEN,LINETHICK4;
SB20B67:IF(B5=BMLLV AND QUL90=1,MA20,DRAWNULL),COLORGREEN,LINETHICK4;
SB30B67:IF(B5=BMLLV AND QUL90=1,MA30,DRAWNULL),COLORGREEN,LINETHICK4;
SS5S64:IF(S5=SMHHV AND QU60=1,MA5,DRAWNULL),COLORWHITE,LINETHICK4;
SS10S64:IF(S5=SMHHV AND QU60=1,MA10,DRAWNULL),COLORWHITE,LINETHICK4;
SS20S64:IF(S5=SMHHV AND QU60=1,MA20,DRAWNULL),COLORWHITE,LINETHICK4;
SS30S64:IF(S5=SMHHV AND QU60=1,MA30,DRAWNULL),COLORWHITE,LINETHICK4;
SS5S65:IF(S5=SMHHV AND QU50=1,MA5,DRAWNULL),COLORLICYAN,LINETHICK4;
SS10S65:IF(S5=SMHHV AND QU50=1,MA10,DRAWNULL),COLORLICYAN,LINETHICK4;
SS20S65:IF(S5=SMHHV AND QU50=1,MA20,DRAWNULL),COLORLICYAN,LINETHICK4;
SS30S65:IF(S5=SMHHV AND QU50=1,MA30,DRAWNULL),COLORLICYAN,LINETHICK4;
SS5S66:IF(S5=SMHHV AND QU40=1,MA5,DRAWNULL),COLORLIGREEN,LINETHICK4;
SS10S66:IF(S5=SMHHV AND QU40=1,MA10,DRAWNULL),COLORLIGREEN,LINETHICK4;
SS20S66:IF(S5=SMHHV AND QU40=1,MA20,DRAWNULL),COLORLIGREEN,LINETHICK4;
SS30S66:IF(S5=SMHHV AND QU40=1,MA30,DRAWNULL),COLORLIGREEN,LINETHICK4;
SS5S67:IF(S5=SMHHV AND QU30=1,MA5,DRAWNULL),COLORBROWN,LINETHICK4;
SS10S67:IF(S5=SMHHV AND QU30=1,MA10,DRAWNULL),COLORBROWN,LINETHICK4;
SS20S67:IF(S5=SMHHV AND QU30=1,MA20,DRAWNULL),COLORBROWN,LINETHICK4;
SS30S67:IF(S5=SMHHV AND QU30=1,MA30,DRAWNULL),COLORBROWN,LINETHICK4;
SS5S68:IF(S5=SMHHV AND QU20=1,MA5,DRAWNULL),COLORYELLOW,LINETHICK4;
SS10S68:IF(S5=SMHHV AND QU20=1,MA10,DRAWNULL),COLORYELLOW,LINETHICK4;
SS20S68:IF(S5=SMHHV AND QU20=1,MA20,DRAWNULL),COLORYELLOW,LINETHICK4;
SS30S68:IF(S5=SMHHV AND QU20=1,MA30,DRAWNULL),COLORYELLOW,LINETHICK4;
SS5S69:IF(S5=SMHHV AND QU10=1,MA5,DRAWNULL),COLORMAGENTA,LINETHICK4;
SS10S69:IF(S5=SMHHV AND QU10=1,MA10,DRAWNULL),COLORMAGENTA,LINETHICK4;
SS20S69:IF(S5=SMHHV AND QU10=1,MA20,DRAWNULL),COLORMAGENTA,LINETHICK4;
SS30S69:IF(S5=SMHHV AND QU10=1,MA30,DRAWNULL),COLORMAGENTA,LINETHICK4;
SS5S610:IF(S5=SMHHV AND QU01=1,MA5,DRAWNULL),COLORRED,LINETHICK4;
SS10S610:IF(S5=SMHHV AND QU01=1,MA10,DRAWNULL),COLORRED,LINETHICK4;
SS20S610:IF(S5=SMHHV AND QU01=1,MA20,DRAWNULL),COLORRED,LINETHICK4;
SS30S610:IF(S5=SMHHV AND QU01=1,MA30,DRAWNULL),COLORRED,LINETHICK4;
LL0:=IF(PERIOD=14 OR PERIOD=11 OR PERIOD=10 OR PERIOD=18 OR PERIOD=17 OR PERIOD=16 OR PERIOD=15 OR PERIOD=7,1,0);
LL1:=IF(ISLASTBAR AND LL0=1,1,0);
H20%:IF(LL1=1,H-H*0.2,DRAWNULL),COLORLIGRAY,LINETHICK2;
{DRAWNUMBER(H20%<>DRAWNULL AND LL1=1,H20%,H20%),COLORLIGRAY;}
H30%:IF(LL1=1,H-H*0.3,DRAWNULL),COLORLIGREEN,LINETHICK4;
DRAWNUMBER(H30%<>DRAWNULL AND LL1=1,H30%,H30%),COLORLIGREEN;
H40%:IF(LL1=1,H-H*0.4,DRAWNULL),COLORLIGRAY,LINETHICK4;
DRAWNUMBER(H40%<>DRAWNULL AND LL1=1,H40%,H40%),COLORLIGRAY;
H50%:IF(LL1=1,H-H*0.5,DRAWNULL),COLORRED,LINETHICK5;
DRAWNUMBER(H50%<>DRAWNULL AND LL1=1,H50%,H50%),COLORRED;
H60%:IF(LL1=1,H-H*0.6,DRAWNULL),COLORLIGRAY,LINETHICK3;
DRAWNUMBER(H60%<>DRAWNULL AND LL1=1,H60%,H60%),COLORLIGRAY;
H70%:IF(LL1=1,H-H*0.7,DRAWNULL),COLORLIGREEN,LINETHICK5;
DRAWNUMBER(H70%<>DRAWNULL AND LL1=1,H70%,H70%),COLORLIGREEN;
H80%:IF(LL1=1,H-H*0.8,DRAWNULL),COLORLIGRAY,LINETHICK3;
DRAWNUMBER(H80%<>DRAWNULL AND LL1=1,H80%,H80%),COLORLIGRAY;
H90%:IF(LL1=1,H-H*0.9,DRAWNULL),COLORLIGREEN,LINETHICK5;
DRAWNUMBER(H90%<>DRAWNULL AND LL1=1,H90%,H90%),COLORLIGREEN;
H99%:IF(LL1=1,H-H*0.999,DRAWNULL),COLORYELLOW,LINETHICK5;
DRAWNUMBER(H99%<>DRAWNULL AND LL1=1,H99%,H99%),COLORYELLOW;
LL2:=IF(ISLASTBAR AND PERIOD=5,1,0);
QC:IF(LL2=1, REF(CLOSE,1),DRAWNULL),COLORRED,LINETHICK4;
ZHANG2%:IF(LL2=1,QC+QC*0.02,DRAWNULL),COLORWHITE,LINETHICK1;
{DRAWNUMBER(ZHANG2%<>DRAWNULL AND LL2=1,ZHANG2%,ZHANG2%),COLORWHITE;}
ZHANG3%:=IF(LL2=1,QC+QC*0.03,DRAWNULL),COLORBLUE,LINETHICK1;
{DRAWNUMBER(ZHANG3%<>DRAWNULL AND LL2=1,ZHANG3%,ZHANG3%),COLORWHITE;}
ZHANG4%:=IF(LL2=1,QC+QC*0.04,DRAWNULL),COLORWHITE,LINETHICK1;
{DRAWNUMBER(ZHANG4%<>DRAWNULL AND LL2=1,ZHANG4%,ZHANG4%),COLORWHITE;}
ZHANG5%:IF( LL2=1,QC+QC*0.05,DRAWNULL),COLORBLUE,LINETHICK2;
{DRAWNUMBER(ZHANG5%<>DRAWNULL AND LL2=1,ZHANG5%,ZHANG5%),COLORWHITE;}
ZHANG6%:=IF( LL2=1,QC+QC*0.06,DRAWNULL),COLORWHITE,LINETHICK1;
{DRAWNUMBER(ZHANG6%<>DRAWNULL AND LL2=1,ZHANG6%,ZHANG6%),COLORWHITE;}
ZHANG7%:=IF( LL2=1,QC+QC*0.07,DRAWNULL),COLORBLUE,LINETHICK1;
{DRAWNUMBER(ZHANG7%<>DRAWNULL AND LL2=1,ZHANG7%,ZHANG7%),COLORWHITE;}
ZHANG8%:IF( LL2=1,QC+QC*0.08,DRAWNULL),COLORWHITE,LINETHICK1;
{DRAWNUMBER(ZHANG8%<>DRAWNULL AND LL2=1,ZHANG8%,ZHANG8%),COLORWHITE;}
ZHANG9%:=IF( LL2=1,QC+QC*0.09,DRAWNULL),COLORBLUE,LINETHICK1;
{DRAWNUMBER(ZHANG9%<>DRAWNULL AND LL2=1,ZHANG8%,ZHANG8%),COLORWHITE;}
ZHANG10%:IF( LL2=1,QC+QC*0.1,DRAWNULL),COLORBLUE,LINETHICK4;
{DRAWNUMBER(ZHANG10%<>DRAWNULL AND LL2=1,ZHANG10%,ZHANG10%),COLORWHITE;}
DIE2%:IF( LL2=1,QC-QC*0.02,DRAWNULL),COLORGRAY,LINETHICK1;
{DRAWNUMBER(DIE2%<>DRAWNULL AND LL2=1,DIE2%,DIE2%),COLORGRAY;}
DIE3%:=IF( LL2=1,QC-QC*0.03,DRAWNULL),COLORBLUE,LINETHICK1;
{DRAWNUMBER(DIE3%<>DRAWNULL AND LL2=1,DIE3%,DIE3%),COLORGRAY;}
DIE4%:=IF(LL2=1,QC-QC*0.04,DRAWNULL),COLORGRAY,LINETHICK1;
{DRAWNUMBER(DIE4%<>DRAWNULL AND LL2=1,DIE4%,DIE4%),COLORGRAY;}
DIE5%:IF( LL2=1,QC-QC*0.05,DRAWNULL),COLORBLUE,LINETHICK2;
{DRAWNUMBER(DIE5%<>DRAWNULL AND LL2=1,DIE5%,DIE5%),COLORGRAY;}
DIE6%:=IF( LL2=1,QC-QC*0.06,DRAWNULL),COLORGRAY,LINETHICK1;
{DRAWNUMBER(DIE6%<>DRAWNULL AND LL2=1,DIE6%,DIE6%),COLORGRAY;}
DIE7%:=IF( LL2=1,QC-QC*0.07,DRAWNULL),COLORBLUE,LINETHICK1;
{DRAWNUMBER(DIE7%<>DRAWNULL AND LL2=1,DIE7%,DIE7%),COLORGRAY;}
DIE8%:IF( LL2=1,QC-QC*0.08,DRAWNULL),COLORGRAY,LINETHICK1;
{DRAWNUMBER(DIE8%<>DRAWNULL AND LL2=1,DIE8%,DIE8%),COLORGRAY;}
DIE9%:=IF( LL2=1,QC-QC*0.09,DRAWNULL),COLORGRAY,LINETHICK1;
{DRAWNUMBER(DIE9%<>DRAWNULL AND LL2=1,DIE9%,DIE9%),COLORGRAY;}
DIE10%:IF( LL2=1,QC-QC*0.1,DRAWNULL),COLORBLUE,LINETHICK4;
{DRAWNUMBER(DIE10%<>DRAWNULL AND LL2=1,DIE10%,DIE10%),COLORGRAY;}

通达信拨开云天主图指标公式

 

相关文章