在线检测未来函数

飞狐低吸低涨主图指标公式

来源:Internet,编辑:股旁网,2015-09-01

W:=BARSLAST(barpos=sysparam(2));
P:=BACKSET(barpos=sysparam(3),W/2+1);
K:=BARSLAST(CROSS(P,0.5));
KJ:=SYSPARAM(4)-SYSPARAM(5);
平衡:SYSPARAM(5)+KJ/2,COLOR00FFFF,LINEDOT;
FILLRGN(W>K,平衡,SYSPARAM(4)),COLORFF0000;{该行设置背景色}
VERTLINE(CROSS(P,0.5)),COLOR00FFFF,LINEDASHDOT;
压力:IF(K>=0,SYSPARAM(4)-KJ*0.191,平衡),COLORFF00FF,LINEDOT;
支撑:IF(K>=0,SYSPARAM(5)+KJ*0.191,平衡),COLOR00FF00,LINEDOT;
低吸:K>=0 and CROSS(平衡,LOW),COLORFF8899,LINETHICK0;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0;
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0;
DRAWTEXT(HIGH=SYSPARAM(4) and K>=0,HIGH*1.01,'←'+NUMTOSTR(HIGH,2)),COLORFFFFFF;
DRAWICON(低吸,LOW,6);
{以下设置提示文字部分}
DRAWTEXT(barpos=sysparam(3),压力,'0.809'),COLOR0000FF,ALIGN1;
DRAWTEXT(barpos=sysparam(3),平衡,'0.500'),COLORFFFFFF,ALIGN1;
DRAWTEXT(barpos=sysparam(3),支撑,'0.191'),COLOR00FFFF,ALIGN1;
DRAWTEXT(K=0,SYSPARAM(4)-KJ/12,'★强势区域--急拉减仓!'),COLOR00FFFF,ALIGN0;
DRAWTEXT(K=0,SYSPARAM(4)-KJ/3,'●震荡整理--寻机低吸!'),COLOR00FF00,ALIGN0;
DRAWTEXT(K=0,SYSPARAM(5)+KJ/3,'◆反弹中轨--逢高休息!'),COLORFFFFFF,ALIGN0;
DRAWTEXT(K=0,SYSPARAM(5)+KJ/10,'■弱势区域--暂不参与!'),COLORFFFF00,ALIGN0;
{以下设置个股信息}
DRAWTEXTEX(C>0,1,10,50,'所属板块:'+BLKNAME),COLORFFFFFF;
DRAWTEXTEX(C>0,1,10,120,'股票名称:'+'【'+STKLABEL+' '+STKNAME+'】'),COLOR00FF00;
DD:=FINANCE(1);SS:=FINANCE(7);
DRAWTEXTEX(C>0,1,10,190,'总股本:'+NUMTOSTR(DD,0)+'万' +' 流通A股:'+NUMTOSTR(SS,0)+'万'),COLOR00FFFF;
DRAWTEXTEX(C>0,1,10,300,'■低点至今上涨:'+NUMTOSTR(低涨,2)+'% '+NUMTOSTR(天,0)+'天'),COLOR0000FF;
W1:=IF(barpos=sysparam(3),W+1,0);
DRAWTEXTEX(C>0,1,10,360,'■目前可见K线:'+NUMTOSTR(HHV(W1,W),0)+'天'),COLOR00FF00;
DRAWTEXTEX(C>0,1,10,420,'■建议查阅K线:短线30天,中长线120天!'),COLORFF8899;
DRAWTEXTEX(C>0,1,10,920,'====【若水论坛の一品茶缘】===='),COLOR889999;
{以下设置五彩立体K线}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
MA5:MA(CLOSE,5),COLORFFFFFF;
MA10:MA(CLOSE,10),COLOR00FFFF;
MA20:MA(C,20),COLORFF00FF;

飞狐低吸低涨主图指标公式

 

相关文章