在线检测未来函数

大智慧庄家红了指标公式

来源:Internet,编辑:股旁网,2015-09-01

input:n(9,1,100);
DRAWGBK(CLOSE>1,STRIP(RGB(0,150,150),RGB(0,20,20),0));
VAR2:=(HIGH+LOW+(CLOSE)*(2))/(4);
B: ((EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))*(38)),COLOR0000FF,LINESTICK;
VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VAR33:=EMA(VAR22,10);
VAR44:=EMA(VAR33,10);
VAR55:=(3)*(VAR33)-(2)*(VAR44);
VAR66:=EMA(VAR55,5);
a: (EMA(VAR66,1)),COLOR0000FF,LINETHICK3;
Vur1:=VOL/CAPITAL;
Vur2:=1.1*(MAX(HIGH,REF(CLOSE,1))/MIN(LOW,REF(CLOSE,1))-1);
Vur3:=2.5*MAX(Vur1,Vur2);
Vur4:=DMA(CLOSE,Vur3);
Vur5:=20*(Vur4/REF(Vur4,1)-1)*48;
Vur6:=EMA(Vur5,2);
红黄极强:STICKLINE(Vur5>0,0,Vur5,7,0),COLOR0077FF;
STICKLINE(Vur5>0,0,Vur5,6,0),COLOR0088FF;
STICKLINE(Vur5>0,0,Vur5,5,0),color00AAFF;
STICKLINE(Vur5>0,0,Vur5,4,0),color00BBFF;
STICKLINE(Vur5>0,0,Vur5,3,0),color00CCFF;
STICKLINE(Vur5>0,0,Vur5,2,0),color00DDFF;
STICKLINE(Vur5>0,0,Vur5,1,0),color00EEFF;
红强势:STICKLINE(Vur6>0,0,Vur6,7,0),COLOR000066;
STICKLINE(Vur6>0,0,Vur6,6,0),COLOR000088;
STICKLINE(Vur6>0,0,Vur6,5,0),COLOR0000AA;
STICKLINE(Vur6>0,0,Vur6,4,0),COLOR0011BB;
STICKLINE(Vur6>0,0,Vur6,3,0),COLOr0022CC;
STICKLINE(Vur6>0,0,Vur6,2,0),COLOR0033DD;
STICKLINE(Vur6>0,0,Vur6,1,0),COLOR0044EE;
绿蓝极弱:STICKLINE(Vur5<0,0,Vur5,6.6,0),COLORff4400;
STICKLINE(Vur5<0,0,Vur5,6,0),COLORff5500;
STICKLINE(Vur5<0,0,Vur5,5,0),COLORFF6611;
STICKLINE(Vur5<0,0,Vur5,4,0),COLORFF8822;
STICKLINE(Vur5<0,0,Vur5,3,0),COLORFFaa33;
STICKLINE(Vur5<0,0,Vur5,2,0),COLORFFbb44;
STICKLINE(Vur5<0,0,Vur5,1,0),COLORFFcc55;
绿弱势:STICKLINE(Vur6<0,0,Vur6,7,0),color004400;
STICKLINE(Vur6<0,0,Vur6,6,0),color006600;
STICKLINE(Vur6<0,0,Vur6,5,0),color008800;
STICKLINE(Vur6<0,0,Vur6,4,0),color00aa00;
STICKLINE(Vur6<0,0,Vur6,3,0),color00bb00;
STICKLINE(Vur6<0,0,Vur6,2,0),color00cc00;
STICKLINE(Vur6<0,0,Vur6,1,0),color00dd00;
VAb:=EMA(EMA(CLOSE,5),5);
控盘:=(VAb-REF(VAb,1))/REF(VAb,1)*1000;
VAc:=100*WINNER(CLOSE*0.95);
粉上天:STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,7,0),COLORFF00FF;
STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,6,0),COLORFF22FF;
STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,5,0),COLORFF44FF;
STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,4,0),COLORFF66FF;
STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,3,0),COLORFF88FF;
STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,2,0),COLORFF99FF;
STICKLINE(VAc>30 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFFBBFF;
e:=EMA(CLOSE,12)-EMA(CLOSE,26);
f:=EMA(e,n);
if(e<0,e,0)*30,colorred,linethick2;
if(e<0,0,e)*30,coloryellow,linethick2;
if(e<f,e,f)*30,COLOR00ff00,linethick2;
if(e>f,f,f)*30,COLORwhite,linethick2;
金叉:=CROSS(e,f) AND e<-0.1;
STICKLINE(金叉,0,-40.18,1,0),COLORred;
DRAWTEXT(金叉,-32,' 金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(e,f),BARSLAST(f>=0));
二次金叉:=CROSS(e,f) AND f<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-20,1,0),Color222233;
DRAWTEXT(二次金叉,-15,' 二次金叉'),Color222233;
u:100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),colorblack,linethick2;
w:=ema(u,3);
FILLRGN(u,w,u>ref(u,1),rgb(0,105,0),u<ref(u,1),rgb(105,0,0));
d:80,COLORff4444,linethick2;
DRAWTEXTREL(10, d+60,'进出准备线 ' ),COLORff4444;
x:95,colorgreen,linethick1;
DRAWTEXTREL(10, x-20,'时尚流行进出线'),colorgreen;
110;
VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3)) AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2)) AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2)) AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR (REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));
VARA2:=LLV(LOW,5);
VARA3:=HHV(HIGH,5);
VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),4);
VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);
VARA6:=(VARA5<24) AND (OPEN<MA(CLOSE,20));
VARA1 AND (VARA6),COLORFF0000;
STICKLINE(VARA1 AND (VARA6),0,79.5,7,0),COLORff1111;
STICKLINE(VARA1 AND (VARA6),0,79.5,6,0),COLORff2222;
STICKLINE(VARA1 AND (VARA6),0,79.5,5,0),COLORFF3333;
STICKLINE(VARA1 AND (VARA6),0,79.5,4,0),COLORFF4444;
STICKLINE(VARA1 AND (VARA6),0,79.5,3,0),COLORFF5555;
STICKLINE(VARA1 AND (VARA6),0,79.5,2,0),COLORFF6666;
STICKLINE(VARA1 AND (VARA6),0,79.5,1,0),COLORFF7777;
Vr10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
q:Vr10,colorred;
DRAWICON(Vr10,u+10,1) ;
STICKLINE( q ,0 , 30,8, 0),colorblack;
DRAWTEXT(q,40 ,'买100%' ),coloryellow;

大智慧庄家红了指标公式

 

相关文章