在线检测未来函数

大智慧潜龙在渊主图指标公式

来源:Internet,编辑:股旁网,2015-09-09

MA10:MA(C,10),COLORGRAY;
MA20:MA(C,20),COLORGREEN;
MA40:MA(C,40),COLORRED;
MA60:MA(C,60),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
潜龙在渊:=(AV + NEWVOL);AA:=MA(C,40)>REF(MA(C,40),1) AND REF(MA(C,40),1)>REF(MA(C,40),2);
BB:=MA(C,60)>REF(MA(C,60),1) AND REF(MA(C,60),1)>REF(MA(C,60),2);
CC:=MA(C,20)>REF(MA(C,20),1) AND REF(MA(C,20),1)>REF(MA(C,20),2);
EE:=(AA OR BB OR CC);
DRAWTEXT(CROSS(潜龙在渊,0) AND EE,L*0.98,'★潜龙在渊'),COLORRED;

大智慧潜龙在渊主图指标公式

 

相关文章