在线检测未来函数

同花顺红绿柱面积指标公式

来源:Internet,编辑:股旁网,2015-09-08

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
MACDHS:=IF(MACD>0 AND MACD>REF(MACD,1),MACD,0);
MACDHX:=IF(MACD>0 AND MACD<REF(MACD,1),MACD,0);
MACDLX:=IF(MACD<0 AND MACD<REF(MACD,1),MACD,0);
MACDLS:=IF(MACD<0 AND MACD>REF(MACD,1),MACD,0);
红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),PRECIS2,COLOR0000FF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),PRECIS2,COLOR006000;;
DRAWTEXT(REF(MACD,1)>0 AND MACD<=0 ,HHV(MACD,4),''+TOSTRING(REF(红柱面积,1),2)),colorred; DRAWTEXT(REF(MACD,1)<0 AND MACD>=0 ,LLV(MACD,4),''+TOSTRING(REF(ABS(绿柱面积),1),2)),Color00ff00;
DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD<0,LLV(MACD,4),''+TOSTRING(ABS(绿柱面积),2)),Color004A00;
DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD>0,HHV(MACD,4),''+TOSTRING(ABS(红柱面积),2)),colorred;

同花顺红绿柱面积指标公式

 

相关文章