在线检测未来函数

通达信三平顶底主图指标公式

来源:Internet,编辑:股旁网,2015-10-05

DRAWBAND(MA(C,5),RGB(230,0,250),HHV(MA(C,5),13),RGB(0,100,150));
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
差值1:=ABS(REF(CCI1,1)-CCI1);
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5);
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ111:=(ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5))
OR (VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1);
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
下跌:=IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
立桩量3:=FILTER(TJ111,5);
TJ222:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(HIGH,1),1,
IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(HIGH,2),1,
IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破3:=TJ222=1;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量3)),
REF(HIGH,BARSLAST(立桩量3)),10,1),COLORGRAY;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量3)),
REF(LOW,BARSLAST(立桩量3)),10,1),COLORBROWN;
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破3;
条件成立:=FILTER(成立,5);
DRAWTEXT(条件成立 AND 下跌!= VAR6,H*1.005,'成立') COLORGRAY;
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)!=0,REF(SS,1),IF(REF(SS,2)!=0,REF(SS,2),IF(REF(SS,3)!=0,REF(SS,3),IF(REF(SS,5)!=0,REF(SS,5),IF(REF(SS,6)!=0,REF(SS,6),IF(REF(SS,7)!=0,REF(SS,7),0))))));
{STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,2.8,0),COLORBLUE;
STICKLINE(SS=-1 OR SM<=-1 AND SS=0,B1,C,2.8,0),COLORYELLOW;
STICKLINE(SS=2,B2,C,2.8,0),COLORBLUE;
STICKLINE(SS=-2,B2,C,2.8,0),COLORYELLOW;}
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,2.8,0),COLORGREEN;
STICKLINE((SS=1 OR SS=2) AND SM<0,B2,B1,2.8,0),COLORMAGENTA;
AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));
BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AA AND CLOSE>REF(OPEN,2),LOW*0.97,'三平底'),COLORWHITE;
DRAWTEXT(BB AND CLOSE<REF(CLOSE,2),HIGH*1.03,'三平顶'),COLORCYAN;
操作:HHV(MA(CLOSE,5),13),COLORGREEN;
MA5:MA(CLOSE,5) COLORWHITE;
MA10:MA(CLOSE,10) COLORYELLOW;
MA20:MA(CLOSE,20) COLORMAGENTA;
MA60:MA(CLOSE,60) COLORCYAN;
OC:=REF(CLOSE,1);
RSV:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
YX:=((CLOSE>OC) AND C>O);
KK:=HHV(K,5);
HH:=HHV(D,5);
D1:=REF(D,1);
K1:=REF(K,1);
DRAWTEXT((((D1<30) AND CROSS(K,D)) AND YX),(LOW * 0.98),'←短买!'),COLORYELLOW;
VAR11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)
-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
黑马线:=EMA(VAR11,5), LINETHICK2,COLOR6600FF;
黑马线2:=100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),LINETHICK2,,;
DRAWTEXT(CROSS(黑马线,黑马线2),L*0.95,'追涨'),COLORRED;
VARP1:=(C+H+O+L)/4;
卖出:XMA(VARP1,20)*(1+80/1000),POINTDOT,COLORGREEN,LINETHICK3;
买入:XMA(VARP1,32)*(1-100/1000),POINTDOT,COLORMAGENTA,LINETHICK3;
中线:(卖出+买入)/2,POINTDOT,COLORWHITE,LINETHICK3;
{股灵吧决策}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
FF:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
DRAWTEXT(CROSS(VAR200,MA(VAR300,5)),LOW*0.97,'入货'),COLORYELLOW;
{N:=0.98;
VAR4:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR4=1,2,0);
顶:= IF(VAR5=2,2,0);
中线卖出:=IF(顶>REF(顶,1),1,0);
止损价:=IF(中线卖出=1, C*N,0), POINTDOT,COLOR00FF00,LINETHICK5;
STICKLINE(止损价,C*N,C*N,200,1),COLORRED,LINETHICK1;}{画线}
{AA1:=MA(C,5);
BB1:=MA(C,15);
AF:=CROSS(AA1,BB1);
STICKLINE(AF,LLV(L,4),LLV(L,4),50,1),COLORRED,LINETHICK3;
DRAWTEXT(AF,LLV(L,4),'止损线'),COLORYELLOW;};

通达信三平顶底主图指标公式

 

相关文章