在线检测未来函数

通达信简约K线主图指标公式

来源:Internet,编辑:股旁网,2015-10-05

{涨跌停K线变色}
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;{涨停K线色}
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORBLUE;{跌停K线色}
DRAWTEXT_FIX(C>0,0,0.15,0,'黄色K线是涨停,蓝色K线是跌停。'),COLORWHITE;
{大机构黄金波浪线}
{精简版}{本指标核心}
M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);
VAR1:=EMA(M13,62);
VAR2:=(CLOSE+HIGH+LOW)/3;
VAR3:=EMA(VAR2,10);
VAR4:=REF(VAR3,1);
STICKLINE(VAR3>VAR4,VAR3,VAR4,0.28,0),COLOR00FFFF;
STICKLINE(VAR3<VAR4,VAR3,VAR4,0.28,0),COLORFF0000;
{均线}
MA5:MA(CLOSE,5)COLORWHITE;
MA10:MA(CLOSE,10)COLORYELLOW;
MA20:MA(CLOSE,20)COLORGREEN;
MA60:MA(CLOSE,60)COLORDB00DB;
{区间换手率}
DRAWTEXT_FIX(ISLASTBAR,0.985,0.01,1.0,STRCAT('今日换手率: ', CON2STR(DYNAINFO(37)*100,2))),COLORC080FF;
DRAWTEXT_FIX(ISLASTBAR,0.985,0.06,1.0,STRCAT('5日换手率: ', CON2STR(SUM(DYNAINFO(37)*100,5),2))),COLORC080FF;
DRAWTEXT_FIX(ISLASTBAR,0.985,0.11,1.0,STRCAT('20日换手率: ', CON2STR(SUM(DYNAINFO(37)*100,20),2))),COLORC080FF;
{基本面}
{------第1行-------所属行业及板块-------------}
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLORC080FF;
DRAWTEXT_FIX(1,0.04,0,0,HYBLOCK)COLORC080FF;
DRAWTEXT_FIX(1,0.08,0,0,'所属地区:')COLORC080FF;
DRAWTEXT_FIX(1,0.12,0,0,DYBLOCK)COLORC080FF;
DRAWTEXT_FIX(1,0.16,0,0,'概念板块:')COLORC080FF;
DRAWTEXT_FIX(1,0.20,0,0,GNBLOCK)COLORC080FF;
{------第二行------重要参考------------------}
DRAWTEXT_FIX(1,0.00,0.05,0,'重要参考:')COLORC080FF;
DRAWTEXT_FIX(1,0.04,0.05,0,'每股净资产:'),COLORC080FF;
DRAWNUMBER_FIX(1,0.09,0.05,0,FINANCE(34)),COLORC080FF;
DRAWTEXT_FIX(1,0.13,0.05,0,'每股未分配利润:'),COLORC080FF;
DRAWNUMBER_FIX(1,0.19,0.05,0,FINANCE(32)),COLORC080FF;
DRAWTEXT_FIX(1,0.23,0.05,0,'每股公积金:'),COLORC080FF;
DRAWNUMBER_FIX(1,0.28,0.05,0,FINANCE(18)),COLORC080FF;

通达信简约K线主图指标公式

 

相关文章