在线检测未来函数

通达信双黄金主图指标公式

来源:Internet,编辑:股旁网,2015-10-09

N:=7;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:=R1>REF(R1,1);
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1);
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1);
NOTEXT1:=DRAWLINE(S2,H,S1,H,1),LINETHICK2,COLORRED;
NOTEXT2:=DRAWLINE(U2,L,U1,L,1),LINETHICK2,COLORGREEN;
NOTEXT3:=REF(H,BARSLAST(S2)),COLORRED;
NOTEXT4:=REF(H,BARSLAST(S1)),COLORLIRED;
NOTEXT5:=REF(L,BARSLAST(U2)),COLORGREEN;
NOTEXT6:=REF(L,BARSLAST(U1)),COLORGREEN;
高:IF(NOTEXT3>NOTEXT4,NOTEXT3,NOTEXT4),COLORRED;
低:NOTEXT6,COLORRED;
TS1:=CONST(BARSLAST(S2)),NODRAW,COLORWHITE;
TS2:=CONST(BARSLAST(S1)),NODRAW,COLORWHITE;
AH1:=IF(CURRBARSCOUNT<=TS1,高-(高-低)*0.191,DRAWNULL),COLORRED,DOTLINE;
AH2:IF(CURRBARSCOUNT<=TS2,高-(高-低)*0.382,DRAWNULL),COLORRED,DOTLINE;
AH3:=IF(CURRBARSCOUNT<=TS1,高-(高-低)*0.5,DRAWNULL),COLORRED,DOTLINE;
AH4:IF(CURRBARSCOUNT<=TS1,高-(高-低)*0.618,DRAWNULL),COLORRED,DOTLINE;
AH5:=IF(CURRBARSCOUNT<=TS1,高-(高-低)*0.809,DRAWNULL),COLORRED,DOTLINE;
高J:IF(CURRBARSCOUNT<=30,REFDATE(HHV(H,30),DATE),DRAWNULL),COLORWHITE,DOTLINE;
低J:IF(CURRBARSCOUNT<=30,REFDATE(LLV(L,30),DATE),DRAWNULL),COLORWHITE,DOTLINE;
H2J:IF(CURRBARSCOUNT<=30,高J-(高J-低J)*0.382,DRAWNULL),COLORWHITE,DOTLINE;
H4J:IF(CURRBARSCOUNT<=30,高J-(高J-低J)*0.618,DRAWNULL),COLORWHITE,DOTLINE;
ZF:=(C/REF(C,1)-1)*100;
A:=EMA(C,8.3896)-EMA(C,17.5185);
B:=EMA(A,9.0503);
火车轨:=REF(ZF<-9.5 AND C=L,1) AND ZF>9.5 AND C=H AND A<B;
DRAWTEXT(火车轨,L*0.98,'火车轨');
D3X3:REF(EMA(C,3),3),DOTLINE,COLORLIGRAY;
双穿:=CROSS(C,D3X3) AND COUNT(CROSS(C,D3X3),6)=2 AND D3X3>=REF(D3X3,1)
AND A>REF(A,1) AND B>REF(B,1);
DRAWTEXT(双穿,L*0.98,'双穿');

通达信双黄金主图指标公式

 

相关文章