在线检测未来函数

通达信ZIG转向画矩形主图指标公式

来源:Internet,编辑:股旁网,2015-10-09

A:ZIG(3,10),COLORYELLOW,DOTLINE;
HT:=BARSLAST(A<REF(A,1) AND REF(A,1)>REF(A,2));
LT:=BARSLAST(A>REF(A,1) AND REF(A,1)<REF(A,2));
HH:=HHV(C,LT+1);
LL:=LLV(C,HT+1);
QF1:=BACKSET(HT=0,2);
QF2:=BACKSET(LT=0,2);
Q1:=BARSLAST(CROSS(QF1=1,0.5));
Q2:=BARSLAST(CROSS(QF2=1,0.5));
X1:=REFX(HH,BARSNEXT(Q1=0));
X2:=REFX(LL,BARSNEXT(Q2=0));
DRAWLINE(Q2=0,X1,Q1=0,HH,0),COLORYELLOW;
DRAWLINE(Q2=0,X2,Q1=0,LL,0),COLORYELLOW;
STICKLINE(Q2=0 ,X1,C,0,0),COLORYELLOW;
STICKLINE(Q1=0 ,LL,C,0,0),COLORYELLOW;
DRAWLINE(Q1=0,C,Q2=0,HH,0),COLORYELLOW;
DRAWLINE(Q1=0,X2,Q2=0,LL,0),COLORYELLOW;
STICKLINE(Q2=0 ,HH,C,0,0),COLORYELLOW;
STICKLINE(Q1=0 ,X2,C,0,0),COLORYELLOW;

通达信ZIG转向画矩形主图指标公式

 

相关文章