在线检测未来函数

通达信大小波段主图指标公式

来源:Internet,编辑:股旁网,2015-10-08

获利了结:EMA(EMA(EMA(HIGH,5),5),5)*1.15,COLORFFFFFF,LINETHICK1;
风险: EMA(EMA(EMA(HIGH,5),5),5)*1.1,COLORYELLOW;
回档: EMA(EMA(EMA(HIGH,5),5),5)*1.05,COLOR00FF00;
平衡: EMA(EMA(EMA(HIGH,5),5),5),COLORFF00FF,LINETHICK1;
反弹: EMA(EMA(EMA(HIGH,5),5),5)*0.95,COLORGRAY,LINETHICK1;
超跌: EMA(EMA(EMA(HIGH,5),5),5)*0.9,COLORBLUE,LINETHICK1;
ZT:=C/REF(C,1)>1.097;
BH:=BARSLAST(ZT);
STICKLINE(ZT,REF(O,BH),REF(C,BH),3,0),COLORYELLOW;
B1:=REF(C,1)<REF(O,1) AND REF(C,1)<REF(C,2) AND REF(H,1)>REF(H,2) AND REF(L,1)>REF(L,2);
B2:=C>REF(O,1) AND C>O AND O>=REF(C,1) AND C/REF(C,1)<1.04;
B3:=REF(C,2)/REF(C,3)>1.02 AND REF(C,2)/REF(C,3)<1.05 AND REF(C,2)>REF(H,3);
BB1:=B1 AND B2 AND B3;
DRAWTEXT(BB1,0.98*L,'多方炮'),COLORYELLOW;
STICKLINE(BB1,O,C,3,0),COLORYELLOW;
超级多方炮:=BB1 AND C/LLV(C,60)<1.10;
DRAWICON(超级多方炮,0.96*L,23);
持股线:(MA(C,3)+MA(C,5))/2,COLORRED;
持币线:(MA(C,8)+MA(C,13))/2,COLORWHITE;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,LOW*0.98,1),,,COLORRED,LINETHICK3;
DRAWICON(SEL,HIGH*1.02,2),,,COLORGREEN,LINETHICK3;
清仓:=DRAWTEXT(H>获利了结 AND C<获利了结 AND C<O OR REF(C,1)>获利了结 AND C<REF(C,1),获利了结*0.99,'清仓');
满仓:=DRAWTEXT((REF(C,1)<超跌 OR L<超跌) AND C>超跌 AND C>O OR FILTER(REF(C,1)<超跌 AND C>REF(C,3),5),L*0.99,'满仓');
{DRAWTEXT(满仓,0.93*L,'●满仓'),COLORMAGENTA;}
{DRAWTEXT(清仓,1.03*H,'●清仓'),COLORGREEN;}
DRAWICON(满仓,LOW*0.93,1);
DRAWICON(清仓,H*1.03,2);
高:=REFDATE(HHV(H,75),DATE);
低:=REFDATE(LLV(L,75),DATE);
H1:=高-(高-低)*0.191;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高,'高'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H1,'809'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,H2,'618'),COLORGRAY;
DRAWTEXT(CURRBARSCOUNT=1,H3,'中'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,H4,'382'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=1,H5,'191'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,低,'低'),COLORRED;
STICKLINE(CURRBARSCOUNT=13,高,高,700,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=13,H1,H1,700,-1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=13,H2,H2,700,-1),COLORGRAY;
STICKLINE(CURRBARSCOUNT=13,H3,H3,700,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=13,H4,H4,700,-1),COLORLIRED;
STICKLINE(CURRBARSCOUNT=13,H5,H5,700,-1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=13,低,低,700,-1),COLORRED;
CCI背:=IF(LLV(CCI,2)>LLV(CCI,7) AND LLV(L,2)<=LLV(L,7) AND HHV(H,10)>MA(CLOSE,60),1,0),COLORWHITE;
DRAWTEXT(CCI背 AND REF(CCI,1)<-150 AND C>O,L*0.8,'●杀'),COLORGREEN;
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.5),'●买点'),COLORGREEN;
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT((XL3 > 0),(LOW - 0.8),'●绝底'),COLORGREEN;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),EMA8,'★∠45升'),COLORWHITE;
AA1I:=MA(C,5);
BB1I:=MA(C,15);
AF:=CROSS(AA1I,BB1I);
STICKLINE(AF,LLV(L,4),LLV(L,4),80,1),COLORGREEN,LINETHICK3;
DRAWTEXT(AF,LLV(L,4),'止损线'),COLORYELLOW;

通达信大小波段主图指标公式

 

相关文章