在线检测未来函数

通达信跌幅共振修正版指标公式

来源:Internet,编辑:股旁网,2015-10-13

CD:=50;
CDZQ:=45;
CDCQ:=26;
TD:=50;
TDZQ:=45;
TDCQ:=26;
趋势:=3*SMA((C-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,5,1)-2*SMA(SMA((C-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,5,1),3,1),COLORGRAY;
短期:0;
中期:1;
长期:2;
3;
M5:=MA(O,5);
M8:=MA(O,8);
M13:=MA(O,13);
M21:=MA(O,21);
M34:=MA(O,34);
M55:=MA(O,55),LINETHICK2;
M89:=MA(O,89),LINETHICK2;
MZZQ:=MA(O,IF(BARSCOUNT(O)*0.1<144,144,BARSCOUNT(O)*0.1)),LINETHICK2;
M8下穿55:=CROSS(M55,M8);
M8上穿55:=CROSS(M8,M55);
T:=BARSLAST(M8下穿55);
T1:=BARSLAST(M8上穿55);
前高价:=FINDHIGH(HHV(H,34),T,5,1),LINETHICK4;
前低价:=FINDHIGH(LLV(L,34),T1,5,1);
M13下穿89:=CROSS(M89,M13);
M13上穿89:=CROSS(M13,M89);
T3:=BARSLAST(M13下穿89);
T4:=BARSLAST(M13上穿89);
前高价1:=FINDHIGH(HHV(H,55),T3,8,1),LINETHICK4;
前低价1:=FINDHIGH(LLV(L,55),T4,8,1);
M21下穿ZZQ:=CROSS(MZZQ,M21);
M21上穿ZZQ:=CROSS(M21,MZZQ);
T5:=BARSLAST(M21下穿ZZQ);
T6:=BARSLAST(M21上穿ZZQ);
前高价2:=FINDHIGH(HHV(H,144),T5,13,1),LINETHICK4;
前低价2:=FINDHIGH(LLV(L,144),T6,13,1);
QLLV:=前低价/H,LINETHICK2;
QLLV1:=前低价1/H,LINETHICK2;
QLLV2:=前低价2/H,LINETHICK2;
QHHV:=L/前高价;
QHHV1:=L/前高价1;
QHHV2:=L/前高价2;
QUL01:=RANGE(QLLV2,0.95,1.00);
QUL05:=RANGE(QLLV2,0.90,0.95);
QUL10:=RANGE(QLLV2,0.85,0.90);
QUL15:=RANGE(QLLV2,0.80,0.85);
QUL20:=RANGE(QLLV2,0.75,0.80);
QUL25:=RANGE(QLLV2,0.70,0.75);
QUL30:=RANGE(QLLV2,0.65,0.70);
QUL35:=RANGE(QLLV2,0.60,0.65);
QUL40:=RANGE(QLLV2,0.55,0.60);
QUL45:=RANGE(QLLV2,0.5,0.55);
QUL50:=RANGE(QLLV2,0.45,0.5);
QUL55:=RANGE(QLLV2,0.4,0.45);
QUL60:=RANGE(QLLV2,0.35,0.4);
QUL65:=RANGE(QLLV2,0.3,0.35);
QUL70:=RANGE(QLLV2,0.25,0.3);
QUL75:=RANGE(QLLV2,0.2,0.25);
QUL80:=RANGE(QLLV2,0.15,0.2);
QUL85:=RANGE(QLLV2,0.1,0.15);
QUL90:=RANGE(QLLV2,0.05,0.1);
QUL95:=RANGE(QLLV2,0,0.05);
QUL99:=RANGE(QLLV2,0,0.01);
QU01:=RANGE(QHHV2,0.95,1.00);
QU05:=RANGE(QHHV2,0.90,0.95);
QU10:=RANGE(QHHV2,0.85,0.90);
QU15:=RANGE(QHHV2,0.80,0.85);
QU20:=RANGE(QHHV2,0.75,0.80);
QU25:=RANGE(QHHV2,0.70,0.75);
QU30:=RANGE(QHHV2,0.65,0.70);
QU35:=RANGE(QHHV2,0.60,0.65);
QU40:=RANGE(QHHV2,0.55,0.60);
QU45:=RANGE(QHHV2,0.5,0.55);
QU50:=RANGE(QHHV2,0.45,0.5);
QU55:=RANGE(QHHV2,0.4,0.45);
QU60:=RANGE(QHHV2,0.35,0.4);
QU65:=RANGE(QHHV2,0.3,0.35);
QU70:=RANGE(QHHV2,0.25,0.3);
QU75:=RANGE(QHHV2,0.2,0.25);
QU80:=RANGE(QHHV2,0.15,0.2);
QU85:=RANGE(QHHV2,0.1,0.15);
QU90:=RANGE(QHHV2,0.05,0.1);
QU95:=RANGE(QHHV2,0.01,0.05);
QU99:=RANGE(QHHV2,0,0.01);
QHHVT00:IF(QHHV<=CD/100 AND CROSS(5,趋势),0.3,0),COLORRED,LINETHICK2;
QHHVT01:IF(QHHV<=CD/100 AND CROSS(趋势,5),0.6,0),COLORLIRED,LINETHICK2;
QHHVT10:IF(QHHV1<=CDZQ/100 AND CROSS(5,趋势),1.3, 1),COLORRED,LINETHICK2;
QHHVT11:IF(QHHV1<=CDZQ/100 AND CROSS(趋势,5),1.6, 1),COLORLIRED,LINETHICK2;
QHHVT20:IF(QHHV2<=CDCQ/100 AND CROSS(5,趋势),2.3, 2),COLORRED,LINETHICK2;
QHHVT21:IF(QHHV2<=CDCQ/100 AND CROSS(趋势,5),2.6, 2),COLORLIRED,LINETHICK2;
QLLVT00:IF(QLLV<=TD/100 AND CROSS(趋势,90),-0.6,0),COLORBLUE,LINETHICK2;
QLLVT01:IF(QLLV<=TD/100 AND CROSS(90,趋势),-0.6,0),COLORLIBLUE,LINETHICK2;
QLLVT10:IF(QLLV1<=TDZQ/100 AND CROSS(趋势,90),0.6,1),COLORBLUE,LINETHICK2;
QLLVT11:IF(QLLV1<=TDZQ/100 AND CROSS(90,趋势),0.6,1),COLORLIBLUE,LINETHICK2;
QLLVT20:IF(QLLV2<=TDCQ/100 AND CROSS(趋势,90),1.6,2),COLORBLUE,LINETHICK2;
QLLVT21:IF(QLLV2<=TDCQ/100 AND CROSS(90,趋势),1.6,2),COLORLIBLUE,LINETHICK2;
DRAWTEXT(QHHVT00=0.3 AND QU10=1 ,0,'1');
DRAWTEXT(QHHVT00=0.3 AND QU15=1 ,-0.2,'15');
DRAWTEXT(QHHVT00=0.3 AND QU20=1 ,0,'2');
DRAWTEXT(QHHVT00=0.3 AND QU25=1 ,-0.2,'25');
DRAWTEXT(QHHVT00=0.3 AND QU30=1 ,0,'3');
DRAWTEXT(QHHVT00=0.3 AND QU35=1 ,-0.2,'35');
DRAWTEXT(QHHVT00=0.3 AND QU40=1 ,0,'4');
DRAWTEXT(QHHVT00=0.3 AND QU45=1 ,-0.2,'45');
DRAWTEXT(QHHVT00=0.3 AND QU50=1 ,0,'5');
DRAWTEXT(QHHVT00=0.3 AND QU55=1 ,-0.2,'55');
DRAWTEXT(QHHVT00=0.3 AND QU60=1 ,0,'6');
DRAWTEXT(QHHVT00=0.3 AND QU65=1 ,-0.2,'65');
DRAWTEXT(QHHVT00=0.3 AND QU70=1 ,0,'7');
DRAWTEXT(QHHVT00=0.3 AND QU75=1 ,-0.2,'75');
DRAWTEXT(QHHVT00=0.3 AND QU80=1 ,0,'8');
DRAWTEXT(QHHVT00=0.3 AND QU85=1 ,-0.2,'85');
DRAWTEXT(QHHVT00=0.3 AND QU90=1 ,0,'9');
DRAWTEXT(QHHVT00=0.3 AND QU95=1 ,-0.2,'95');
DRAWTEXT(QLLVT00=-0.6 AND QUL10=1 ,0.6,'1');
DRAWTEXT(QLLVT00=-0.6 AND QUL15=1 ,1,'15');
DRAWTEXT(QLLVT00=-0.6 AND QUL20=1 ,0.6,'2');
DRAWTEXT(QLLVT00=-0.6 AND QUL25=1 ,1,'25');
DRAWTEXT(QLLVT00=-0.6 AND QUL30=1 ,0.6,'3');
DRAWTEXT(QLLVT00=-0.6 AND QUL35=1 ,1,'35');
DRAWTEXT(QLLVT00=-0.6 AND QUL40=1 ,0.6,'4');
DRAWTEXT(QLLVT00=-0.6 AND QUL45=1 ,1,'45');
DRAWTEXT(QLLVT00=-0.6 AND QUL50=1 ,0.6,'5');
DRAWTEXT(QLLVT00=-0.6 AND QUL55=1 ,1,'55');
DRAWTEXT(QLLVT00=-0.6 AND QUL60=1 ,0.6,'6');
DRAWTEXT(QLLVT00=-0.6 AND QUL65=1 ,1,'65');
DRAWTEXT(QLLVT00=-0.6 AND QUL70=1 ,0.6,'7');
DRAWTEXT(QLLVT00=-0.6 AND QUL75=1 ,1,'75');
DRAWTEXT(QLLVT00=-0.6 AND QUL80=1 ,0.6,'8');
DRAWTEXT(QLLVT00=-0.6 AND QUL85=1 ,1,'85');
DRAWTEXT(QLLVT00=-0.6 AND QUL90=1 ,0.6,'9');
DRAWTEXT(QLLVT00=-0.6 AND QUL95=1 ,1,'95');
DRAWTEXT(ISLASTBAR=1,0,'短期');
DRAWTEXT(ISLASTBAR=1,1,'中期');
DRAWTEXT(ISLASTBAR=1,2,'长期');

通达信跌幅共振修正版指标公式

 

相关文章