在线检测未来函数

通达信看图操盘指标公式

来源:Internet,编辑:股旁网,2015-10-13

A:=VOL*CLOSE;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,17);
主力:=(B-B1)*100/B,COLORYELLOW;
买:IF(主力>0 AND 0>=REF(主力,1),6,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;
买1:IF(REF(主力,1)<3 AND REF(主力,1)>0 AND (主力-REF(主力,1))>6,6,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;
买2:IF(REF(主力,1)<0 AND (主力-REF(主力,1))>6,6,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;
卖:IF(主力<0 AND 0<=REF(主力,1),6,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
卖1:IF(REF(主力,1)>8 AND REF(主力,1)-主力>6,6,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
{黄金中线作为中线指标}
JJ:=(CLOSE+HIGH+LOW)/3;
AA:=EMA(JJ,5);
BB:=REF(AA,1);
CC:IF(AA>BB,0,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORRED;
DD:IF(AA<=BB,0,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
{20日均线作为长线指标}
EE:=EMA(JJ,20);
持股:IF(EE>REF(EE,1),-3,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;
持币:IF(EE<=REF(EE,1),-3,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
{3日均线作为短线指标}
FF:IF(EMA(CLOSE,3)>REF(EMA(CLOSE,3),1),3,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORRED;
GG:IF(EMA(CLOSE,3)<=REF(EMA(CLOSE,3),1),3,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
{利多方舟}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
{综合判断}
HH:=IF(CLOSE>(HIGH+LOW)/2,1,0)+IF(CROSS(VAR200,MA(VAR300,5)),2,0)
+IF(FF=3,1,0)+IF(持股=-3,1,0)+IF(CC=0,1,0)+IF(买=6,2,0)
+IF(买1=6,2,0)+IF(买2=6,2,0);
II:=IF(CLOSE<=(HIGH+LOW)/2,-1,0)+IF(CROSS(MA(VAR300,5),VAR100),-2,0)+IF(DD=0,-1,0)
+IF(GG=3,-1,0)+IF(持币=-3,-1,0)+IF(卖=6,-2,0)+IF(卖1=6,-2,0);
DRAWICON(HH>=5,-7,7);
DRAWICON(II<=-5,-7,8);
KK:15;
LL:-15;

通达信看图操盘指标公式

 

相关文章