在线检测未来函数

通达信春种秋收指标公式

来源:Internet,编辑:股旁网,2015-10-13

DRAWGBK(C>0,RGB(0,0,139),RGB(0,139,139),0,'',0);
OK:=100*(L-REF(C,1))/REF(C,1)<-3.5 AND 100*(O-L)/REF(C,1)>3.5
AND 100*(C-REF(C,1))/REF(C,1)>2,STICK,COLORMAGENTA,LINETHICK6;
L1:=MA(CLOSE,27);
L2:=(CLOSE-L1)/L1*100;
L3:=MA(L2,2);
L4:=BARSLAST(CROSS(-10,L3)=1);
L5:=L3<-10 AND L4>3;
LK:=ABS( IF(L5,L3,0));
JK:=LK>0;
OL:=DMA(EMA(C,60),SUM(V,60)/CAPITAL)*POW(IF(C>60,100,10),6)/EXP(2*H-L/3)/2,LINETHICK2;
春种:=OK AND OL AND JK;
STICKLINE(春种,0,0.22,3,0),COLORFFFF00;
STICKLINE(春种,0,28,2,0),COLOR191970;
STICKLINE(春种,0,28,1,0),COLOR191970;
STICKLINE(春种,0,8,0.2,0),COLORGREEN;
DRAWTEXT(春种,16,'春种'),COLORRED;
DRAWICON(春种,春种*1.28*22,17);
DRAWICON(春种,春种*1.28*18,17);
{秋收}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
S:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(REF(MA(DX,2),1),DX),1,0);
STICKLINE(S,0,0.20,3,0),COLOR008888;
STICKLINE(S,0,28,2,0),COLORFFD700;
STICKLINE(S,0,28,1,0),COLOR0000FF;
STICKLINE(S,0,8,0.2,0),COLOR0000FF;
DRAWTEXT(S,16,'秋收'),COLORGREEN;
DRAWICON(S,S*1.28*22,18);
DRAWICON(S,S*1.28*18,18);
平均成交额:MA(AMOUNT,15)/10000000,COLORGRAY;
临界成效额:MA(平均成交额,9),COLORLIBLUE;
STICKLINE(平均成交额<REF(平均成交额,1) OR (AMOUNT/REF(AMOUNT,1)<0.97),平均成交额,REF(平均成交额,1),1,0),LINETHICK1,COLORYELLOW;
STICKLINE(平均成交额>=REF(平均成交额,1),平均成交额,REF(平均成交额,1),1,0),LINETHICK1,COLORRED;
STICKLINE(平均成交额<临界成效额,平均成交额,REF(平均成交额,1),1,0),LINETHICK1,COLORGREEN;
3;
0;
-3;
-3,STICK,LINETHICK3,COLORGREEN;
3,CIRCLEDOT;
2,CIRCLEDOT;
1,CIRCLEDOT;

通达信春种秋收指标公式

 

相关文章