在线检测未来函数

飞狐震荡趋势指标公式

来源:Internet,编辑:股旁网,2015-10-20

{---------------------【右侧实效-功能开关】---------------------}
{价格重心}
A:=(H+L+O+C*3)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
X1:=(C+L+H)/3;X2:=EMA(X1,6);X3:=EMA(X2,5);
{震荡趋势}
VAR1:=(A-LLV(L,100))/(HHV(H,100)-LLV(L,100))*100-50;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=3*VAR2-2*VAR3;
VAR5:=EMA((A-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100-50,2);
VAR6:=SMA(VAR5,3,1);
VAR7:=SMA(VAR6,3,1);
VAR8:=3*VAR6-2*VAR7;
VAR9:=(A-EMA(A,13))/STD(A,13)*50;
VAR10:=EMA(EMA(VAR9,5),13);
VAR11:=EMA(VAR10,10);
VAR12:=3*VAR10-2*VAR11;
VARA:=VAR2+VAR6+VAR10;
VARB:=VAR3+VAR7+VAR11;
VARC:=VAR4+VAR8+VAR12;
VARD:=((VARA+VARB+VARC)/3)/8;
CD:=EMA(EMA(VARD,5),3);
CD1:=SMA(CD,4,1);
CDD1:=EMA(VARD,13);
ZD1:=SMA(CDD1,3,1);
CDD2:=SMA(VARD,13,1);
ZD2:=EMA(CDD2,5);
{---------------------【右侧直效-图解模板】---------------------}
REFLINE:20,-20,16,-16;
{背景填色}
FILLRGN(1,0,-8),COLOR001100;
FILLRGN(1,0,8),COLOR000040;
FILLRGN(1,-8,-5.5),COLOR002000;
FILLRGN(1,8,5.5),COLOR000020;
PARTLINE(1,0),COLOR000000;
DRAWICON(CROSS(X2,X3),-18,9);DRAWICON(CROSS(X3,X2),18,10);
{震荡趋势}
FILLRGN(1,ZD1,ZD2),COLOR002851;
PARTLINE(1,ZD2),COLOR004080;
STICKLINE(CD>=CD1,CD,CD1,4,0),COLOR4E004E;
STICKLINE(CD>=CD1,CD,CD1,3,0),COLOR660066;
STICKLINE(CD>=CD1,CD,CD1,2,0),COLOR840084;
STICKLINE(CD>=CD1,CD,CD1,1,0),COLORA200A2;
STICKLINE(CD<CD1,CD,CD1,4,0),COLOR404040;
STICKLINE(CD<CD1,CD,CD1,3,0),COLOR505050;
STICKLINE(CD<CD1,CD,CD1,2,0),COLOR696969;
STICKLINE(CD<CD1,CD,CD1,1,0),COLOR8B8B8B;

飞狐震荡趋势指标公式

 

相关文章