在线检测未来函数

通达信风云KDJ指标公式

来源:Internet,编辑:股旁网,2015-10-20

N:=90;
P1:=3;
P2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,P1,1);
D:SMA(K,P2,1);
J:3*K-2*D;
{KDJ日周金叉死叉}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周J:="KDJ.J#WEEK"(9,3,3);
周金叉:=CROSS(周K,周D);
日金叉:=FILTER(CROSS(K,D) AND K<20,4);
DRAWTEXT(周金叉,D,'★'),COLORYELLOW;
DRAWTEXT(周金叉,D*0.93,' KD周金叉'),COLORYELLOW;
DRAWTEXT(CROSS(周D,周K),D*0.95,'KD周死叉'),COLOR00DDBB;
DRAWICON(日金叉,K,1);
DRAWTEXT(日金叉,D,'低位金叉'),COLOR00CCCC;
KDB:=BARSLAST(REF(CROSS(K,D),1));
KDDB:=REF(CLOSE,KDB+1)>CLOSE AND REF(K,KDB+1)<K AND CROSS(K,D);
K底背:=IF(FILTER(KDDB>0,5),1,0);
DRAWTEXT(K底背=1,D*0.98,'底背离'),COLORRED;
KDD:=BARSLAST(REF(CROSS(D,K),1));
K顶背:=REF(CLOSE,KDD+1)<CLOSE AND REF(K,KDD+1)>K AND CROSS(D,K);
DRAWTEXT(FILTER(K顶背>0,5),D+8,'顶背离'),COLORFFAA22;
STICKLINE(C>0,-20,5,4,0),COLORBLACK;
F1:=ZIG(3,15);
F2:=IF((F1> REF(F1,1)),100,80);
MA势:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100;
势:EMA(MA势,5),COLORLIRED,DOTLINE;
IF(势<=45,势,DRAWNULL),COLORGREEN,DOTLINE;
趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
ZZ:=趋势>REF(趋势,1);
K1:=DVOL/1000000;
K2:=DCLOSE;
V1:=EMA(K1,5);
V2:=EMA(K2,5);
价异动:=K2>REF(V2,1)*1.06;
量异动:=K1>REF(V1,1)*1.6&&ZZ;
停牌:=DYNAINFO(17)>0;
M1:=SUM(价异动,2)>0 AND 停牌;
M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;
共鸣:(F2=100 AND C>REF(C,1) AND FILTER(M1 AND M2,3))*30,COLORRED;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
TX:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
TJ1X:=COUNT(TX=0,100)=0;
TJ2:=COUNT(T2L=0,100)=0;
TJ3:=COUNT(T3L=0,100)=0;
TJ4:=COUNT(T4L=0,100)=0;
TJ5:=COUNT(T5L=0,100)=0;
TJA:=C>REF(C,1)*1.05;
AA:=REF(TX,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200);
M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
D3:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJX:=COUNT(XGX,30)=2 AND XGX;
SR11:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR21:=FILTER(SR11,10);
SR31:=BACKSET(SR21,10+1);
HDH:=FILTER(SR31,10);
前高G:=REF(H,BARSLAST(HDH));
倍量G:=VOL/REF(VOL,1)>=1.9;
突破前高G:=CROSS(C,前高G);
YG:= 倍量G AND 突破前高G;
SJG:=BARSLAST(YG);
H300:=HHVBARS(DIF,300);
AL:=BOLL.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EXPMA(C,25);
Z,:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
Z,F:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND Z,F<17 AND Z, AND TJQ;
起程:=TJ1Q AND XL>75;
A1F:=REF(C,1);
A3F:=(DCLOSE-A1F)/A1F*100;
AA1F:=(A3F-REF(A3F,1));
选股1:=CROSS(AA1F,9.8);
A11F:=REF(V,1);
A13F:=DVOL/A11F;
AA3F:=(A13F-REF(A13F,1));
选股2:=CROSS(AA3F,500);
潜伏:=选股1 AND 选股2;
爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100;
XB:=CROSS(爆发点,20);
TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4L:=TJ1L OR TJ2L OR TJ3L;
TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9;
KCCC3:=中线/长线1<1+0.01*20;
大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L;
VARAA:=LLV(LOW,5);
VARBA:=HHV(HIGH,5);
确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4);
MA500:=MA(CLOSE,500);
MA250:=MA(CLOSE,250);
MA120:=MA(CLOSE,120);
MA30:=MA(CLOSE,33);
MA60:=MA(CLOSE,55);
涨停收盘:=(C-REF(C,1))*100/REF(C,1)>=4 AND H-C<0.02;
HD30:=FILTER(BACKSET(FILTER(REF(H,30)=HHV(H,2*30+1),30),30+1),30);
LD30:=FILTER(BACKSET(FILTER(REF(H,30)=LLV(H,2*30+1),30),30+1),30);
AX30:=REF(H,BARSLAST(HD30));
T300:=BARSLAST(HD30)<BARSLAST(LD30) AND NOT(HD30);
顶30:=IF(T300,AX30,AX30);
JZ:=(CROSS(C,顶30) AND DIF>=-0.21 AND DEA<=0.37 AND MA30>MA60 AND (CROSS(C,MA30)OR CROSS(C,MA120)OR CROSS(C,MA250)OR CROSS(C,MA500) OR LOW< MA30)) AND MA30- MA60<0.7 AND 涨停收盘 AND ABS((顶30-MA30)/顶30*100)<10;
信号:IF(确>REF(确,1) AND DIF>DEA AND (JZ OR 大牛 OR XB OR 潜伏 OR 起程 OR CURRBARSCOUNT=CONST(SJG)+2 OR TJX OR (CCI<=100 AND L<=低2)),100,0),STICK,COLORFF00FF,LINETHICK2;
卖警:IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN;
泥淖:IF((F1> REF(F1,1)),100,80),COLORFF9900;
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
上0:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
下0:=DRAWLINE(Y1,Y2,Y3,Y4,0);
TJ:=IF(上0<REF(上0,1) AND 下0=上0,1,0);
未来空柱:=IF(REF(TJ,1)=0 AND TJ>=1,100,0);
{K线形态解盘}
TT:=240/FROMOPEN;
比:=TT;
J12:=(HIGH - ((HIGH - LOW) / 3));
J23:=(LOW + ((HIGH - LOW) / 3));
T1{早晨之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T2{黄昏之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1)
> REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02
AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));
T3{长十字}:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));
T4{垂死十字}:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH),1,0));
T5{早晨十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1)
< REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T6{黄昏十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1)
> REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));
T7{射击之星}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5)),1,0));
T8{倒转锤头}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW >
3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5)),1,0));
T9{锤头}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5)),1,0));
T10{吊颈}:=CONST(IF((HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW >
3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
T11{穿头破脚}:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96
AND CLOSE<REF(OPEN,1)
AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04
AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));
T12{乌云盖顶}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97
AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));
T13{曙光初现}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03
AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));
T14{身怀六甲}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)
> MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));
T15{十字胎}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1)
,REF(OPEN,1))),1,0));
T16{平顶}:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH<0.001),1,0));
T17{平底}:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)
-REF(LOW,2))/REF(LOW,1)<=0.001)),1,0));
T18{大阳烛}:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018),1,0));
T19{三个白武士}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)
>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));
T20{双飞乌鸦}:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN
AND CLOSE/OPEN<0.98),1,0));
T21{孕育线}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)
-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1)
AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)
<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN
AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1)
AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))
<=1/100),1,0));
T22{多方炮}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND CLOSE>OPEN),1,0));
T23{出水芙蓉}:=CONST(IF(((OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<
EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)
>1.2 AND C/REF(C,1)>1.049)),1,0));
T24{上升三部曲}:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)
<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2)
AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4)),1,0));
T25{下跌三部曲}:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)
>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1)
AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)
<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4)),1,0));
T26{跳空缺口}:=CONST(IF(HIGH<REF(LOW,1) OR LOW>REF(HIGH,1),1,0));
T27{三只乌鸦}:=CONST(IF((REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)
<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2)
AND CLOSE<REF(CLOSE,1)),1,0));
T28{光脚阴线}:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));
T29{光头阳线}:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));
T30{分离}:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)
-REF(OPEN,1))<0),1,0));
T31{长下影}:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667),1,0));
T32{长上影}:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667),1,0));
T33{十字星}:=CONST(IF((CLOSE=OPEN AND HIGH!=LOW),1,0));
T34{大阴烛}:=CONST(IF((OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018),1,0));
T35{好友反攻}:=CONST(IF(((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN
AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1)
AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))
/CLOSE<0.002)),1,0));
T36{倾盆大雨}:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O
>REF(O,1) AND C<REF(O,1)),1,0));
T37{M9}:=CONST(V*比>REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T38{M10}:=CONST(V*比<REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T39{M11}:=CONST(V*比>REF(V,1)AND MA(V,5)<REF(MA(V,5),1));
T40{M12}:=CONST(V*比<REF(V,1)AND MA(V,5)<REF(MA(V,5),1));
T41{M13}:=CONST((((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1));
T42{M14}:=CONST((((AMOUNT / VOL) / 100) > REF(HIGH,1)));
T43{M15}:=CONST((((AMOUNT / VOL) / 100) < REF(LOW,1)));
TS1:=IF(T1=1,0.02+0.02,0.02),NODRAW;
TS2:=IF(T2=1,TS1+0.08,TS1),NODRAW;
TS3:=IF(T3=1,TS2+0.08,TS2),NODRAW;
TS4:=IF(T4=1,TS3+0.08,TS3);
TS5:=IF(T5=1,TS4+0.08,TS4);
TS6:=IF(T6=1,TS5+0.08,TS5);
TS7:=IF(T7=1,TS6+0.08,TS6);
TS8:=IF(T8=1,TS7+0.08,TS7);
TS9:=IF(T9=1,TS8+0.08,TS8);
TS10:=IF(T10=1,TS9+0.08,TS9),NODRAW;
TS11:=IF(T11=1,TS10+0.08,TS10);
TS12:=IF(T12=1,TS11+0.08,TS11);
TS13:=IF(T13=1,TS12+0.08,TS12);
TS14:=IF(T14=1,TS13+0.08,TS13);
TS15:=IF(T15=1,TS14+0.08,TS14);
TS16:=IF(T16=1,TS15+0.08,TS15);
TS17:=IF(T17=1,TS16+0.08,TS16);
TS18:=IF(T18=1,TS17+0.08,TS17);
TS19:=IF(T19=1,TS18+0.08,TS18);
TS20:=IF(T20=1,TS19+0.08,TS19);
TS21:=IF(T21=1,TS20+0.08,TS20);
TS22:=IF(T22=1,TS21+0.08,TS21);
TS23:=IF(T23=1,TS22+0.08,TS22);
TS24:=IF(T24=1,TS23+0.08,TS23);
TS25:=IF(T25=1,TS24+0.08,TS24);
TS26:=IF(T26=1,TS25+0.08,TS25);
TS27:=IF(T27=1,TS26+0.08,TS26);
TS28:=IF(T28=1,TS27+0.08,TS27);
TS29:=IF(T29=1,TS28+0.08,TS28);
TS30:=IF(T30=1,TS29+0.08,TS29);
TS31:=IF(T31=1,TS30+0.08,TS30);
TS32:=IF(T32=1,TS31+0.08,TS31);
TS33:=IF(T33=1,TS32+0.08,TS32);
TS34:=IF(T34=1,TS33+0.08,TS33);
TS35:=IF(T35=1,TS34+0.08,TS34);
TS36:=IF(T36=1,TS35+0.08,TS35);
TS37:=IF(T37=1,TS36+0.08,TS36);
TS38:=IF(T38=1,TS37+0.08,TS37);
TS39:=IF(T39=1,TS38+0.08,TS38);
TS40:=IF(T40=1,TS39+0.08,TS39);
TS41:=IF(T41=1,TS36+0.08,TS36);
TS42:=IF(T42=1,TS41+0.08,TS41);
TS43:=IF(T43=1,TS42+0.08,TS42);
DRAWTEXT_FIX(T1=1,0,TS1,0,'早晨之星,仅在低位见底回升【其余区域忽略】'),COLORFF00FF ;
DRAWTEXT_FIX(T2=1,0,TS2,0,'黄昏之星,处高位见顶回落'),COLORFFFF00 ;
DRAWTEXT_FIX(T3=1,0,TS3,0,'长十字,重要的警告信号,原趋势停顿或反转'),COLORGREEN ;
DRAWTEXT_FIX(T4=1,0,TS4,0,'垂死十字,下跌信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T5=1,0,TS5,0,'早晨十字星,处低位时为上涨信号,见底回升'),COLORFF00FF ;
DRAWTEXT_FIX(T6=1,0,TS6,0,'黄昏十字星,趋势停顿或反转,下跌或见顶回落'),COLORFFFF00 ;
DRAWTEXT_FIX(T7=1,0,TS7,0,'射击之星,可能见顶回落'),COLORFFFF00 ;
DRAWTEXT_FIX(T8=1,0,TS8,0,'倒转锤头构成一个看涨信号,可能见底回升'),COLORFF00FF ;
DRAWTEXT_FIX(T9=1,0,TS9,0,'锤头,在低位可能见底回升,如有量配合,信号强烈【高位观望】'),COLOR0000FF ;
DRAWTEXT_FIX(T10=1,0,TS10,0,'吊颈,上升行情中见顶回落,如高位出现,见顶信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T11=1,0,TS11,0,'穿头破脚,处高位出现,见顶回落信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T12=1,0,TS12,0,'乌云盖顶,见顶回落信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T13=1,0,TS13,0,'曙光初现,将演化为V型反转或横盘。'),COLORFF00FF ;
DRAWTEXT_FIX(T14=1,0,TS14,0,'身怀六甲,低位或见底回升;高位见顶回落信号'),COLORGREEN ;
DRAWTEXT_FIX(T15=1,0,TS15,0,'十字胎'),COLORGREEN ;
DRAWTEXT_FIX(T16=1,0,TS16,0,'平顶,行情见顶,股价将反转。但下跌力度较小'),COLORFFFFFF ;
DRAWTEXT_FIX(T17=1,0,TS17,0,'平底,行情探低见底,股价行将反转上升,但力度较小'),COLORFFFFFF ;
DRAWTEXT_FIX(T21=1,0,TS21,0,'孕育线,注意股价位置'),COLOR00FFFF ;
DRAWTEXT_FIX(T22=1,0,TS22,0,'多方炮,低位可能上涨,中位上涨中继,高位或为见顶预警信号'),COLORFFFFFF ;
DRAWTEXT_FIX(T23=1,0,TS23,0,'出水芙蓉,阳线穿过20、40、60日均线,上攻势头初现'),COLORRED ;
DRAWTEXT_FIX(T24=1,0,TS24,0,'上升三部曲,上涨信号'),COLORFF00FF ;
DRAWTEXT_FIX(T25=1,0,TS25,0,'下跌三部曲,下跌信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T27=1,0,TS27,0,'三只乌鸦站枝头,见顶回落'),COLORFFFF00 ;
DRAWTEXT_FIX(T28=1,0,TS28,0,'光脚阴线,下跌信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T29=1,0,TS29,0,'光头阳线,低位或中位是积极上攻态势,后市看涨【高位谨慎】'),COLOR00FFFF ;
DRAWTEXT_FIX(T31=1,0,TS31,0,'长下影,有可能止跌回升,但在高位升势末期须小心'),COLORGREEN ;
DRAWTEXT_FIX(T32=1,0,TS32,0,'长上影,表明行情上档压力沉重,升势受阻'),COLORFFFF00 ;
DRAWTEXT_FIX(T33=1,0,TS33,0,'十字星,重要的警告信号,原趋势停顿或反转'),COLORGREEN ;
DRAWTEXT_FIX(T34=1,0,TS34,0,'大阴烛,后市向淡,发生逆转'),COLORLIBLUE ;
DRAWTEXT_FIX(T36=1,0,TS36,0,'倾盆大雨,见顶信号'),COLORFFFF00 ;
DRAWTEXT_FIX(T41=1,0,TS41,0,'极端行情,在未来的几日内可能变更方向'),COLORFFFF00 ;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
倍量:=VOL/REF(VOL,1)>=1.9;
突破前高:=CROSS(C,前高);
Y:= 倍量 AND 突破前高;
SJ:=BARSLAST(Y);
DRAWTEXT(CURRBARSCOUNT=CONST(SJ)+2,45,'过左峰'),COLORYELLOW;
B:=ZIG(3,10);
G:=MA(B,2);
W:=CROSS(G,B);
DRAWTEXT(W=1,70,'卖' ),COLOR00FF00;
VARA1:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARA2:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARA3:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARA4:=(((VARA1 + (2 * VARA2)) + (3 * VARA3)) / 6);
VARA5:=MA(VARA4,3);
底部反转:=CROSS(KDJ.J,0) AND (VARA5 <= (0 - 7));
DRAWTEXT(F2=100 AND 底部反转,50,'反转预警'),COLORRED;
值:=(EMA(((CLOSE-LLV(LOW,14))/(HHV(HIGH,35)-LLV(LOW,56)))*(4),4))*(25),COLORGREEN,LINETHICK2;
DRAWTEXT(FILTER(CROSS(值,5),10), 40,'超低'),COLORYELLOW;
DIFX:=(2*EMA(CLOSE, 12)-EMA(EMA(CLOSE,12),12))-(2*EMA(CLOSE, 26)-EMA(EMA(CLOSE, 26),26));
DEAX:=2*EMA(DIFX, 9) - EMA(EMA(DIFX, 9),9);
FF:=C=LLV(C,180);
GG:= DEAX> REF(DEAX,1) AND REF(DEAX> REF(DEAX,1),1)=1;
LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;
拐点出击:=(NOT(未来空柱=100) AND F2=100 AND LL AND GG)*DEAX;
VAR1:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
山底:=IF(CLOSE>SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORGREEN;
山顶:=IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE;
DIFF变红:=IF(DIFF>=REF(DIFF,1),DIFF,DRAWNULL),COLORLIRED;
{DEA:=EMA(DIFF,9),COLORWHITE;}
DEA变红:=IF(DEA>=REF(DEA,1),DEA,DRAWNULL),COLORLIMAGENTA;
{MACD:=2*(DIFF-DEA),COLORSTICK;}
NOTEXT上买下卖:=CLOSE-REF(CLOSE,49),COLORWHITE;
NOTEXT红买绿卖:=MA(NOTEXT上买下卖,49),COLORGREEN;
上买下卖:=IF(NOTEXT上买下卖>NOTEXT红买绿卖,NOTEXT上买下卖,DRAWNULL),LINETHICK2,COLORMAGENTA;
红买绿卖:=IF(NOTEXT红买绿卖>=REF(NOTEXT红买绿卖,1) AND NOTEXT上买下卖>NOTEXT红买绿卖,NOTEXT红买绿卖,DRAWNULL),LINETHICK3,COLORRED;
红买:=上买下卖 AND 红买绿卖 AND DEA变红,COLORRED,NODRAW;
绿卖:=红买!=1,COLORGREEN,NODRAW;
底:=SMA(VAR2,3,1),COLORGREEN;
顶:=SMA(底,3,1),COLORRED;
方向:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
方向向下:=(DMA((2*CLOSE+LOW+HIGH)/4,方向)),COLORGREEN;
红灯停:=IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED;
向下:=方向向下 AND 红灯停,COLORGREEN,NODRAW;
空仓基因:=绿卖 AND 向下,COLORGREEN,NODRAW;
B2:=BARSLAST(REF(CROSS(顶,底),1));
顶背离:=空仓基因 AND REF(C,B2+1)<HHV(H,3) AND REF(底,B2+1)>底 AND CROSS(顶,底) AND 底>80 AND MA(C,5)>MA(C,377) AND 山顶;
DRAWTEXT(顶背离=1,85,'顶背'),COLORFFFF00;
DRAWTEXT(FILTER(拐点出击,30), 30,'拐点→'),COLORWHITE;

通达信风云KDJ指标公式

 

相关文章