在线检测未来函数

同花顺OAMV活跃指标公式

来源:Internet,编辑:股旁网,2015-10-21

N:=10;
Var1:=SMA(O*AMOUNT/10000000,n,1);
C0:=INTPART(Var1*1000)/1000;
B1:=REF(C0,1);B2:=REF(C0,2);B3:=REF(C0,3);B4:=REF(C0,4);B5:=REF(C0,5);B6:=REF(C0,6);B7:=REF(C0,7);
B8:=REF(C0,8);B9:=REF(C0,9);B10:=REF(C0,10);B11:=REF(C0,11);B12:=REF(C0,12);B13:=REF(C0,13);B14:=REF(C0,14);
B15:=REF(C0,15);B16:=REF(C0,16);B17:=REF(C0,17);B18:=REF(C0,18);B19:=REF(C0,19);B20:=REF(C0,20);
B21:=REF(C0,21);B22:=REF(C0,22);B23:=REF(C0,23);B24:=REF(C0,24);B25:=REF(C0,25);B26:=REF(C0,26);
B27:=REF(C0,27);B28:=REF(C0,28);B29:=REF(C0,29);B30:=REF(C0,30);B31:=REF(C0,31);B32:=REF(C0,32);
B33:=REF(C0,33);B34:=REF(C0,34);B35:=REF(C0,35);B36:=REF(C0,36);B37:=REF(C0,37);B38:=REF(C0,38);
B39:=REF(C0,39);B40:=REF(C0,40);B41:=REF(C0,41);B42:=REF(C0,42);B43:=REF(C0,43);B44:=REF(C0,44);
B45:=REF(C0,45);B46:=REF(C0,46);B47:=REF(C0,47);B48:=REF(C0,48);B49:=REF(C0,49);B50:=REF(C0,50);
HL:=IF(C0>B1 AND B1>=B2,1,IF(C0<B1 AND B1<=B2,-1,IF(C0>B2 AND B2>B1,2,IF(C0<B2 AND B2<B1,-2,0))));
HG:=IF(B1>B2 AND B1>B3,1,IF(B1<B2 AND B1<B3,-1,IF(B2>B3 AND B2>B4,2,IF(B2<B3 AND B2<B4,-2,
IF(B3>B4 AND B3>B5,3,IF(B3<B4 AND B3<B5,-3,IF(B4>B5 AND B4>B6,4,IF(B4<B5 AND B4<B6,-4,
IF(B5>B6 AND B5>B7,5,IF(B5<B6 AND B5<B7,-5,IF(B6>B7 AND B6>B8,6,IF(B6<B7 AND B6<B8,-6,
IF(B7>B8 AND B7>B9,7,IF(B7<B8 AND B7<B9,-7,IF(B8>B9 AND B8>B10,8,IF(B8<B9 AND B8<B10,-8,
IF(B9>B10 AND B9>B11,9,IF(B9<B10 AND B9<B11,-9,IF(B10>B11 AND B10>B12,10,IF(B10<B11 AND B10<B12,-10,
IF(B11>B12 AND B11>B13,11,IF(B11<B12 AND B11<B13,-11,IF(B12>B13 AND B12>B14,12,IF(B12<B13 AND B12<B14,-12,
IF(B13>B14 AND B13>B15,13,IF(B13<B14 AND B13<B15,-13,IF(B14>B15 AND B14>B16,14,IF(B14<B15 AND B14<B16,-14,
IF(B15>B16 AND B15>B17,15,IF(B15<B16 AND B15<B17,-15,IF(B16>B17 AND B16>B18,16,IF(B16<B17 AND B16<B18,-16,
IF(B17>B18 AND B17>B19,17,IF(B17<B18 AND B17<B19,-17,IF(B18>B19 AND B18>B20,18,IF(B18<B19 AND B18<B20,-18,
IF(B19>B20 AND B19>B21,19,IF(B19<B20 AND B19<B21,-19,IF(B20>B21 AND B20>B22,20,IF(B20<B21 AND B20<B22,-20,
IF(B21>B22 AND B21>B23,21,IF(B21<B22 AND B21<B23,-21,IF(B22>B23 AND B22>B24,22,IF(B22<B23 AND B22<B24,-22,
IF(B23>B24 AND B23>B25,23,IF(B23<B24 AND B23<B25,-23,IF(B24>B25 AND B24>B26,24,IF(B24<B25 AND B24<B26,-24,
IF(B25>B26 AND B25>B27,25,IF(B25<B26 AND B25<B27,-25,IF(B26>B27 AND B26>B28,26,IF(B26<B27 AND B26<B28,-26,
IF(B27>B28 AND B27>B29,27,IF(B27<B28 AND B27<B29,-27,IF(B28>B29 AND B28>B30,28,IF(B28<B29 AND B28<B30,-28,
IF(B29>B30 AND B29>B31,29,IF(B29<B30 AND B29<B31,-29,IF(B30>B31 AND B30>B32,30,IF(B30<B31 AND B30<B32,-30,
IF(B31>B32 AND B31>B33,31,IF(B31<B32 AND B31<B33,-31,IF(B32>B33 AND B32>B34,32,IF(B32<B33 AND B32<B34,-32,
IF(B33>B34 AND B33>B35,33,IF(B33<B34 AND B33<B35,-33,IF(B34>B35 AND B34>B36,34,IF(B34<B35 AND B34<B36,-34,
IF(B35>B36 AND B35>B37,35,IF(B35<B36 AND B35<B37,-35,IF(B36>B37 AND B36>B38,36,IF(B36<B37 AND B36<B38,-36,
IF(B37>B38 AND B37>B39,37,IF(B37<B38 AND B37<B39,-37,IF(B38>B39 AND B38>B40,38,IF(B38<B39 AND B38<B40,-38,
IF(B39>B40 AND B39>B41,39,IF(B39<B40 AND B39<B41,-39,IF(B40>B41 AND B40>B42,40,IF(B40<B41 AND B40<B42,-40,
IF(B41>B42 AND B41>B43,41,IF(B41<B42 AND B41<B43,-41,IF(B42>B43 AND B42>B44,42,IF(B42<B43 AND B42<B44,-42,
IF(B43>B44 AND B43>B45,43,IF(B43<B44 AND B43<B45,-43,IF(B44>B45 AND B44>B46,44,IF(B44<B45 AND B44<B46,-44,
IF(B45>B46 AND B45>B47,45,IF(B45<B46 AND B45<B47,-45,IF(B46>B47 AND B46>B48,46,IF(B46<B47 AND B46<B48,-46,
IF(B47>B48 AND B47>B49,47,IF(B47<B48 AND B47<B49,-47,IF(B48>B49 AND B48>B50,48,IF(B48<B49 AND B48<B50,-48,
0))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))));
MA5:EMA(Var1,5),colorcyan;
个股生命线: EMA(Var1,10);
MA34: EMA(Var1,23);
B1,POINTDOT,colorblack;
B2,POINTDOT,colorblack;
STICKLINE(HL=1 OR HG>=1 AND HL=0,B1,C0,5,0),colorred;
STICKLINE(HL=-1 OR HG<=-1 AND HL=0,B1,C0,5,0),colorgreen;
STICKLINE(HL=2,B2,C0,5,0),colorred;
STICKLINE(HL=-2,B2,C0,5,0),colorgreen;
STICKLINE((HL=-1 OR HL=-2) AND HG>0,B2,B1,5,0),colorred;
STICKLINE((HL=1 OR HL=2) AND HG<0,B2,B1,5,0),colorgreen;
Var11:=AMOUNT/600000;
Var22:=SMA(Var11,10,1);
Var33:=REF(Var22,1);
STICKLINE(Var22>Var33,Var22,Var33,7,0),colorred;
STICKLINE(Var22<Var33,Var22,Var33,7,0),colorgreen;

同花顺OAMV活跃指标公式

 

相关文章