在线检测未来函数

通达信波段顶底区域指标公式

来源:Internet,编辑:股旁网,2015-10-21

HDY:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(HDY,RGB(255,000,139),10,RGB(255,255,71));
STICKLINE(C>0,90,10,10,0),COLOR000000;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,13,1);
D1:=SMA(K1,13,1);
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),8,0),COLORFF5D00;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),7,0),COLORFF5D10;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),6,0),COLORFF7710;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),5,0),COLORFF8810;
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),4,0),COLORFF9910;
VA1:=HHV(HIGH,9)-LLV(LOW,9);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(CLOSE+HIGH+LOW)/3;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
DRAWKLINE(EMA(B1,5),EMA(B1,5),B1+1,B1);
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1<EMA(CLOSE,120);
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1),CIRCLEDOT ,COLORFF9900 ;
安全:=20;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;

通达信波段顶底区域指标公式

 

相关文章