在线检测未来函数

通达信出击加仓KDJ指标公式

来源:Internet,编辑:股旁网,2015-10-27

N:=26;
RSVP:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100-50;
KV:=SMA(RSVP,3,1);
DV:=SMA(KV,3,1);
JV:=3*KV-2*DV;
ZDZK1:=EMA(JV,6);
ZDZK2:=REF(ZDZK1,1);
XW1:=IF(O<=REF(O,1),0,MAX((H-O),(O-REF(O,1))));
XW2:=IF(O>=REF(O,1),0,MAX((O-L),(O-REF(O,1))));
XW3:=SUM(XW1,21);
XW4:=SUM(XW2,21);
XW5:=IF(XW3>XW4,(XW3-XW4)/XW3,IF(XW3=XW4,0,(XW3-XW4)/XW4));
{14天强弱}
RS:=SMA(MAX(C-REF(C,1),0),14,1)/SMA(ABS(C-REF(C,1)),14,1)*100;
ZD:= EMA(EMA(EMA(RS,7),3),3);
ZD1:=(ZD-REF(ZD,1))/REF(ZD,1)*15;
STICKLINE(ZD1>=0,0,ZD1*50,0.5,0),COLOR0000BE;
STICKLINE(ZD1<=0,0,ZD1*50,0.5,0),COLORCYAN;
Y1:=AMOUNT/V/100;
Y2:=(3*H+L+O+2*C)/7;
Y3:=100*(WINNER(1.1*C)-WINNER(0.9*C));
Y4:=SUM(AMOUNT,13)/Y1/100;
Y5:= DMA(Y2,V/Y4);
Y6:=(C-Y5)/Y5*100;
Y7:=(Y3<10) AND (Y6<=-10);
Y8:=SMA(MAX(C-REF(C,1.5),0),6,1)/SMA(ABS(C-REF(C,1.5)),1,1)*100;
重亏:STICKLINE(Y6<=-10 AND ZD1<0,ZD1*55,ZD1*45,1,0),COLORFF89B2;
全亏:STICKLINE(Y6<=-16 AND ZD1<0,ZD1*60,ZD1*55,1,1),COLORBLUE;
超跌:STICKLINE(Y7 AND ZD1<0,ZD1*65,ZD1*60,1,0),COLORFFFFFF;
{备战区1}
ZDD1:=(HHV(H,21)-C)/(HHV(H,21)-LLV(L,21))*100-10;
ZDD2:=(C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;
ZDD3:=SMA(ZDD2,13,8);
ZDD4:=CEILING(SMA(ZDD3,13,8));
ZDD5:=SMA(ZDD1,21,8);
XH1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
XH2:=ZDD4-ZDD5<-65 AND XH1<12;
备战区:=XH2;
{备战区2}
XX1:=MA(LOW,2)*0.96;
XX2:=MA(LOW,26)*0.85;
XX3:= REF(XX1,1)<XX2 AND REF(XX1,1)<XX1 AND REF(XX1,1)<REF(XX1,2);{30}
备战区2:=XX3;
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
DSY:=100*VOL/CAPITAL;
备战区3:=(C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8;
{STICKLINE((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,0,ZD1*25,1,0),COLOR006EFF;
DRAWICON((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,0,1);}
{备战区4}
WW1:= SUM( MA(C,10),9)/10.110;
WW2:=CROSS(C,WW1);
VW1:=DMA(EMA(C,12),SUM(V,5)/3/CAPITAL);
VW2:=REF(H,10)/C>1.35;
VW3:=(COST(20)-C)/C>0.15;
VW4:=H>L*1.051;
VW5:=VW4 AND COUNT(VW4,5)>1;
VW6:=(((C-VW1)/VW1*100<-30) OR VW2) AND VW3 AND VW5;
{STICKLINE(VW6,0,ZD1*-40,1,0),COLOR0000FF;}
DRAWICON(VW6,ZD1*-40,4);
{买2}
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3 OR VW6,0,15,1,0),COLORF8B7F0;
DRAWTEXT(XL3 OR VW6,15,'←买'),COLORF8B7F0;
{井喷}
JJP1:=REF(INDEXC,1);
JJP2:=FILTER((INDEXC-JJP1)/JJP1>0.03 AND ZDZK1>=ZDZK2,7);
STICKLINE(JJP2,0,-15,4,0),COLORFF00FF;
DRAWTEXT(JJP2,-15,'←买'),COLORFF00FF;
X1:=EMA(HHV(H,500),21);
X2:=EMA(HHV(H,250),21);
X3:=EMA(HHV(H,90),21);
X4:=EMA(LLV(L,500),21);
X5:=EMA(LLV(L,250),21);
X6:=EMA(LLV(L,90),21);
X7:=EMA((X1*0.558+X2*0.558+X3*0.558+X4*0.96+X5*0.96+X6*0.96)/6,21);
X8:=EMA((X1*0.55 +X2*0.55+ X3*0.65+ X4*1.25+X5*1.23+X6*1.2 )/6,21);
X9:=EMA((X1*0.68+ X2*0.68+ X3*0.68+ X4*1.3 +X5*1.3+ X6*1.3 )/6,21);
VARA:=EMA((X7*3+X8*2+X9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(C*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(L,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(C,58),1,0);
VAR11:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
MID:=REF(H+L,1)/2;
CR:=SUM(MAX(0,H-MID),N)/SUM(MAX(0,MID-L),N)*100;
出击:=IF(CR<60 AND VAR11>10,35,0),COLORGREEN;
攻击:=IF (VAR11>20,30,0),COLORYELLOW;
{加仓}
XC1:=(MA(C,80)-MA(C,13)/3);
XC2:= MA((C-XC1)/XC1,1);
XC3:=EMA(XC2,12)*0.7;
XC4:=EMA(XC2,3);
XC5:=IF(LLV(XC4-XC3,12)>0,0,-10);
XC6:=EMA(C,12)-EMA(C,26);
XC7:=EMA(XC6,9);
XC8:=2*(XC6-XC7);
加仓:=IF(XC5<0 AND CROSS(XC8,0),50,0),LINETHICK1,COLORBLUE;
出击加仓:IF((出击=35 OR 攻击=30 OR 加仓=50),30,0);
DRAWTEXT(加仓=50,35,'←加仓'),COLORBLUE;
做多:IF(ZDZK1>=ZDZK2,ZDZK1+2,ZDZK2),COLORRED;
做空:IF(ZDZK2-ZDZK1,ZDZK2,ZDZK1),COLORGREEN;

通达信出击加仓KDJ指标公式

 

相关文章