在线检测未来函数

通达信十二生肖主图指标公式

来源:Internet,编辑:股旁网,2015-11-01

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L-0.012,'一穿三'),COLORFF00FF;
STICKLINE(一穿三,OPEN,CLOSE,1,0),COLORFF00FF;
强势5:MA(C,5),LINETHICK1;
生命24:MA(C,24),COLORYELLOW,LINETHICK1;
MA90:MA(C,90),COLORRED,LINETHICK1;
DG1:=(CROSS(强势5,生命24));
DRAWICON(DG1,生命24,1);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
EMA3:=EMA(C,3);
DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),
LOW*0.99,' ∠45'),COLORFFFFFF;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORRED;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;
AA:=(REF(O,1)/REF(C,1)-1)*100>2.168 AND O<REF(C,1) AND C>O AND H>=(REF(C,1)+REF(O,1))/2
AND REF(V,1)>(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5 ;
半分位:=IF(AA,50,0);
DRAWICON(AA,LOW,1);DRAWTEXT(AA,1.01*LOW,'鱼'),COLORYELLOW,LINETHICK2;
BB:=(REF(O,1)/REF(C,1)-1)*100>2.168 AND O<REF(C,1) AND C>O AND H>=(REF(C,1)+REF(O,1))/2
AND REF(V,1)<(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5 ;
半3分位:=IF(BB,50,0);
DRAWICON(BB,LOW,1);DRAWTEXT(BB,1.01*LOW,'鼠'),COLORYELLOW
,LINETHICK2;
CC:=(REF(O,1)/REF(C,1)-1)*100>2.168 AND O>REF(C,1) AND C>O AND H>REF(H,1)
AND REF(V,1)>(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5 ;
半4分位:=IF(CC,50,0);
DRAWICON(CC,LOW,1);DRAWTEXT(CC,1.03*LOW,'猴'),COLORYELLOW
,LINETHICK2;
DD:=(REF(O,1)/REF(C,1)-1)*100>2.168 AND O>REF(C,1) AND C>O AND H>REF(H,1)
AND REF(V,1)<(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5 ;
半5分位:=IF(DD,50,0);
DRAWICON(DD,LOW,1);DRAWTEXT(DD,1.03*LOW,'羊'),COLORYELLOW
,LINETHICK2;
FF:= C>REF(H,1) AND C<O AND REF(V,1)<(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5 ;
半6分位:=IF(FF,100,0);
DRAWICON(FF,LOW,1.05);DRAWTEXT(FF,1.03*LOW,'鸡'),COLORYELLOW
,LINETHICK2;
HH:= C>REF(H,1) AND C<O AND REF(V,1)>(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5 ;
半7分位:=IF(HH,100,0);
DRAWICON(FF,LOW,1.05);DRAWTEXT(HH,1.03*LOW,'猪'),COLORYELLOW
,LINETHICK2;
ZZ:=C<O AND REF(CLOSE,1)>O AND (REF(CLOSE,2)/REF(C,3)-1)>1
AND V<(REF(V,1)*0.3) ;
半8分位:=IF(ZZ,100,0);
DRAWICON(FF,LOW,1.05);DRAWTEXT(ZZ,1.03*LOW,'狗'),COLORBLUE,LINETHICK2;
AAAA:=REF(C>O,3) AND REF(C>O,2) AND REF(C<O,1) AND C>O;
BBBB:=((REF(V,1)+VOL)/2<(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2>(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZF:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EE:=(ZF>=10)AND AAAA AND BBBB ;
DRAWTEXT(EE,0.99*LOW,'虎'),COLORYELLOW
;
STICKLINE(EE,OPEN,CLOSE,1.5,0),COLORLIBLUE;
AAAAAA:=REF(C>O,3) AND REF(C>O,2) AND REF(C<O,1) AND C>O;
BBBBBB:=((REF(V,1)+VOL)/2>(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2<(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZFFF:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EEEE:=(ZFFF>=10)AND AAAAAA AND BBBBBB ;
DRAWTEXT(EEEE,0.99*LOW,'蛇'),COLORYELLOW
;
STICKLINE(EEEE,OPEN,CLOSE,1.5,0),COLOR110077;
AAAAA1:=REF(C>O,3) AND REF(C>O,2) AND REF(C>O,1) AND C<O;
BBBBB1:=((REF(V,1)+VOL)/2>(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2<(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZFF1:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EEE1:=(ZFF1>=10)AND AAAAA1 AND BBBBB1 ;
DRAWTEXT(EEE1,0.99*LOW,'兔'),COLORYELLOW
;
STICKLINE(EEE1,OPEN,CLOSE,1.5,0),;
AAAA2:=REF(C>O,3) AND REF(C>O,2) AND REF(C>O,1) AND C<O;
BBBB2:=((REF(V,1)+VOL)/2<(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2>(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZF2:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EE2:=(ZF2>=10)AND AAAA2 AND BBBB2 ;
DRAWTEXT(EE2,0.99*LOW,'马'),COLORYELLOW
;
STICKLINE(EE2,OPEN,CLOSE,1.5,0),COLOR808000;
AAAA12:=REF(C>O,3) AND REF(C>O,2) AND REF(C>O,1) AND C<O;
BBBB12:=((REF(V,1)+VOL)/2<(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2<(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZF12:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EE12:=(ZF12>=10)AND AAAA12 AND BBBB12 ;
DRAWTEXT(EE12,0.99*LOW,'牛'),COLORYELLOW
;
STICKLINE(EE12,OPEN,CLOSE,1.5,0),COLORYELLOW;
AAAAA:=REF(C>O,3) AND REF(C>O,2) AND REF(C<O,1) AND C<O;
BBBBB:=((REF(V,1)+VOL)/2>(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2<(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZFF:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EEE:=(ZFF>=10)AND AAAAA AND BBBBB ;
DRAWTEXT(EEE,0.99*LOW,'龙'),COLORYELLOW
;
STICKLINE(EEE,OPEN,CLOSE,1.5,0),COLORYELLOW;
AAAAC:=REF(C>O,3) AND REF(C>O,2) AND REF(C<O,1) AND C<O;
BBBBC:=((REF(V,1)+VOL)/2<(REF(V,3)+REF(V,2))/2)*0.318 AND (REF(V,3)+REF(V,2))/2>(REF(V,4)+REF(V,5)+REF(V,6)+REF(V,7)+REF(V,8))/5;
ZCF:=((HHV(REF(H,2),REF(H,3))-LLV(REF(L,2),REF(L,3)))/LLV(REF(L,2),REF(L,3)))*100;
EEC:=(ZCF>=10)AND AAAAC AND BBBBC ;
DRAWTEXT(EEC,0.99*LOW,'豹'),COLORYELLOW;
STICKLINE(EEC,OPEN,CLOSE,1.5,0),COLORMAGENTA;

通达信十二生肖主图指标公式

 

相关文章