在线检测未来函数

通达信鳄鱼主图指标公式

来源:Internet,编辑:股旁网,2015-11-01

Y:=(HIGH+CLOSE+LOW)/3;
吻线:REF(SMA(Y,5,1),3),COLORGREEN;
齿线:REF(SMA(Y,8,1),5),COLORRED;
颚线:REF(SMA(Y,13,1),8),COLORBLUE;
VAR2:=H>=REF(H,1)&&H>=REF(H,2)&&H>REFX(H,1)&&H>REFX(H,2);
VAR3:=L<=REF(L,1)&&L<=REF(L,2)&&L<REFX(L,1)&&L<REFX(L,2);
DRAWICON(VAR2,1.02*HIGH,1);
DRAWICON(VAR3,0.98*LOW,2);
MA55:=MA(CLOSE,55);
☆上升:IF(MA55>REF(MA55,1),MA55,DRAWNULL),COLORMAGENTA;
★下降:IF(MA55<REF(MA55,1),MA55,DRAWNULL),COLORWHITE;
AO:=SMA(Y,5,1)-SMA(Y,34,1);
AC:=SMA((AO-SMA(AO,5,1)),5,1);
VAR4:=AO>REF(AO,1) AND AC>REF(AC,1);
VAR5:=AO<REF(AO,1) AND AC<REF(AC,1);
VAR6:=AO>=REF(AO,1) AND AC<=REF(AC,1);
VAR7:=AO<=REF(AO,1) AND AC>=REF(AC,1);
STICKLINE(VAR4, H,L,0,1),COLORRED;
STICKLINE(VAR4 AND C>=O,O,C,2.5,1),COLORRED;
STICKLINE(VAR4 AND C<O,O,C,2.5,1),COLORRED;
STICKLINE(VAR4 AND C<O,O,C,2.5,0),COLORRED;
STICKLINE(VAR5, H,L,0,1),COLORGREEN;
STICKLINE(VAR5 AND C>=O,O,C,2.5,1),COLORGREEN;
STICKLINE(VAR5 AND C<O,O,C,2.5,1),COLORGREEN;
STICKLINE(VAR5 AND C<O,O,C,2.5,0),COLORGREEN;
STICKLINE(VAR6 OR VAR7, H,L,0,1),COLORLIGRAY;
STICKLINE(VAR6 OR VAR7 AND C>=O,C,O,2.5,1),COLORLIGRAY;
STICKLINE(VAR6 OR VAR7 AND C<O,C,O,2.5,1),COLORLIGRAY;
STICKLINE(VAR6 OR VAR7 AND C<O,C,O,2.5,0),COLORLIGRAY;

通达信鳄鱼主图指标公式

 

相关文章