在线检测未来函数

通达信MACDYX指标公式

来源:Internet,编辑:股旁网,2015-11-04

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
红面积:IF(DIF>DEA,SUM(MACD,BARSLAST(CROSS(DIF,DEA))),DRAWNULL),NODRAW,COLORLIRED;
绿面积:IF(DIF<DEA,SUM(MACD,BARSLAST(CROSS(DEA,DIF))),DRAWNULL),NODRAW,COLORGREEN;
DRAWNUMBER(CROSS(DIF,DEA),DEA,REF(绿面积,1)),COLORGREEN;
DRAWNUMBER(CROSS(DEA,DIF),DEA*1.1,REF(红面积,1)),COLORLIRED;
DRAWNUMBER(DIF>DEA,MACD,BARSLAST(CROSS(DIF,DEA))+1),COLORRED;
DRAWNUMBER(DIF<DEA,MACD,BARSLAST(CROSS(DEA,DIF))+1),COLORCYAN;

通达信MACDYX指标公式

 

相关文章