在线检测未来函数

通达信短线用MACD指标公式

来源:Internet,编辑:股旁网,2015-11-05

DIF:EMA(CLOSE,7)-EMA(CLOSE,14),COLORCCFFFF;
MACD:EMA(DIF,3),COLORFF2400,LINETHICK2;
DEF:2*(DIF-MACD),COLORFFFF00,LINETHICK0;
STICKLINE(DEF>=0 AND DEF>=REF(DEF,1),0,DEF,2,1),COLOR7093DB;
STICKLINE(DEF>=0 AND DEF< REF(DEF,1),0,DEF,2,0),COLOR7093DB;
STICKLINE(DEF<0 AND DEF>=REF(DEF,1),0,DEF,2,1),COLORB87333;
STICKLINE(DEF<0 AND DEF< REF(DEF,1),0,DEF,2,0),COLORB87333;
ST:=IF(DEF>0 AND REF(DEF,1)>REF(DEF,2) AND DEF< REF(DEF,1),1,0);
SJ:=IF(DEF<0 AND REF(DEF,1)< REF(DEF,2) AND DEF>REF(DEF,1),1,0);
ZL:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),1,0);
ZC:=IF(CROSS(MA(C,20),C) OR CROSS(MA(C,60),C),1,0);
ZD:=IF(CROSS(MACD,DIF) AND DIF>0 AND MACD>0,1,0);
ZK:=IF(CROSS(DIF,MACD) AND DIF<0 AND MACD<0,1,0);

通达信短线用MACD指标公式

 

相关文章