在线检测未来函数

通达信趋势与压力画线主图指标公式

来源:Internet,编辑:股旁网,2015-11-09

STICKLINE(C>=O,H,L,0,0),COLORFFFFFF;
STICKLINE(C>=O,C,O,3,1),COLORFFFFFF;
STICKLINE(C<O,H,L,0,0),COLORB6B600;
STICKLINE(C<O,C,O,3,1),COLORB6B600;
A0:=(L+H+C*2)/4;
A1:=EMA(A0,14)COLORYELLOW,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(EMA(A0,20)-REF(EMA(A0,20),1))/REF(EMA(A0,20),1)*100;
G1:=BARSLAST(CROSS(A1X,0));
买入止损:REF(A0,G1),COLORWHITE,LINETHICK2;
脉冲:(A0-A1)/A1*100,NODRAW;
斜脉冲:(A0-REF(A0,1))/(A1-REF(A1,1)),NODRAW;
买入盈利:(A0-买入止损)/买入止损*100,NODRAW;
Y1:=REF(A0,G1)*1.1,COLORGREEN;
Y2:=REF(A0,G1)*1.2,COLORGREEN;
Y3:=REF(A0,G1)*1.3,COLORGREEN;
Y4:=REF(A0,G1)*1.4,COLORGREEN;
Y5:=REF(A0,G1)*1.5,COLORGREEN;
Y6:=REF(A0,G1)*1.6,COLORGREEN;
Y7:=REF(A0,G1)*1.7,COLORGREEN;
B1:IF(A1X>=0,买入止损,DRAWNULL),COLORFF1CAE,LINETHICK2;
B2:IF(A1X>=0,A1,DRAWNULL),COLORFF7F00,LINETHICK2;
①:IF(H>=Y1,Y1,DRAWNULL),COLORFF2400,LINETHICK1,DOTLINE;
②:IF(H>=Y2,Y2,DRAWNULL),COLOR3232CD,DOTLINE;
③:IF(H>=Y3,Y3,DRAWNULL),COLORE47833,DOTLINE;
④:IF(H>=Y4,Y4,DRAWNULL),COLORGREEN,DOTLINE;
⑤:IF(H>=Y5,Y5,DRAWNULL),COLORE47833,DOTLINE;
⑥:IF(H>=Y6,Y6,DRAWNULL),COLORGREEN;
⑦:IF(H>=Y7,Y7,DRAWNULL),COLORGREEN;

通达信趋势与压力画线主图指标公式

 

相关文章