在线检测未来函数

通达信天地会指标公式

来源:Internet,编辑:股旁网,2015-11-10

N:=1;
 XOPEN:=(REF(O,N)+REF(C,N))/2;
 XCLOSE:=CLOSE;
 XHIGH:=MAX(HIGH,XOPEN);
 XLOW:=MIN(LOW,XOPEN);
 VOLALITY:=MA(XHIGH-XLOW,8);
天高:MA(XCLOSE,5)+VOLALITY/2;
地厚:MA(XCLOSE,5)-VOLALITY/2;
 BU:=CROSS(XCLOSE,天高);
SEL:=CROSS(地厚,XCLOSE);
 VAR1:=BARSLAST(BU);
 VAR2:=BARSLAST(SEL);
 DRAWICON(REF(VAR1,1)>VAR2 AND VAR1=0,XLOW,1);
 DRAWICON(REF(VAR2,1)>VAR1 AND VAR2=0,XHIGH,2);
 STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2,0 ),COLORRED;
 STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XHIGH,XCLOSE ,0,0 ),COLORRED;
 STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XOPEN,XLOW ,0,0 ),COLORRED;
 STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2,0 ),COLORYELLOW;
 STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XHIGH,XOPEN ,0,0 ),COLORYELLOW;
 STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XLOW ,0,0 ),COLORYELLOW;
 STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XCLOSE ,XOPEN ,2,0 ),COLORGREEN;
 STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XOPEN ,XHIGH ,0,0 ),COLORGREEN;
 STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XCLOSE,XLOW ,0,0 ),COLORGREEN;
 STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XCLOSE ,XOPEN ,2,0 ),COLORBLUE;
 STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XCLOSE,XHIGH ,0,0 ),COLORBLUE;
 STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XOPEN,XLOW ,0,0 ),COLORBLUE;

通达信天地会指标公式

 

相关文章