在线检测未来函数

通达信量抓牛指标公式

来源:Internet,编辑:股旁网,2015-11-13

DRAWGBK(C>O,RGB(8,46,84),RGB(0,255,127),0,0,1);
DRAWTEXT_FIX(1,0.88,5,0,'~☆~昊轩炒股~☆~'),COLORRED;
N:=5;
P1:=80;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3,POINTDOT;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3,POINTDOT;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
异动:=CROSS(V2,REF(V2,1)*1.2) AND LONGCROSS(CLOSE,REF(C,1)*1.025,4) AND V/REF(MA(V,5),1)>2,COLORMAGENTA;
抓牛:C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND REF(MACD,1)<MACD ,COLORYELLOW,LINETHICK3,NODRAW;
GD:=DY2<REF(DY2,1) AND REF(DY2,1)<REF(DY2,2) AND REF(DY2,2)<REF(DY2,3) AND C>O AND VAR3>VAR5 AND C/REF(C,1)>=1.02;
GD2:=DY2<REF(DY2,1) AND REF(DY2,1)<REF(DY2,2) AND REF(DY2,2)<REF(DY2,3)AND VAR3>VAR5;
DRAWTEXT(CROSS(V2,REF(V2,1)*1.2) AND LONGCROSS(CLOSE,REF(C,1)*1.025,4) AND DDX/REF(MA(DDX,5),1)>2,0,'★'),COLORMAGENTA;
MACD:="MACD.MACD",NODRAW;
拐点:CROSS(C,VAR2) AND CROSS(C,VAR6) AND MACD<0 AND REF(MACD,1)<MACD ,COLORMAGENTA,LINETHICK3,NODRAW;
STICKLINE(抓牛=1,40,8,0.5,0),COLORBLUE;
DRAWTEXT(抓牛=1,20,'再抓牛'),COLORBLUE;
DRAWICON(抓牛,40,25);
STICKLINE(拐点=1,40,8,0.5,0),COLORMAGENTA;
DRAWTEXT(拐点=1,18,'拐点'),COLORMAGENTA;
DRAWICON(拐点,40,26);
{主升抓牛}
A:=CROSS(SMA(CLOSE,2,1),SMA(LOW,5,1));
A1:=(SMA(HIGH,21,2)*1.05)*1.05;
A2:=IF(A,A1,SMA(LOW,5,1));
A3:=CROSS(SMA(CLOSE,2,1),(SMA(HIGH,21,2)*1.05));
A4:=IF(A3,(SMA(HIGH,21,2)*1.05)*1.10,(SMA(LOW,21,2)*0.95));
A5:=A2>SMA(LOW,5,1) AND CROSS(C,REF(MA(C,13),13/2+1)) AND VOL>0;
A6:=REF(H/O<1.02,1) AND REF(C<O,1);
在主升抓牛:=A4>(SMA(LOW,21,2)*0.95) OR A5 AND A6;
DRAWTEXT(在主升抓牛,22,'---在主升抓牛'),COLORRED;
STICKLINE(在主升抓牛,40,25,1,0),COLORYELLOW;
STICKLINE(在主升抓牛,25,10,2,0),COLOR00FF00;
STICKLINE(在主升抓牛,10,0,2,0),COLORBLUE;
STICKLINE(在主升抓牛,25,15,0.5,0),COLORRED;
STICKLINE(在主升抓牛,15,6,1,0),COLOR00FF00;
STICKLINE(在主升抓牛,6,0,2,0),COLORBLUE;
DRAWICON(在主升抓牛,40,28);
{短牛}
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:=(MA(HHH,2)*3+HHH*13)/16,COLORFF00FF,LINETHICK1;
SS:=(MA(CCC,2)*3+CCC*13)/16,COLORFF00FF,LINETHICK1;
GG:=MA(HHH,5),LINETHICK1,COLORGREEN;
MM:=MA(CCC,5),LINETHICK1,COLORGREEN;
WW:=IF(QQ<GG,SS,MM),LINETHICK1,COLOR0000FF;
EE:=IF(SS<MM,GG,QQ),COLORFFFFCC,LINETHICK1;
买:=IF(EE-WW<5.6,200,0);
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED;
买AA:=黄金 AND RSVV<VARB2-2;
短牛:=买AA>0,COLORYELLOW,LINETHICK2;
STICKLINE(短牛,38,2,0.5,0),LINETHICK8,COLORYELLOW;
DRAWICON(短牛,38,30);
DRAWTEXT(短牛 ,28 , '短牛 '),COLORYELLOW;

通达信量抓牛指标公式

 

相关文章