在线检测未来函数

大智慧散户机构资金进出分时指标公式

来源:Internet,编辑:股旁网,2015-11-16

成交额:=V*C/100;{万元}
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((BARSTATUS=2),((100*A2)/A6),0);
A8:=IF((BARSTATUS=2),((100*A3)/A6),0);
A9:=IF((BARSTATUS=2),((100*A4)/A6),0);
A10:=IF((BARSTATUS=2),((100*A5)/A6),0);
机构买:(A2),LINETHICK3,COLORRED;
机构卖:(A3),LINETHICK3,COLORFFFF55;
机构进出:=机构买-机构卖;
散户买:(A4),COLOR5555FF;{细红线}
散户卖:(A5),COLOR55FF55;{细绿线}
强势:=((100*A2)/A6>50);
STICKLINE(强势,机构买*1.02,机构买*1.1,6,0),COLORYELLOW;
拉升:=((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买*1.1,机构买*1.2,6,0),COLORFF00FF;
{DRAWTEXT(BARSTATUS=2,机构买*0.95,'●机构买'),LINETHICK2,COLORRED;
DRAWTEXT(BARSTATUS=2,机构卖*0.95,'○机构卖'),LINETHICK2,COLORFFFF55;}
{DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买*1.02,'●机买'),COLORRED;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买*0.98,'○机卖'),COLORFFFF55;}
DD1:=1;
AAA1:='机构买'+(100*A2)/A6+'% ';
AAA2:='机构卖'+(100*A3)/A6+'% ';
AAA3:='散户买'+(100*A4)/A6+'% ';
AAA4:='散户卖'+(100*A5)/A6+'%';
DRAWTEXTREL(10,10,AAA1),colorred;
DRAWTEXTREL(100,10,AAA2),colorGREEN;
DRAWTEXTREL(200,10,AAA3),colorred;
DRAWTEXTREL(300,10,AAA4),colorGREEN;

大智慧散户机构资金进出分时指标公式

 

相关文章