在线检测未来函数

通达信MDI优化指标公式

来源:Internet,编辑:股旁网,2015-11-16

NOTEXT1:60,POINTDOT;
NOTEXT2:20,POINTDOT;
PDI:"DMI.PDI",DOTLINE,COLORMAGENTA;
MDI:"DMI.MDI",DOTLINE,COLORCYAN;
ADX:"DMI.ADX",LINETHICK2,COLORWHITE;
ADXR:"DMI.ADXR",LINETHICK2,COLORYELLOW;
空军战场:IF(MDI>REF(MDI,1) AND PDI<REF(PDI,1),ADX,DRAWNULL),LINETHICK2,COLORGREEN;
DRAWICON(空军战场>0,60,39);
红军战场:IF(MDI<REF(MDI,1) AND PDI>REF(PDI,1),ADX,DRAWNULL),LINETHICK2,COLORRED;
DRAWICON(红军战场>0,60,38);
出局:=REF(PDI,1)>60 AND REF(PDI,1)>REF(PDI,2) AND REF(PDI,1)>PDI;
DRAWTEXT(出局,PDI,'止'),COLORGREEN;
进场:=REF(PDI,1)<20 AND REF(PDI,1)<REF(PDI,2) AND REF(PDI,1)<PDI;
DRAWTEXT(进场,PDI,'启'),COLORRED;
顺势启动:=CROSS(ADX,ADXR),NODRAW;
DRAWTEXT(顺势启动,ADX,'顺'),COLORYELLOW;
DRAWICON(顺势启动,70,11);
逆势启动:=CROSS(ADXR,ADX),NODRAW;
DRAWTEXT(逆势启动,ADX,'反'),COLORYELLOW;
DRAWICON(逆势启动,70,12);
上攻:=CROSS(PDI,MDI),NODRAW;
回踩:=CROSS(MDI,PDI),NODRAW;
DRAWICON(上攻,PDI,1);
DRAWICON(回踩,PDI,2);
强势启动:=PDI>REF(PDI,1) AND PDI>ADX AND ADX>ADXR AND CROSS(ADX,ADXR) AND PDI>MDI AND EXIST(CROSS(PDI,MDI),3);
DRAWICON(强势启动,PDI,33);

通达信MDI优化指标公式

 

相关文章