在线检测未来函数

通达信主力进出轨迹指标公式

来源:Internet,编辑:股旁网,2015-11-17

K1:=IF(CLOSE>=REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW+CLOSE-REF(CLOSE,1),HIGH-OPEN+CLOSE-LOW);
K2:=IF(CLOSE<=REF(CLOSE,1),OPEN-LOW+HIGH-CLOSE+REF(CLOSE,1)-CLOSE,OPEN-LOW+HIGH-CLOSE);
DT:=VOL*K1/(K1+K2);
KT:=VOL-DT;
买量:=SUM(DT,3);
卖量:=SUM(KT,3);
DX:=EMA(买量-卖量,5)*VOL/CAPITAL*100;
STICKLINE(DX>0,0,DX,2,0),COLOR000088;
STICKLINE(DX>0,0,DX,2,0),COLOR0000AA;
STICKLINE(DX>0,0,DX,2,0),COLOR0000CC;
STICKLINE(DX>0,0,DX,2,0),COLOR0000EE;
STICKLINE(DX<0,0,DX,2,0),COLOR008800;
STICKLINE(DX<0,0,DX,2,0),COLOR00AA00;
STICKLINE(DX<0,0,DX,2,0),COLOR00CC00;
STICKLINE(DX<0,0,DX,2,0),COLOR00EE00;
YX:=BARSSINCE(DX)+1;
QM:=BARSLAST(DX<=0);
主力强买:IF(QM<0,YX,QM),COLOR00FFFF;
QM卖:=BARSLAST(DX>=0);
主力强卖:IF(QM卖<0,YX,QM卖),COLOR00FF00;
力度:(主力强买-主力强卖),COLORRED;

通达信主力进出轨迹指标公式

 

相关文章