在线检测未来函数

通达信个股DDX及选股指标公式

来源:Internet,编辑:股旁网,2015-11-18

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN))/5000;
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));
进出量:=买量+卖量;
今DDX:进出量,COLORRED,NODRAW,LINETHICK1;
昨DDX:REF(今DDX,1),COLORGREEN,NODRAW,LINETHICK1;
倍DDX:今DDX/昨DDX,COLOR00FFFF,NODRAW,LINETHICK1;
STICKLINE(进出量<0,0,进出量,1.9,0),COLORFF6600;
STICKLINE(进出量<0,0,进出量,1.4,0),COLORFF9900;
STICKLINE(进出量<0,0,进出量,0.9,0),COLORFFCC00;
STICKLINE(进出量<0,0,进出量,0.4,0),COLORCYAN;
{仿指南针 机构}
DC:=(2*CLOSE+HIGH+LOW+OPEN)/5;
EMDC:=EMA(EMA(EMA(DC,4),4),4);
AA3:= (EMDC-REF(EMDC,1))/REF(EMDC,1)*100, ;
BA:= MA(AA3,2);
机构:(AA3-BA)*30000,COLORRED,NODRAW;
昨机:REF(机构,1),COLORGREEN,NODRAW,LINETHICK1;
前机:REF(昨机,1),COLOR00FFFF,NODRAW,LINETHICK1;
STICKLINE(进出量>0,0,进出量,1.9,0),COLOR000099;
STICKLINE(进出量>0,0,进出量,1.4,0),COLOR0000CC;
STICKLINE(进出量>0,0,进出量,0.9,0),COLOR0000FF;
STICKLINE(进出量>0,0,进出量,0.4,0),COLORCC66FF;
{仿指南针 散户}
CC3:=EMA(CLOSE,5)-EMA(CLOSE,55);
DD3:=EMA(CC3,10);
散户:(CC3-DD3)*20000,COLORRED,NODRAW;
昨散:REF(散户,1),COLORGREEN,NODRAW,LINETHICK1;
前散:REF(昨散,1),COLOR00FFFF,NODRAW,LINETHICK1;
{用法:双方资金流向一致看涨}
{满仓}
MA2:=EMA(C,2);
MA5:=EMA(C,5);
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
YCX:=MA5>=REF(MA5,1);
H5:=MAX(MAX(MA5,EMA13),EMA30);
L5:=MIN(MIN(MA5,EMA13),EMA30);
一阳穿三线:= H5<C AND O<L5 AND YCX AND MA2>REF(MA2,1);
IF(一阳穿三线,18,0),COLORFFFF00,DOTLINE,LINETHICK1;
DRAWTEXT(一阳穿三线,10,'满仓'),COLORFFFF00;
{青云}
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
IF(FILTER(MR,10),-18,0),COLOR00FFFF,DOTLINE,LINETHICK1;
DRAWTEXT(FILTER(MR,10),-10,'青云'),COLOR00FFFF;
0,COLORCBCBC0;

{
选股公式:

MA2:=EMA(C,2);
MA5:=EMA(C,5);
EMA13:=EMA(C,13);
EMA30:=EMA(C,30);
YCX:=MA5>=REF(MA5,1);
H5:=MAX(MAX(MA5,EMA13),EMA30);
L5:=MIN(MIN(MA5,EMA13),EMA30);
一阳穿三线:H5<C AND O<L5 AND YCX AND MA2>REF(MA2,1);
}

通达信个股DDX及选股指标公式

 

相关文章